Video Screencast Help

IIS script maps must be properly configured for ASP.NET

Created: 17 Nov 2010 • Updated: 27 Apr 2011 | 14 comments
This issue has been solved. See solution.

I'm getting the IIS script maps must be properly configured for ASP.NET message when attempting to install ITMS 7.1 Beta. Here's the history so far.

- Installed the Beta successfully using a local administrator account
- Realized that the install was completed using a local account. Uninstalled the Beta.
- Deleted existing DB for the beta (on a remote SQL server).
- Rebooted beta server.
- Attempted to reinstall the beta. Received IIS message.
- Fix (And readiness refresh) unsuccessful.
- Uninstalled the partiall uninstalled beta. Rebooted.
- Uninstalled/Reinstalled IIS. Rebooted.
- Verified .NET installed and configured.
- Attempted to install the beta. Same result.

Any help that you can offer would be greatly appreciated.

Thanks!

Mike

 

Comments 14 CommentsJump to latest comment

Fabrice B M Raud's picture

Hello Mike,

 

As a workaround try to give the Network Service Account full control on the

"c:\Windows\Temp" folder.

 

Best regards

 

Fabrice

FABEMARA Consulting S.L.
Torrejòn de Ardoz (Madrid)

http://www.fabemara.es

http://assistance.fabemara.com

MikeLombardo's picture

Fabrice,

Thanks for the tip. Unfortnately, adding the rights did not effect the end result. I'm still stuck with the IIS script maps message.

Thanks,

Mike

IT_Knecht's picture

Hello,

I'm getting the same error while "installing" Altiris Client Mangement Suite. Are there any tricks/bug fixes or even working solutions to solve this problem?

I even tried the "EnableNextButton" trick, but as result the configuration fails.

 

Any help that you can offer would be greatly appreciated.

Thanks in advance.

SIM error.png
rpoag's picture

Have you tried removing IIS, .NET 3.5.1, rebooting, adding them back and trying again? Sometimes will kick it.  Do you get an error when you try to run the corrective action through the prereq checker?

Ryan Poag
Northrop Grumman
If your question has been resolved, please be sure to "Mark as Solution"! Thank you.

IT_Knecht's picture

No luck with removing IIS, .NET and reinstalling.

The only message displayed is, that the script maps will be changed with "yes/no/abort" dialouge. Then it tries the "fixing" and goes back to the overview.

rpoag's picture

Did you try clicking the button really hard?  :-)

Your error looks different from the other error reported. Object reference errors, when I have gotten them, have been resolved by restarting the installer. Do you have any proxy settings? They seem to cause issues.

Ryan Poag
Northrop Grumman
If your question has been resolved, please be sure to "Mark as Solution"! Thank you.

IT_Knecht's picture

The button is nearly broken ... out of frustration ...

And the Object reference error appears only, if i "skip" the readiness check with the "EnableNextButton" registry hack/fix whatever.

The question: is the IIS script map related to the Object reference error? If that's the case, fixing will hopefully solve the another error.

rpoag's picture

Don't hurt your mouse.  It is an innocent.

You need the prereq check to work. I think it registers .NET 2.0 asp extensions. You could try registering the extensions manually and see if the prereq checks feels better about things.

Ryan Poag
Northrop Grumman
If your question has been resolved, please be sure to "Mark as Solution"! Thank you.

Justin Inglett's picture

Hey All,

 

I have seen this issue a few times and it is caused by a few different things, but lets start with this first:

 

Have you checked to make sure that the user you are trying to install under is a part of the IIS worker processer group?

     - The group is IIS_WPG in windows server 2003 (I know you are running 2008 but just wanted to get the data out there for others that might not be running 2008)

     - The group is IIS_IUSRS in windows server 2008

  * This is one of the two things that happens when you do an aspnet_regiis -ga during the install. It adds the user the the group above as well as adding the user as the application pools Process Model's Identity, as seen below ~

IIS_IUSRS group:

 

 

 

Application Identity:

 

 

 

 

Let me know if this works out for you or not! If not I will send a few other things that can cause the issue.

 

Cheers

IT_Knecht's picture

@rpoag
But someone is to blame ...

I have tried to register the asp extensions via aspnet_regiis.exe and via text-to-keyboard -> result: nothing changed.

 

@Justin
The user was not member of IIS_IUSRS, but the checks still fails.

What is up next?

 

If everything fails, i will setup a new server and try it again ... long live the test site!

IT_Knecht's picture

So,

after a clean install of IIS (after removing everything related to IIS, kinda annoying) I got past the readiness check ... YEAH !!!

SOLUTION
rpoag's picture

Glad to hear something worked for you. I thought you already removed IIS previously and it did not help?

Ryan Poag
Northrop Grumman
If your question has been resolved, please be sure to "Mark as Solution"! Thank you.

IT_Knecht's picture

I removed and reinstalled the IIS several times now, but some traces were left behind.
This time I manually removed everything (folder, file, regkey) that were still present on the machine.

rpoag's picture

Excellent!  At least you got it working. Hopefully the rest of the install will go smoothly.

Ryan Poag
Northrop Grumman
If your question has been resolved, please be sure to "Mark as Solution"! Thank you.