Video Screencast Help
Give us your opinion and win with Symantec! Please help us by taking this survey to tell us about your experience with Symantec Connect, so that we can continue to grow and improve.  Take the survey.

ILO Inventory not populating for Servers

Created: 14 May 2014 • Updated: 14 May 2014 | 6 comments

Does anyone know if pcA is required to use the right click > iLO Power Management ? My servers (with working ILO) all say "Remote power management is not supported on hardware of selected computer."

I also noticed I get an informational entry in the logs when I try it:

The specified machine does not have valid pcA License (Workstation: {0}

Any idea why this wouldn't be working? It can't really be related to a pcA license right?

Operating Systems:

Comments 6 CommentsJump to latest comment

Igor Perevozchikov's picture

Hi,

please check these links about similar problem

Thanks,

IP.

  1. Don't forget that, first you can find an answer for your question in Knowledge base
  2. If answer solves your question, then please mark as solution to close a thread
Brandon's picture

I am not trying to use the WOL feature, just the ILO feature. These are ProLiant G6 and Gen8 servers that support ILO and I can get to the web interface for it manually. Opening up the interface from DS 6.9 always worked, but in 7.1 and 7.5 it does not.

SELECT * from vComputer vc
INNER join [Inv_iLO] ilo ON vc.guid = ilo.guid

This only returns 26 servers. Those 26 work with the right click ILO. In reality, this number should be a few hundred. So if there isn't a tie in to pcAnywhere for this, why wouldn't this ILO inventory be collected? The Full inventory policies are turned on and running.

Igor Perevozchikov's picture
  • As far as I see, these iLO actions are related to "Deployment Solution" product guid
  • Also found some old information about case when iLO doesn't work:
"ILo doesn't work. Integrated 
Lights-Out (ILo) power management works only when the correct version of the 
sm2user.dll file is installed. This DLL is installeed by HP and must be 
8.11.00.0 or later for ILo functionality in Symantec Management Plaform." 
  • Some information about how to get data in "Inv_iLO" table:
1.Install the Altiris agent and the Deployment Plug-in to a ilO capable 
client.
2.Do a send basic inventory so the NS could get all the information 
needed 
  1. Don't forget that, first you can find an answer for your question in Knowledge base
  2. If answer solves your question, then please mark as solution to close a thread
Brandon's picture

I haven't found any indication that sm2user.dll is still used for ILO3/4, but I am looking into that. Any idea which ILO component from HP this is part of? This is what I currently have on the server(s):

HP ProLiant iLO 3/4 Management Controller Driver Package for Windows Server 2008/2012 X64 3.8.0.0
HP ProLiant iLO 3/4 Channel Interface Driver for Windows X64 3.7.0.0
HP Lights-Out Online Configuration Utility for Windows 2003/2008/2012 x64 Editions 4.1.0.0
Online ROM Flash Component for Windows - ILO4 1.20

I did confirm the agents on the servers:
Symantec Management Agent 7.5.1675.2
Deployment Solution Plug-in 7.5.1602

For whatever reason the "Send basic inventory" still doesn't populate any information in Inv_ILO.

This machine still has a Dagent 6.9.490 on it pointing to a legacy 6.9 console and the properties for the machine in that console are fully populated in the ILO section. It seems just SMP 7.x isn't working.

Igor Perevozchikov's picture

Here is information from Deployment Solution help center in SMP Console:

  • About ILO power management
  • Deployment Solution

Integrated Lights-Out (ILO) power management lets you remotely manage HP servers. You can use ILO power management to effectively unplug and plug in a computer.

ILO power management works only when the correct version of the sm2user.dll file is installed. HP installs this DLL, and it must be version 8.11.00.0 or later to enable ILO functionality in Symantec Management Platform.

You can see the ILO capabilities of a specific server by using the Manage > Computers menu. Then, right-click a server name in your list and click the ILO Power Management option. From the resulting menu, you can turn on and turn off that computer. You can also click Interfaces to view the remote Web console interface for that computer.

For more information about ILO, see the HP Web site.

About sm2user.dll part of:

Other questions:

1) You've mentioned that 26 servers are returned Inv_iLO data and iLO works there:

  • Is there any difference between what OS have they? Otherwise these 26 servers have same OS as other servers, where iLO doesn't work or they have different Operating Systems?

2) Don't know does it make sense, but do other servers, where iLO isn't populated in Inv_iLO table, have    consumed DS license as other 26 servers, where iLO works?

3) Also if you have DS 7.5 HF6 installed, please take a look on this case about DS versions:

Thanks,

IP.

  1. Don't forget that, first you can find an answer for your question in Knowledge base
  2. If answer solves your question, then please mark as solution to close a thread
Brandon's picture

1) I have found no pattern for the OS's on the 26. I  have 2003 R2/2008/2008 R2 with entries. The firmwares also vary.

2) I recently re-applied our renewed licenses which added over one hundred spare licenses. I was waiting to follow up after that hoping it was a license inssue, but that does appear to be the problem.

I have opened a case with support to do some further investigating 07149113.