Video Screencast Help

Image cleanup errors

Created: 23 Aug 2007 • Updated: 21 May 2010 | 10 comments
Hi,
I have a question about Image Cleanup. The Job itself reports a status of 0 when completed but when i look in the log i have the following error:
 
8/23/2007 5:05:13 PM - Info bpdbm(pid=5356) image catalog cleanup         
8/23/2007 5:05:13 PM - Info bpdbm(pid=5356) deleting images which expire before Thu Aug 23 17:05:12 2007 (1187877912)      
8/23/2007 5:06:07 PM - Info bpdbm(pid=5356) processing client myclient         
8/23/2007 5:06:09 PM - Info bpdbm(pid=5356) deleted 1 expired records, compressed 0, tir removed 0, deleted 0 expired copies
8/23/2007 5:06:09 PM - Info nbdelete(pid=5632) deleting expired images. Media Server: media.com Media: E:\netbackup\backups    
8/23/2007 5:06:11 PM - started process bpdm (2360)
8/23/2007 5:06:11 PM - Critical bpdm(pid=2360) sts_get_lsu_prop_byname on LSU E:\netbackup\backups failed: 2060013 no more entries   
8/23/2007 5:06:12 PM - Critical bpdm(pid=2360) Invalid storage device: E:\netbackup\backups no more entries     
8/23/2007 5:06:13 PM - Critical bpdm(pid=2360) failure to open disk at path E:\netbackup\backups: plug-in reports error 2060013 no more entries
8/23/2007 5:06:14 PM - Error bpdm(pid=2360) volume E:\netbackup\backups does not exist or is not available.   
the requested operation was successfully completed(0)
 
The temporary diskstaging store has never been on E:\netbackup\backups but on F:\netbackup\backups. How do correct this issue? Running Netbackup 6.5 on a W2K3 server.
 
Thank you,
 
Kari

Comments 10 CommentsJump to latest comment

GoPhins!'s picture
I am encountering this issue.
 
Any ideas?
backem_up's picture

This solved it for me!  Thanks for the tip!

Amit Vats's picture

Hi All

 

Is this command

nbdelete -allvolumes -force

 

will remove the fragments only from the Disk Storage unit or it can affect my prod backup on the Tapes.

bumj1's picture

I had this problem before as well.  Here is a link to another Symantec technote that should also solve the problem.

 

http://seer.entsupport.symantec.com/docs/290907.htm

Amit Vats's picture

hi

 

I had tried creating dummy storage unit and used nbdelete also, but still image clean up is partial successful and giving me status  (47) host is unreachable and

 

<Date>08:35:38 - Info nbdelete (pid=22440) deleting expired images. Media Server:  Media: /tmp/test
<Date>08:35:38 - Error nbdelete (pid=22440) Fragments were not removed. Server  is invalid (37 )
the requested operation was partially successful (1)

Svetlana's picture

I had a similar issue after I modified storage unit and moved directory with all catalog backups to another drive. Even though catalog backups were written to the new location, Image Cleanup either failed or ended partially successfully running on both new and old locations.
2/15/2009 9:05:16 AM - Critical bpdm(pid=5544) sts_get_lsu_prop_byname on LSU F:\BACKUP_V2 failed: 2060013 no more entries 
2/15/2009 9:05:16 AM - Critical bpdm(pid=5544) Invalid storage device: F:\BACKUP_V2 no more entries  
2/15/2009 9:05:16 AM - Critical bpdm(pid=5544) failure to open disk at path F:\BACKUP_V2: plug-in reports error 2060013 no more entries
2/15/2009 9:05:16 AM - Error bpdm(pid=5544) volume F:\BACKUP_V2 does not exist or is not available. 

But after I created empty F:\BACKUP_V2 folder and let Image Cleanup run once, I deleted folder and now Image Cleanup doesn’t try to run on non-existing old folder.

Scott Murray's picture

Hello,

Just wondering if a resolution has been found to the thread entry by Amit Vats on 02-16-2009 ?

I have the same issue where the Job details indicate the Media Server name is blank - and the Error 47 - Host Unreachable appears.

If we look in the directory \Veritas\NetBackup\var\nbdelete, we also see a lockfile in there relating to a Media Server with a blank name.

All commands such as nbdelete, and bpimage -cleanup don't work. So I'm not sure where the nbdelete/image cleanup gets its Disk Storage Unit list from ?

If we check the EMM via nbemmcmd or with bpstulist, all is in order.

Any extra info appreciated.

Thanks.

Amit Vats's picture

Hi

 

Problem got resolved after support send the cleanup script which works at the SQL DB level of netbackup.

First SQL DB was dumped at temporary location , then cleansript was run , which had removed the images from the DB.

Now image cleanup commands are working fine .

Ajenda's picture

Disregard, this issue was now resolved.