Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Imaged E6510 losing domain info

Created: 17 Feb 2011 • Updated: 17 Feb 2011 | 5 comments

I've imaged a Dell E6510 with Win7-64bit Pro.  I have a job that joins the machine to our domain. Then I install the drivers, doing a Power Control/reboot after every install. In the midst of the reboots, somehow the machine loses its domain info and reverts back to being a member of the default workgroup "WORKGROUP".

Any ideas on how to prevent or correct this?

Comments 5 CommentsJump to latest comment

EdT's picture

What drivers are you installing after joining the machine to your domain? 

It occurs to me that installing different drivers for your NIC, for example, may reset any existing domain settings, or create a new "identity" for your NIC that is no longer associated with the settings previously established. You should be able to identify which driver is causing this issue by checking after each of your reboots.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

ConQuer0r 2's picture

The NIC driver is being installed via a batch file and the unattend file. Win 7 did not have any nic driver for it *E6510), so I copied one from Dell in the image job itself, and install as noted above.  The driver does not get changed.  One of the driver jobs does reinstall it using the same switches, though in this case it is not necessary.

The problem occurs even when no drivers are installed or changed, but when repeated reboots occur. I can recreate it with a test job I made for this purpose that sends 10-12 reboots in a row after re-joining it and doing the required reboot.

The rejoining can be via a job or manually. The error occurs with the multiple reboots.

EdT's picture

This is indeed odd behaviour.

Can you reproduce this by manually rebooting the machine 10-12 times in a row after rejoining the network?

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

bhawver's picture

At what point do you run the join domain job?  Directly after the imaging?  It's possible that the job is kicking off too soon while the Windows 7 machine is still processing either driver installs or a post configuration.  I've had this problem in the past and found that if I inserted a job/task prior to the configuration job with a script (with just the line "rem Place holder for configuration"), this seemed to correct my issue.  Also, personally, I would do any name change first, reboot, and then join it to a domain.  It seems to be more clean in our environment.

Brian Hawver
Systems Engineer
Yaskawa America, Inc.

Connect Etiquette: "Mark as Solution" those posts which resolve your problem, and give a thumbs up to useful comments, articles and downloads.

ConQuer0r 2's picture

Took a machine - Dell Optiplex 960, 4GB ram. Installed Win7-64bit (not SP1) from DVD.  Did NOT put an altiris agent at first. Got NIC working.  Machine was joined to the domain.  ran windows updates.  User was using it for work.

As a test, we put the DS agent and pushed a job that contained a single Power Control / Restart.  The machine rebooted three (3) times and lost domain info.

Unacceptable.