Video Screencast Help

Images missing in catalog recovery

Created: 16 Sep 2013 | 8 comments

Hi All,

I have recently upgraded from Netbackup 7.0.1 to 7.5.0.6 on Windows server 2008 R2, I can see all the images after upgrade. Then i took a catalog backup from 7.5.0.6 server which completed successfully with 0 status, however there was a warning showing in the logs reagrding TIR catalog backup.

I have tried to restore this catalog backup on another server in a test environement, test environment is clone of the production, having everything identical. I restored the catalog backup and it completed successfully with 0 status. But when i checked the images for different clients I found most of the images were missing and there were no incremental and differential images, backup policies were also not restored.

I have already applied this patch on both servers NB_7.5.0.6_ET3289890_1.zip is an Emergency Engineering Binary (EEB) replacement for bpdbm on NetBackup 7.5.0.6. But still not able to recover the full catalog with all the desired information.

 

Thanks

Operating Systems:

Comments 8 CommentsJump to latest comment

Mark_Solutions's picture

Are you sure the restore went perfectly?

No client images on the live site that use alternate locations for their images?

If policies were also missing it sounds like the catalog recovery did not work or that on the DR site NetBackup was not installed to the same location

I would double check everything and try again

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

GV89's picture

I m not sure how u perform catalog recovery...

But this should work..

Please try recovering it again...

NBU_UFO's picture

Mark thank you for your comments.

Netbackup is installed on at the default path both in live+test. I have all the images on the default path, we are not using alternate path for any image.

If the restore job is completing without any errors or warning, then its obvious its successfull.

I will try again and post the results.

Marianne's picture

Next time you test catalog recovery, please make a note of the log file (Recover#####).

This log will tell us what exactly was restored.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

mbreit1910's picture

I am at a DR exercise and I'm encountering this exact same issue.  We are running 7.5.0.6 on Windows 2008 R2.  Some servers have all image information and pull up fine in the BAR, but some, despite the full list of images displaying , I also get "Unable to obtain list of files using specified search criteria."  I have found one thing in common for all of the servers whose images are missing.  The computername is specified in caps for all of them.  (I know this sounds crazy, but 5 servers in the same policy, 3 have a capitalized host names and two are in lower case.  The 2 lower case servers are recoverable, but the three upper case servers have no images.)  If you have an update for this issue, I'd love to hear from you!

 

Marianne's picture

The 2 lower case servers are recoverable, but the three upper case servers have no images.)

 

Check the folder names under  ...\netbackup\db\images

What do you see? Upper case or lower case for the problematic servers?

Also check folders under client names. What do you see?

Please bear in mind that NBU is case sensitive. Best to be consistent as far as client names in policies are concerned.

Have you checked the the 'Recover###...' log file yet?

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

mbreit1910's picture

Thanks for the response. 

Unfortunately (or maybe fortunately) our DR exercoise is complete.  At the end of our test, I was able to run the catalog recovery a second time and all of the previously failing objects were now accessible.  The Recover### log provided no clues.  Support wanted me to recreate the problem with logging turned up, but the problem was not re-creatable. 

On our production system, the server names in the images folder are lower case, yet the actual image names are upper case (host name on server is specified in upper case).  From your comment, it sounds like we may run into problems due to our lack of consistency. 

We have another DR exercise in January.  Since I don't really have a root cause, all I can do is jack up logging before I attempt the initial catalog recovery in case we encounter the problem again.