Video Screencast Help

Imaging Windows 7 w/ Altiris 7.1

Created: 14 May 2013 | 5 comments

I'm trying to image Windows 7 using Altiris 7.1 and it is not working as intended.

I have created a custom unattend.xml file and have overwritten the one located at \nscap/bin/win32/x86/deployment.
I also have a SetupComplete.cmd that enables and renames the built-in Administrator account.

Here are the steps I take:

  1. Boot new PC into Audit Mode
  2. Configure and install applications
  3. Copied the Unattend.xml to windows\system32\sysprep
  4. Copied the SetupComplete.cmd to windows\setup\scripts
  5. Install Altiris agent and push a job containing:
  • Prepare for Image Capture (Options selected: Windows 7 Pro x86 SP1, Current Key, and Reboot to PXE)
  • Capture Image (Options selected: Ghost and Disk Image)
  • Reboot to Production

When it reboots, the Unattend.xml tells the system to automatically log in once. However, it doesn't log in and the administrator account is still disabled and there's no way to get into Windows 7.

I then...

  1. Remove all records of the PC from Altiris
  2. Reboot into Automation
  3. Push a job containing:
  • Deploy Image (Options selected: Current Key, deselected DeployAnywhere, Generate Sysprep)
  • Reboot to Production

I get the same results

I tried changing Sysprep Configuration from Generate to Custom pointing it to \nscap\bin\win32\x86\deploy and get the same results.

If I run the sysprep manually everything works as intended. This did work about 1-2 months ago on a previous PC and I'm not sure what changed, certainly the unattend.xml and the setupcomplete.cmd did not change.

Operating Systems:

Comments 5 CommentsJump to latest comment

Thomas Baird's picture

First, stop using Audit mode to configure the workstation.  Yes, I know that's how you get the administrative account to be copied over to the default profile.  But it's only one way, and it's un-necessary except in certain circumstances.  The default profile can be modified in other ways that is better on sysprep.

Second, the unattend you put in is going to be overwritten.

Let me suggest that you under-think this to start with, and then try to figure out what's missing.  We tried to think this process out pretty well for you, so you shouldn't have to work so hard to make a golden image, capture, and deploy it.  Try, for now, the following:

Build a PC to look like you want it.  Don't bother with Audit mode.

Install the agent.

Run the job you have to capture it.

Deploy it.

Keep it simple to begin with.  IF that doesn't work the way you want it to, find out what is missing, and let us know if we can figure out how to get it for you.  MOST of our customers don't ever use Audit mode, and the one that did had to do some fancy footwork to get things working.  He did, but see if you can avoid the pain.

My 2 cents.

Thomas Baird
Enthusiast for making things better!

Dan Vicente's picture

Please enlighten me on modifying the default profile, because every where I have read and heard (even by Symantec), it is not the suggested method and it too has its problems. I can't remember what they were now as I tried that method almost a year ago and something about it failed. I do vaguely remember one problem was that a lot/some of the settings/configuration are not applied to newly created profiles. Since then, I've been using this method and the process has worked up until this newer PC model.

This exact process worked for 5 different models previously. Either somethings is up with these newer models, or something had changed/malfunctioning with Altiris.

Thomas Baird's picture

There are limits to modifying the default profile this way, but I've only had 2 customers (you included) who ever complained about that, so it must not be TOO big.  Ah well.

I remember now what happened to our other customer that was doing this.  It wasn't the audit mode that broke things - it was the custom unattend mode.  They had some incorrect architectures specified in the unattend, and it was failing.  For instance, they had a mix/mesh of ia64 and amd64, or something like that, in the various sections.

After imaging is complete, before you reboot, browse to the windows\panther folder and look at the unattend in there.  Then reboot, and look at it again.  See if all the sections fired or not.  Maybe they didn't.  It might point to something wrong.  This is sort of how we found the other customer's problem.

Thomas Baird
Enthusiast for making things better!

Dan Vicente's picture

Thank you for your efforts. I found out that the SysAdmin just recently updated Altiris with a fix of some sort. Apparently this update overwrote the unattend.xml file on the server to it's default state as it no longer had a timestamp of 2012 but instead 2009. Which would makes since as to how this was working a week ago and not now.

I have now set all my imaging jobs to use unattend-cust.xml instead of the default unattend.xml or the Generate option so that it doesn't get overwritten with future updates again.

Thanks again!