Video Screencast Help

Implementing WinPE 4 into Altiris 7.1

Created: 11 Oct 2012 | 11 comments

After a few weeks of tinkering, I managed to get Altiris to work with WinPE 4 as a pre-boot environment. Thus far, this method only works for x64 winPE images, but I haven't run into any issues with any of the machines I've imaged with it.

Benefits of winPE 4:

- Embedded Powershell support (!)

- DISM support for TRUE hardware-independent imaging

 

I'm including basic instructions below -- please bear in mind that these instructions imply that you have already created your custom winPE 4 .wim (there are plenty of instructions online as to how to do this):

1. On each PXE server, you must change a line in \\<Package Server>\Deployment\Task Handler\bootwiz\oem\DS\winpe2\default.bdc

There's a line in this file entitled 

 

[Application]
Compress=True
 
This must be changed to False or it will not work.
 
2. In addition you must navigate to \\<Package Server>\Deployment\Task Handler\WAIK\Tools\PETools\amd64
 
Here, you must replace winpe.wim with your winPE 4 .wim file. I HIGHLY recommend backing up the original in case you want to switch back to winPE 2.1
 
 
Once these steps are complete, hit Recreate Preboot Environment in Create Preboot Configurations under Settings -> Deployment on the specific x64 PE you'd like to turn into winPE 4. 
 
I'd love to see how anyone else has fared attempting this. I wanted to share my success and am open to any comments.
Thanks for your time,
Will
 

Comments 11 CommentsJump to latest comment

BBC's picture

Hi Will,

Thank you very much for this post !

We still have DS 6.9 as production environment, but slowly transition over to 7.x and I'd like to see this implemented as well. A question here...

What size is the WinPE 4 you use? I created one myself and that was around 350 MB.Besides, have you spoken to Symantec support on that topic? I did and the general assumption is that 2.1 should do and WinPE 3 is more than sufficient. I'd be much interested in your experience with that and also how you integrate the agent (same as it is done for WinPE 3 I guess)?

Thanks, BBC

Will Nevis's picture

I think my winPE 4 .wim was around 325 MB, close to what you describe. Unfortunately, when I spoke to Symantec about it, the best answer they could give me is that 2.1 is the only supported version. Generally speaking, winPE 3 is generally sufficient since is also supports DISM calls, but the scripting is a little cleaner when you can use Powershell instead of VBScript. The built-in Powershell cmdlets for DISM provide some nice error feedback as well (e.g. lets you know which drivers don't get loaded for some reason).

 

Symantec has been pretty smoke-and-mirrors about how the agent gets integrated into the PEs. The bootwiz (something that you're probably familiar with in 6.9) still exists, but it's run in the background and it feels like you have less control over it in 7.1. If I had a more explicit process as to how that agent integration works, I could probably make the x86 version work.

Thomas Baird's picture

No smoke OR mirrors.  You can add your own apps to WinPE.  It's pretty easy.  Browse to \\server\deployment\task handlers\bootwiz\OEM\DS.  Under here, you'll find 2 environments - one for x64 and one for x86.  Under that you'll find a batch file we run on startup in PE (which we recommend you edit if you add apps.  For instance, I add a menu to my PE to make life a LOT easier).  You'll also find a Program Files in here.  Under Program Files you'll find Altiris, and voila - the agent!  Thar she be!

All BootWiz does is expand the default wim, toss stuff into it, including this stuff, some mods fow Windows and the drivers you add, and then recompress.  That's it.  No smoke, no mirrors.

Have fun editing!  We have a KB on this BTW.

Thomas Baird
Technical Solutions Architect @ www.xcendgroup.com
https://www2.gotomeeting.co

Will Nevis's picture

Thanks for this, Thomas! Could you link to the KB as well?

 

Thanks again,

Will

ManelR's picture

So ...

Do you suppose that using the integrated PE 2.1 (for example in DS 6.9) can be used for deploy a Windows 8 image? I've not tested it I'm only guessing ...

Probably, we need to replace the WAIK folder under C:\Program Files (x86)\Altiris\eXpress\Deployment Server with the new ADK (Assessment and Deployment Kit) for Windows 8.

Any tip would be very appreciated.

Thanks.

 

IT Systems Manager
LCFIB - Computing Lab
Barcelona School of Informatics
Universitat Politècnica de Catalunya - Barcelona Tech
Thomas Baird's picture

The version of PE should not matter for pushing an image of Windows 8.

That said, our agent doesn't yet support Windows 8, and DA doesn't yet support it, so you might have OTHER issues with a Windows 8 image.  If you want to run Sysprep manually, NOT have the agent, use our product to capture and deploy it, it should be fine, but don't do much outside of capture/deploy, because until v7.5 we don't have Win8 support.

Key words there: SHOULD work fine.  Not supported = not tested, but an image is an image is an image.

OH - you might have to lie though on what version of OS you're capturing.  Not sure how well that will work.  ;)  It'd be cool to find out though!

Thomas Baird
Technical Solutions Architect @ www.xcendgroup.com
https://www2.gotomeeting.co

Thomas Baird's picture

This is a GREAT article!  Thanks for posting!

Out of curiosity, why does the compression matter?  What happens if you leave compression on?

Thomas Baird
Technical Solutions Architect @ www.xcendgroup.com
https://www2.gotomeeting.co

Will Nevis's picture

I've found that when compression is turned on, bootwiz fails during the compression step -- I never figured out why. If it's turned off, bootwiz skips this step and everything seems to work alright (on x64, anyway).

 

-Will

EDIT: My guess is that since bootwiz uses the older WAIK tools, it doesn't play nice with the injection of the extra packages necessary for Powershell support. I'd be interested to replace the standard WAIK tools with the Windows 8 WAIK tools and see how bootwiz deals with it.

Thomas Baird's picture

One more note.  For those of you who do NOT want to use PE 4 and/or DISM (which I think we can make work in earlier versions as well - pretty sure I got it into 3.1), you can find out what drivers work and which do not by launching the image, and whether it fails or not, looking in the windows\panther folder.  Everything is logged in there for driver selection by Windows.  Pretty cool stuff.

Thomas Baird
Technical Solutions Architect @ www.xcendgroup.com
https://www2.gotomeeting.co