Video Screencast Help
Give us your opinion and win with Symantec! Please help us by taking this survey to tell us about your experience with Symantec Connect, so that we can continue to grow and improve.  Take the survey.

Import Software Fails on Large Packages (~4GB and bigger)

Created: 21 Aug 2012 | 13 comments

Has anyone else noticed an issue while trying to upload a working unattended installation to their NS if the package is larger (ie, 4GB or larger size) than a typical package (under 200-500MB usually)?

I remember over the past couple of years we had to do some work-arounds in order to get our Autodesk Inventor product package (anywhere from 4-8GB in size) ready for deployment. Some workarounds were either;

* Upload the files in batches (usually about ~1GB at a time) to eventually make up the 4-8GB Project.
***This had a lot of issues even still pushing in batches (made me wonder more about the amount of files rather than the total file size itself).
***Afterwards, the deployment job would still fail while clients tried to pull files from the Task Server (filenames were too long to copy down from server because of pathnames).

* Made a Self-Extracting EXE from the completed unattended installation msi
***Package Files were compressed to about 3GB in size to then deploy to clients and run the extractor before even running the setup files.
***Elliminated the pathname and filenames from being to long from the Task Server.

Although the self-extracting exe work-around is doing well for us we believe that there shouldn't be such an issue while trying to upload a larger package into the NS server. The whole process can take hours before finally erroring out for whatever reason (usually during the java portion of the upload that comes after pressing "Next >").

Last year it took us a while to determine that part of the issue was in the pathname & filenames being too long from the Task Server. The NS itself was ok being that all packages were pushed to the root of the drive (ie, E:\Packages\{GUID}\cache), where as the Task Servers pushed the files deeper into the system (ie, F:\Altiris\Altiris Agent\Package Delivery\{GUID}\cache").

Once we created the Self-Extracting EXE this took care of the "too long" issue on Task Servers, however, we still have issues uploading initially to the NS if the overall package is too big in filesize or possibly too many files to upload.

Any solutions, ideas, suggestions are appreciated. I will be opening a case with Symantec later today and more screenshots and details will be coming once I recreate this today (it shouldn't be hard since we can recreate it each year for this Inventor program).

Here are some more details regarding our Inventor package;

The above screenshot is what continuely fails duing an upload to the server. The screenshot below is of the properties from the Self-Extracting EXE created of the above screenshot that works on upload and deployment to clients.

Comments 13 CommentsJump to latest comment

Vanyun's picture

Below is some more information regarding the package upload issue we are experiencing;

Upload Began at 10:06am and errored out sometime between 12:00pm and 12:30pm.

Properties of a newly created GUID in our NS Package Share (does contain the AdminImage and Tools folders so we are looking at the correct upload);

NS Server Log Viewer shows the following error around the 12:00pm and 12:30 timeframe.

At this point it does appear to be placing the files onto the NS Package Share properly, however, it does not let us go to the next step of creating/assigning a Software Resource to the uploaded files.

andykn101's picture

Have you tried increasing the Software library timeout?

"Specify the maximum number of seconds to wait before a server timeout occurs when managing a package in the Software Library. Increase this value if you encounter problems when managing a package that contains large files."

Large packages I tend to upload in stages.

Authorised Symantec Consultant (ASC) with Endpoint Management Limited, an Authorised Symantec Delivery Provider based in the UK.

Connect Etiquette: Please "Mark as Solution" posts that fix your problem.

Vanyun's picture

This option didn't seem to make a difference. The process still errors out after the upload of the files. I'm saying "after" now rather than "during" due to the fact that I can navigate the NS Package folder and see a newly created folder with the appropriate file size leaving me to believe that the files are getting to the server ok but there's a disconnect between the finishing of the upload and moving to the software resource section.

Something to keep in mind about the timeout was that the java upload window(s) kept flasing data about calculating hash for each file and uploading each file so I don't believe the timeout would have been the cause but I'm glad that you reminded me to narrow it out as an option by attempting the change.

andykn101's picture

Is the Package resource created? Check Manage > All resources > Pacakge. If it is, check the resource Associations in Resource Manager for the Package Resource.

Check in the NS log when you get the error.

Authorised Symantec Consultant (ASC) with Endpoint Management Limited, an Authorised Symantec Delivery Provider based in the UK.

Connect Etiquette: Please "Mark as Solution" posts that fix your problem.

Vanyun's picture

You're reading my mind. I was actually checking that today but notice the above screenshot GUID does not exist.... but also, the folder that was screenshotted is also gone today. Perhaps there's a cleanup that runs and removes package uploads that never get assigned to a Software Resource?

I am in the process of re-uploading it again to more than likely receive the error again but this time I will be able to validate the folder GUID and then search immediately for it under All Resources.

RufusS's picture

Hi Vanyun,

have you tried to import the software from the NS and not via remote console?

we had the same problem with office 2010, I had to copy the files local to the NS and import from the console on the server it self.

Hope this helps,

Best Regards,

Rufus.

Vanyun's picture

I may try this today to kill some time but after the earlier attempts I am believing the files are reaching the NS fine but having an issue with the next step of creating/assigning a software resource to the package uploaded.

Vanyun's picture

In regards to trying to find the package (Manage > All Resources > Package) today I had actually good luck in the upload as it finished up and went on to the next phase as intended. The bad news is... settings-wise everything is the same as before and I could successfully re-create the issue before but today it is working.

After the upload on 8/23/2012 the next step of selecting a Software Resource did show up. Along with the proper filesize was on the NS Package Share.

I guess I get to try it at least once more now to try and re-create it or maybe move on until it breaks again... this suite of software is very frusterating at times.... indecision

Vanyun's picture

Well I was successful in re-creating the issue again today... not sure if that's really good or not yet though. But with the re-creation I was then able to browse All Resources and try to find the GUID provided from the uploaded folder to the NS Package Share (happens to be 6e93d36f-2c92-4987-a0d5-e41c6c76a1af this time around).

I had no luck locating it this way but I decided to open an exisiting package via resource manager and then replace the URL portion containing the GUID. This is what I found;

It shows up without a Name or Description but I can select Edit Package and see the files I selected for the upload. I am going to try and manually assign this package to a Software Resource and see if the files stick rather than go away overnight like they have been in the prior days of testing.

andykn101's picture

Can you manually assign a package to a Software Resource? How?

Authorised Symantec Consultant (ASC) with Endpoint Management Limited, an Authorised Symantec Delivery Provider based in the UK.

Connect Etiquette: Please "Mark as Solution" posts that fix your problem.

Vanyun's picture

From the Resource Manager (Manage > All Resources > Select Pacakge).

From here, you should see something in the left pane regarding Assign to Software Resource. From this step you can now create a new one or assign it to an existing software resource.

However, today I am looking for my "Test Autodesk" Resource that was created last week and I am not finding it. Also the physical files from the NS are once again gone and the original GUID of 6e93d36f-2c92-4987-a0d5-e41c6c76a1af no longer appears in our Resource Manager.

This leaves me to believe that even manually assigning the package to a software resource will not stop the clean up process that must be happening on the NS.

Dmitri Dragunov's picture
Hello,
 
Which version of Software Management Solution and Software Management Framework do you have?
 
Where is located the software library shared folder?  perhaps you have some connection issues? 
Vanyun's picture

Software Management Solution 7.1.7580
Software Management Framework 7.1.8280

Software Library Shared Folder: "E:\Pacakges" of the NS

As far as physical connections, the server continuely pings throughout the process from the client trying to upload the files. The NS Task Manager also does not show any taxing to the server for resources during the process (cpu, memory, network related).