Video Screencast Help

Import Software - Specified Directory does not exist

Created: 09 Nov 2012 • Updated: 13 Nov 2012 | 3 comments
This issue has been solved. See solution.


I a working on creating a software release package in Altiris Client Management Suite 7.1. In this case, I wish to access the software (AutoCad in this case) installation files from a network location via UNC.  I browse to the location using the "Access package from an existing UNC" option via the Import Software: Specify Software wizard in the Symantec Management Console. My problem is that I keep getting a "The specified directory does not exist" prompt (see attached screenshot). I would naturally think that this would be a permissions issue however I have no problems accessing the same location using Windows Explorer. Additionally, I have also tried mapping a drive letter to this network location and then chooising the option "access package from a directory on the Notification Server" in the Import Software wizard, and then selecting the mapped drive, however I get the same "specified directory does not exist" prompt.

Any insight as to why this would be occuring. There are other network locations that I don't seem to have this issue. To ensure that it is not a permissions issue, we have granted the account we use for the SMP server full rights to the folder on the network which I want to access via the Software Import wizard however this did not work either. Like I said, it shouldn't be a permissions issue as there is no problem accessing the share via Windows Explorer from the server. We have Altiris installed on a virtal Windows Server 2008 Standard R2  

Comments 3 CommentsJump to latest comment

MyITGuy's picture

Does the service account used by the Symantec Management Platform server have access to the remote path?

MyITGuy | Automating your life to make my life easier.

Dmitri Dragunov's picture


You should ensure that UNC is in the same or in the trusted domain with NS(or has read access for everyone and can be accessed from explorer without prompting the password).
You able to open UNC via Exprorer because it has password cache. You can remove credentials from cerdential manager (Control Panel -> User Accounts -> Credential Manager).
Greg_Vic's picture

That's exactly what the problem was. I removed the cached credential and then found that the server did not have access to the share. Once we gave the server access, all is good.

Thank you very much for the tip!