Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

imported media not showing up on bpmedialist

Created: 09 Jul 2012 • Updated: 10 Jul 2012 | 13 comments
This issue has been solved. See solution.

Good morning,

Linux master, media and clients.  7.1.0.4

I ran the two stage import process for some media over the weekend.  It all completed with no problems..

"01:34:55 INF - Imported 717 of 717 images successfully."

I wanted to confirm the media kb count and images matched but it doesn't appear with bpmedialist

bpmedialist -m AAA390
requested media id is not assigned to this host in the EMM database
 
I can find the data to restore from, and it shows up with nbemmcmd but not bpmedialist.  Anyone got any ideas?  I have a fair few of these to work thru *sigh* so would be nice to know if there is an issue to resolve.
 
root@nbmaster: nbemmcmd -listmedia -mediaid AAA390
NBEMMCMD, Version:7.1.0.4
====================================================================
Media GUID:                     d2e4e2c4-845f-1dda-8522-8e7b7c6c1b39
Media ID:                       AAA390                              
Partner:                        -                                   
Media Type:                     DLT2                                
Volume Group:                   001_00001_TLD                       
Application:                    Netbackup                           
Media Flags:                    1                                   
Description:                    Omega SDLT600 Archive Med           
Barcode:                        AAA390                              
Partner Barcode:                --------                            
Last Write Host:                NONE                                
Created:                        03/09/2007 08:41                    
Time Assigned:                  05/26/2005 18:19                    
First Mount:                    03/30/2007 09:36                    
Last Mount:                     07/09/2012 01:33                    
Volume Expiration:              -                                   
Data Expiration:                INFINITY                            
Last Written:                   -                                   
Last Read:                      07/09/2012 01:33                    
Robot Type:                     TLD                                 
Robot Control Host:             nbmaster        
Robot Number:                   1                                   
Slot:                           563                                 
Side/Face:                      -                                   
Cleanings Remaining:            -                                   
Number of Mounts:               732                                 
Maximum Mounts Allowed:         0                                   
Media Status:                   IMPORTED MPX                        
Kilobytes:                      381729805                           
Images:                         774                                 
Valid Images:                   774                                 
Retention Period:               9                                   
Number of Restores:             0                                   
Optical Header Size Bytes:      1024                                
Optical Sector Size Bytes:      0                                   
Optical Partition Size Bytes:   0                                   
Last Header Offset:             0                                   
Adamm Guid:                     00000000-0000-0000-0000-000000000000
Rsm Guid:                       00000000-0000-0000-0000-000000000000
Origin Host:                    nbmaster               
Master Host:                    -                                   
Server Group:                   -                                   
Upgrade Conflicts Flag:                                             
Pool Number:                    29                                  
Volume Pool:                    shell_bkup                          
Previous Pool Name:             -                                   
Vault Flags:                    -                                   
Vault Container:                -                                   
Vault Name:                     -                                   
Vault Slot:                     -                                   
Session ID:                     -                                   
Date Vaulted:                   -                                   
Return Date:                    -                                   
====================================================================

Comments 13 CommentsJump to latest comment

mph999's picture

Firstly, move that media into a non-used volume pool sharpish - it is potentailly at risk of being overwritten.

Martin

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
Andy Welburn's picture

https://www-secure.symantec.com/connect/forums/imp...

Strangely images could be reported on after a Phase I but not after a Phase II - altho' they could still be restored.

(not clear whether this was just for importing BE tapes tho' - well it was nearly a year ago!)

Marianne's picture

Something weird in nbemmcmd output:

Last Write Host:                NONE                                
Created:                        03/09/2007 08:41                    
Time Assigned:                  05/26/2005 18:19                    
First Mount:                    03/30/2007 09:36                  
 

The Last Write Host normally indicates the media ownership.

I also find the Time Assigned of 05/26/2005 and created and first mount in 2007 a bit confusing.....

Media Status is                 IMPORTED MPX  
which will prevent tape from being considered for backups.

Have you been able to change pool although media is assigned?

Has this tape been in the environment since pre-6.x days with possible database inconsistencies that were never fixed?

You could possibly assign ownership to nbmaster with something like this:

bpmedia -movedb -m AAA390 -newserver nbmaster

Also consider running nbcc and submit output to Symantec Support for consistency check.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

sshagent's picture

These tapes are from 2005, and i joined the company in 2007.  The environment they are from looks like it was 5.16.

It is possible that an import might have been tried before, i was certainly asked to do so when i first joined the company but had more pressing thigns to do.  

The first mount date you mention does suggest the tape has been in the machine before so perhaps some old import has caused some db incosistencies as you suggest.  

mph999's picture

OK, got stuck on something ...

Think between us we have agreed it's broken ...

My thoughts, nbemmcmd thinks it's assigned, bpmedialist thinks it isn't (it doesn't appear).

So, is it, or isn't it ...  at the moment, no idea ....

This however is odd

Created:                        03/09/2007 08:41                    
Time Assigned:                  05/26/2005 18:19                    
First Mount:                    03/30/2007 09:36  
 
The created / assigned time would be when the tape is added to the system via the inventory.
The assign time can be in the past, as this will be set to the earlist image on the tape.
 
Here is a tape I just imported.
 
Last Write Host:                womble
Created:                        06/20/2012 09:24
Time Assigned:                  07/03/2012 09:40
First Mount:                    06/20/2012 10:36
Last Mount:                     07/09/2012 16:44
 
The tape  WAS NOT deleted from my server, just expired.
 
The created/ first mount  time is when the tape was added to the volume DB via the robot inventory, this was 20 June, which is about right from memory.  For you, this data would, I expect be today, IF the tapes were added to the library today and had never been on the system.
 
The assign time will equal the earliest image on the tape, or the earlest image on the tape.
 
So in fact,  this setup of dates you have is odd, but quite possible :
 
 
Created:                        03/09/2007 08:41                    
Time Assigned:                  05/26/2005 18:19                    
First Mount:                    03/30/2007 09:36  
 
Consider this ...
 
The tape was expired and then deleted from the system.  It was added to the system via inventroy on 03/09/2007.  This would create the 'Created date'
 
It was imported on 03/30/2007.
 
It was then ONLY expired. 

When you imported it again you would not have changed the dates any further.

However, that doesn't explain the Last write host ...

**********************

Test

here is a tape I expired, then readded to the robot, only a created date.

Last Write Host:                NONE
Created:                        07/09/2012 17:01
Time Assigned:                  -
First Mount:                    -
Last Mount:                     -
 
 
Then I run a phase 1 import on it ...
 
Created:                        07/09/2012 17:01
Time Assigned:                  07/03/2012 09:40
First Mount:                    07/09/2012 17:02
Last Mount:                     07/09/2012 17:02
 
Not sure why it isn't in bpmedialist yet ...
 
Martin
 
 
Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
sshagent's picture

Thanks for your thoughts and efforts, just to add to your above comments that its unlikely it expired if previously imported as the retention is set for "infinite" ( Yes very daft i know, but that is a continuing arguement i've had for all 5 years i've been here ).

My bpmedia type commands are very sluggish as well, so i wonder if some kinda timeout occured for whenever the import process adds to the bpmedialist data.  But then you'd expect errors to well, error :)  Its an odd one.

mph999's picture

The reason bpmedia list isn't working is that the Last Write Host isn't set.

This has to be set along with an assign time.

"..... its unlikely it expired if previously imported as the retention is set for "infinite" 

-true, but how do we know it wasn't manually expired ...

Perhaps not likey, but I was showing one way that the dates could be explained,

I would be tempted to expire the media and reimport.

Martin

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
sshagent's picture

A retry seems most logical.  I did import a tape from the same set previously and that went fine.  

Importin is just soooo slow.  Thanks for your assistance anyway, i'll get to importing

Marianne's picture

If the previous import was successful, another attempt should be quick with:
Found image...
Found image...

If you are importing using the GUI, please copy all text in the Results tab and post it here.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

sshagent's picture
Import didn't find anything
 
Import phase 2 started Tue Jul 10 10:26:02 2012
10:26:15 INF - Found no images matching the selection criteria that were ready for phase 2 import

Have been looking and reading more stuff and found this...

http://www.symantec.com/business/support/index?page=content&id=TECH58277

There it mentions...

2. Determine if the media ID exists in the merge table.  If the media ID appears in this listing, then a different issue exists - do not proceed further.  Contact Symantec Technical Services for assistance with getting this media ID out of the merge table.  The following example shows no media IDs in the merge table:
nbemmcmd
 
Unix/usr/openv/netbackup/bin/admincmd/
 
Windows<Install_dir>\NetBackup\bin\admincmd
 
 
Command syntax example and output:
 
nbemmcmd -listmedia -mergetable
 
 
The following number of records were found:0
 
Command completed successfully.
 
 

...running that command shows this specific tape plus 4 or 5 other tapes in a similar state.  Doh.  Anyone know the details of how to fix this merge table...or do i really need to use symantec support ( haven't used them in many years, so would presumably need to jump through some hoops to get that sorted )

 
mph999's picture

Hmm, the old merge table ...

http://www.symantec.com/docs/TECH44057

Martin

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
SOLUTION
sshagent's picture

Thats seems to have done it.  Thanks for your time :)

Strangely have lost 1 second on the expiration time, but if these tapes are about by 2037 ( or me for that matter ) i'll eat them myself.

Once i've merged the others i'll go and run the nbcc, haven't done a consistency test for many years so probably worth the effort.