Video Screencast Help

Index won't start after upgrade to EV 10.0.3

Created: 10 Feb 2013 • Updated: 22 Feb 2013 | 14 comments
Sarah.Seftel's picture
This issue has been solved. See solution.

Hi all,

interesting issue I've just faced:

Upgrade to EV 10 SP3, after upgrade of directory DB and storage DB, I started the Index service and got the following error:

Event 41312 : The Indexing Service could not complete all the required startup routines: Enterprise Vault Server Cache is not configured for this computer. Service will be stopped. 

since index service is not working, I bypassed the issue by doing the following:

Logged in to SQL, opened ComputerEntry db (from EnterpriseVaultDirectory) in edit mode, and entered cache location manually.

Closed SQL, started indexing service - came up and continued with Indexing upgrade smiley


BTW - I know for sure that this issue did not accrue in upgrade to EV 10 SP1.

Would consider adding the cache location issue to the deployment scanner so it will alert prior to the upgrade...


Comments 14 CommentsJump to latest comment

Rob.Wilcox's picture

You could also do this in the VAC, if the Admin + Directory service will start.  It's on the properties of the 'Computer'.

Sarah.Seftel's picture

you are totally right smiley

I guess I wasn't thinking of bringing the VAC up while services don't go up properly smiley

Next time! (hopefully not)

But it should be addressed by Symantec anyways I think...

Baris Aydogmusoglu's picture

Hello Sarah,

Could you check the cache location from Vault Admin Console please.

I attached a screenshot to this post.

ty, regards

Screen Shot 2013-02-10 at 9.41.11 PM.png

Senior System Expert

Microsoft Exchange Server

Symantec Enterprise Vault

Sarah.Seftel's picture


I didn't ask for solution, I just shared information of issue that can happen when upgrading to EV10.0.3 when no vault cache location defined prior to the installation... smiley

I solved it already.

Baris Aydogmusoglu's picture

Ahh i misunderstood than. So sorry.

Good days.


Senior System Expert

Microsoft Exchange Server

Symantec Enterprise Vault

Rob.Wilcox's picture

I'd suggest that you add the comment to the IDEAS section of the Connect Forums.  And for completeness:

In EV 10.0.2 .. No Cache Location (removed via SQL)
Error 11/02/2013 09:39:02 Enterprise Vault 41312 Index Admin Service 
The Indexing Service could not complete all the required startup routines: Enterprise Vault Server Cache is not configured for this computer. Service will be stopped. 
When you try to start the indexing service.
Deployment Scanner from 10.0.2 (that's the full scanner):
* Doesn't complain at all.
DS from inside the 10.0.3 Setup....
* Doesn't complain at all.
So the 'request' or 'enhancement' or 'idea' (whatever term you'd like to use :)) would be to get Deployment Scanner to pick up on this requirement to have the Cache Location specified.. because currently it doesn't.
Bruce Crankshaw2's picture

I am not sure if the Deployment scanner's purpose is for that? Various EV  documents clearly state that a Cache location is needed for Indexing, see below from the Admin Console documentation and having a Cache location is a prerequisite for EV 10?

"Each Enterprise Vault server that hosts an Indexing service requires a server cache. You must specify the server cache location on the Cache tab of the computer properties for the Enterprise Vault server"

My  understanding of the Deployment Scanner is that it checks for prerequisite software on the server and relevant permission but it can't interrogate SQL tables, also if this was a new installation what would it check for on SQL? There wouldn't be any tables as EV wouldn't be installed yet?


Sarah.Seftel's picture

I would say that I don't completely agree on that issue.

Say I have a customer who don't use anything regarding cache. no vault cache enabled, no virtual, they didn't put cache location in the server properties.

I didn't installed the system, I came there to do the upgrade.

I run deployment scanner, and according to results - I have a green light to upgrade.

Finished upgrading - Indexing service won't start since no cache location in defined.

since it's an upgrade and not a fresh install, I did not read the administration guide, and clearly didn't go through each and every tab in the EV console.

So as I see it - this is an issue that needs to be addressed by Symantec. If upgrade cannot succeed due to the missing cache location in DB - please let me know prior to the upgrade.

As I mentioned before - cache location absence was not needed to 10.0.1 upgrade, so what's changed?

And if you changed it - please notify me - with the deployment scanner results if possible.

Rob.Wilcox's picture

I agree, for a new install...  but.... 

Deployment Scanner is run as part of an upgrade too..  And it does ask for the SQL server to talk to, and it does check 'Connectivity', 'Permissions', 'Compatibility Level'...  which would all surely require logging into SQL.

Deployment Scanner you're right checks for pre-requisite software...  but also more than that.

Nathan Clark 2's picture

Would consider adding the cache location issue to the deployment scanner so it will alert prior to the upgrade

yes i personally think it should be added and would be easy enough to do, I will log it.

JesusWept3's picture

My two cents is the regular deployment scanner it shouldn't be a part of, because then it becomes yet another yellow mark on the list like missing lotus domino gateway

If anything it should be added to the mini DS on installation as part of the set up routine

But honestly, what does it matter?
If you're upgrading to ev10, reading the documentation will show that you need to set up this location, if you're already on ev10 the cache location exists

And then If you try and start the indexing service and it tells you right there and then to set shouldn't really be treated any differently than the vault cache build locations etc

EV's picture

This could be argued either way on the deployment scanner but the bottom line is that as of the  EV 10 base release, the EV Server Cache area can be used by the Indexing Engine. Excerpt from the Indexing Bulletin (Aug 2011)

In EV10, the Server Cache area now contains index results when processing searches where more than 1,000 results are retrieved. As a typical rule of thumb, expect 150 – 400 IOPS per index server for the Server Cache area. For Vault Cache and Accelerator environments the server cache area should be able to support 1,000 IOPS.

This is also found in the EV 10 Best Practice - Enterprise Vault 10 Indexing (September 2011) document