Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

The initial deployment menu is not showing

Created: 06 Feb 2014 • Updated: 10 Feb 2014 | 9 comments
This issue has been solved. See solution.

Hi,

My company is currently using Altiris DS 7.1.

I'm trying to deploy an image to a computer which doesn't have an OS installed. When I booted it to PXE, the initial deployment menu is supposed to be showing up, but it didn't. The computer booted to PXE successfully, and got minint-vp0atg4 as its computer name, then nothing happened. There is another thing I want to point out, the computer(minint-vp0atg4) could not be found in DS console.

I looked for some solutions on the internet, but none of them worked for me.

I tried to stop the SBS services, and deleted all files from SBS store folder, and then restarted SBS services. I also tried to run the resource memebership update. It still didn't work.

I'm very new to Altiris DS. Could anyone tell me if I was doing something wrong? Thanks.

Operating Systems:

Comments 9 CommentsJump to latest comment

SK's picture

Have you configured PXE for unknown computers, as well as added tasks to the "Symantec Console > Settings > Deployment > Initial Deployment" page?

Connect Etiquette: "Mark as Solution" those posts which resolve your problem, and give a thumbs up to useful comments, articles and downloads.

kzhang's picture

Hi SK,

Thanks for your reply.

I have already configured initial deployment settings, and added a few jobs to the initial deployment menu. I also checked the "Response to unknown computers" option in PXE configuration.

After that, however, all the computers in my company was booting to PXE automatically once they got IP addresses from DHCP server. I had to uncheck "Response to unknown computers" option in PXE configuration in order for computers to boot to Windows OS instead of PXE.

Do I really need to check that option?

SK's picture

If you are not using the pre-defined computers feature, then yes, you will need to enable that option in order for PXE to respind to unknown computers.

"all the computers in my company was booting to PXE automatically once they got IP addresses from DHCP server."  This indicates that they are not being managed by the SMP yet, correct?

Connect Etiquette: "Mark as Solution" those posts which resolve your problem, and give a thumbs up to useful comments, articles and downloads.

kzhang's picture

Hi SK,

Thanks for your reply. Those computers booting to PXE automatically are currently managed by SMP. I deleted all sbs files from the SBS store folder, that probably caused this issue.

Klim_Belchev's picture

Maybe the computer is already known to DS but under another name...

Try to look it up by its IP Address.

Hope this helps.

SOLUTION
kzhang's picture

Hi Klim,

That is what I'm thinking, the computer might be already known to the DS.

Question is, does DS record a computer by its IP address or its MAC address?

I couldn't find any computer with name as "minint-*". I don't think the computer has communicated with NS properly. Is there any way I can check on this?

SK's picture

If the computer was known to the SMP, then they would not get the initial deployment job.

minint- is a temp winpe name. 

Connect Etiquette: "Mark as Solution" those posts which resolve your problem, and give a thumbs up to useful comments, articles and downloads.

Klim_Belchev's picture

When in preboot you can do:

ipconfig  - it will give you the local IP of your client.

netstat /b - it will show you active connections. You should see here connections to your NS and Site Server

taskmgr - check that PECTAgent.exe is running at all.

kzhang's picture

I managed to get it worked after deleting the computer with the same IP address from the DS console. Thank you guys for your input.