Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

Injecting 7.1 agent into 6.9 image?

Created: 30 Oct 2012 • Updated: 01 Nov 2012 | 4 comments
This issue has been solved. See solution.

Is there a way to inject the 7.1 agent into an existing 6.9 image, instead of having to deploy the 6.9 image, install the 7.1 agent, and recapture?  The reason I ask is because we have quite a few existing images from 6.9.

I believe that I saw this referenced in one thread by ThomasBaird, but never saw any additional details.

Comments 4 CommentsJump to latest comment

andykn101's picture

I suppose you could create a batch file to install it with an "IF NOT EXIST", and then open the image and just add that to startup and the source files into the image.

The create a policy in altiris to delete the batch file.

Edit: I'd just have a DS Job to do it after I'd imaged the target PC.

Authorised Symantec Consultant (ASC) with Endpoint Management Limited, an Authorised Symantec Delivery Provider based in the UK.

Connect Etiquette: Please "Mark as Solution" posts that fix your problem.

boonet's picture

He had mentioned that there was a pre-existing VBS script out there that could accomplish this.  Any ideas?

md investigate's picture

Hi boonet,

there is an official howto for installing the new sma: http://www.symantec.com/docs/HOWTO36080  Maybe this helps a bit.

It's important to remove the old Agents (Aclient, Dagent). As andykn101 mentioned a run once skript in the startup menu will satisfy your need.

The "clean" method is to deploy the old image, remove old agents, install new ones and recapture the image.

Regards

SOLUTION
boonet's picture

Thank you md investigate.  That pos was very helpful.