Video Screencast Help

the installation directory (including the OS prompt) is too long.

Created: 24 Jul 2014 | 7 comments

I am pushing the Agent to some Linux machines and I ran into a problem today were one fails because the prompt is too long? How can I get around this?

 

Unable to use key file "" (unable to open file)
Using username "root".
Last login: Wed Jul 23 16:43:22 2014 from 10.1.1.1

#                                                                                                                                                                                                                                                            

[root@LINUXSERVER0]~# sstty kill ^U

#                                                                                                                                                                                                                                                            

[root@LINUXSERVER0]~# sstty cols 253

#                                                                                                                                                                                                                                                            

[root@LINUXSERVER0]~# sstty rows 25

#                                                                                                                                                                                                                                                            

[root@LINUXSERVER0]~# eexport LC_ALL="C"

#                                                                                                                                                                                                                                                            

[root@LINUXSERVER0]~# eexport LANG="C"

#                                                                                                                                                                                                                                                            

[root@LINUXSERVER0]~# eecho ACTIVE SHELL IS $SHELL END

ACTIVE SHELL IS /bin/zsh END
#                                                                                                                                                                                                                                                            

[root@LINUXSERVER0]~# uuname -s; echo ERROR=$?

Linux
ERROR=0
#                                                                                                                                                                                                                                                            

[root@LINUXSERVER0]~# 

#                                                                                                                                                                                                                                                            

[root@LINUXSERVER0]~# The push install is cancelled because the installation directory (including the OS prompt) is too long. It must have fewer than 220 characters.

Operating Systems:

Comments 7 CommentsJump to latest comment

Igor Perevozchikov's picture

I don't remember exactly about place of places for key, but can you change directory to more shortly path of .key in ULM Push settings page on SMP Console?

  1. Don't forget that, first you can find an answer for your question in Knowledge base
  2. If answer solves your question, then please mark as solution to close a thread
Brandon's picture

I changed <InstallDir>/opt/altiris/notification/nsagent</InstallDir> to <InstallDir>/opt/altiris</InstallDir> and it is still giving me the same error.

Igor Perevozchikov's picture

Unable to use key file "" (unable to open file)
Using username "root".
Last login: Wed Jul 23 16:43:22 2014 from 10.1.1.1

  • You're using a SSH key file for push agent? What is a length of path to this key, since it says that it unable to open it?

SSHKey.jpg

  1. Don't forget that, first you can find an answer for your question in Knowledge base
  2. If answer solves your question, then please mark as solution to close a thread
Brandon's picture

No SSH Key authorization, just password authorization. My SSH is unchecked like yours, I don't know why it has something in the logs about it but it uses the username anyways and logs in just fine. Can I bump the verbosity up somehow to see what the command line looks like when it tries to run?

Brandon's picture

I should also mention I am using 7.5 HF5 and the client is on RHEL 6.5, which isn't on the official support matrix. I have been following this document however, and I don't see any known issues regarding this problem so I believe it should still install.

Igor Perevozchikov's picture

On Push Install web page (SMP Console), choose manually type of OS (something near to this Linux version) and try to install it again.

  1. Don't forget that, first you can find an answer for your question in Knowledge base
  2. If answer solves your question, then please mark as solution to close a thread
Brandon's picture

I've tried manually setting RHEL 6.4 and unsupported Linux but the logs indicate the same error each time.