Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Installed ServiceDesk 7.0 MR1 on D: drive – How can I upgrade to MR2?

Created: 30 Jun 2010 • Updated: 28 Aug 2010 | 9 comments
Ole Jacob's picture
This issue has been solved. See solution.

I have installed ServiceDesk on another drive than C:. Can anyone provide a description on how to apply MR2?

Thanks, Ole Jacob

Comments 9 CommentsJump to latest comment

matzebru's picture

Me too!

- Bruce

 *** If a forum post solves your problem, please flag it as a solution. If you like an article or forum post, vote it up. ***

sandybluebird's picture

I am waiting for the same... Can anyone help ?????

-Sandeep.

Thanks and Regards,

-Sandeep...

RRJMTC's picture

I spoke with Symantec Technical Support and this is one of the first things that they asked me. They said it is a known issue.

matzebru's picture

Do you happen to know the Knowledgebase article number?

- Bruce

 *** If a forum post solves your problem, please flag it as a solution. If you like an article or forum post, vote it up. ***

JoTz's picture

I've logged a ticket with Symantec when I couldn't get the MR2 to apply porperly. After the update, i couldn't load the forms and have errors.  I've found the workflow packages copied to C drive while the release folders updated in D drive. They replied to try these steps below.

(Do make sure to take a backup of the server and the database in-case you want to get back to the same status after the upgrade.)

(copied from their email)

  1. - Copy the Workflow Designer folder and all sub files\folders that were copied to C: during the failed upgrade to the Workflow Designer folder on your install drive.  You will need to close any Workflow tools and windows and then stop the Logicbase2006ServerExtensions service and stop IIS (from cmd prompt iisreset /stop).
  2. - Once the files are copied over start IIS (from cmd prompt iisreset /start) and start the Logicbase2006ServerExtensions service.
  3. - Open Process Manager portal and go to Admin > Data > Application Properties.
  4. - Click the Action button (lightning bolt icon) and choose Delete Profile Definition.
  5. - Close Process Manager.
  6. - Run the ServiceDesk MR2 install.
  7. - During the installation choose New for the install.  You need to choose this option as there are no longer any Application Properties.
  8. - When you get to the database settings section of the install choose update existing database

-----------------------------

I've just completed this testing and now i have 2 sets of Application properties even though i've deleted it before trying these steps. The processmanager seems to be loading fine, I haven't tried creating a ticket yet but I can view the new technican submit form. Just had another email from Symantec, they say to delete Application properties and try again (for the 2nd time).

If anyone wish to try the steps above, please let us know how it goes for you. Thanks.

SOLUTION
JoTz's picture

Following the steps above. Time to get cracking on the customization.

Ole Jacob's picture
  • Permissions on groups where reset back to default.
  • Most of the workflow that I had modified was updated so I had to modify the new workflows!

PS: The portal kept the configuration.

Ole Jacob

Regards, Ole Jacob

andykn101's picture

I take it MR2 can be installed as a new install.

Do any of these steps need to be carried out to install MR2 to the D drive as a fresh install?

Authorised Symantec Consultant (ASC) with Endpoint Management Limited, an Authorised Symantec Delivery Provider based in the UK.

Connect Etiquette: Please "Mark as Solution" posts that fix your problem.

dmartine71's picture

So,   what a nightmare.  I had MR1 installed on the D Drive. 
I was instructed to reinstall SD7 - It copied everything from c to d (Directory Structure Altiris\Designer and so on)
I was instructed to do what the previous post requested -  and it reset all my configs
I was so frustrated  I decided to start over becuase even though the the second reinstall work after getting things back to normal.  I started having issues all over the place.. the reason is becuase the install did not upgrade some MR1 workflows.  I have people testing this envorment calling me about things not working

So Frustrated I started from Scratch.. new Database, New install -- Seems to be working fine... I have other issues just none with the MR2 upgrade..
Sad part is I have to dothis samething in Production..

Heres a little news... Dont know if you have heard but you are going to have to recreate all your configurations with the release of SD 7.1 -- cannot import or anything.. Hopefully Symantec will have some wizards or something!!!!!!

 

David Martinez

dmartinez0526@hotmail.com

281-627-7382