Video Screencast Help
Symantec Appoints Michael A. Brown CEO. Learn more.

Installing Backup Exec Remote Agent For Oracle On Linux

Created: 19 Mar 2014 | 9 comments

Dears ,,,

Greetings, we have Symantec Backup Exec 2012 Version 14.0 Rev. 1798 (64-bit) installed on Windows Server 2008 R2 Standard. We used to have a remote agent for oracle (Symantec symbdsnap, build 2.0.1-1783) installed on a Oracle Enterprise Linux 5.8 64-bit Kernal 2.6.32-300.10.1.el5uek and it was working fine. Recently, we have updated the operating system to Oracle Enterprise Linux 5.10 64-bit kernal 2.6.39-400.209.1.el5uek. The agent is being installed successfully but when go through the log it says (This platform is not supported.  Exiting install.VxIF::Error:: ERROR: Installing SymSnap Driver Failed.). Is there a another version or anyother way to deploy an agent for Backup Exec on this server.
 

Operating Systems:

Comments 9 CommentsJump to latest comment

sidd3009's picture

Hello,

Backup Exec 2012 till today supports installation of Remote Agent for Linux/Unix Servers(RALUS) on Oracle Enterprise servers version 5 till version 5 Update 7 and version 6 till version 6 Update 1. Refer to the Software Compatibility List of Backup Exec 2012: http://www.symantec.com/docs/tech175581

Just an FYI, the error that you are receiving is for the new feature in Backup Exec 2012, the 'Advanced Open File Option for Linux'. This feature requires the installation of the SymSnap driver and is not supported on all the flavors of Linux/Unix. 

With that being said, as you mentioned, the agent installation was successful and as such, you may try to run a backup(with a few limitations associated to backup of open/locked files).

Regards,

Siddhant Saini
Advanced Technical Support Engineer, Symantec Corporation 
www.symantec.com

Qutaybah_1's picture

Hi,

First thing let me thank you for your reply and clear explaintation. Secondly, I've managed to add these servers to the Symantec Backup Exec 2012 Console. But, when I try to establish the trus or try to back it up it gives an error

(Unable to establish trust with SERVERNAME  Unable to connect to the backup exec agent for windows. Ensure the agend for windows installed, that creditntials are correct and then try this operation again. Additional Information CallingMethod "SetServerTrust" BEMSDK Method "MediaServerAdvertisementUpdate"BEMSDK Failure Code: -536835807:X8).

Also, when I try to browse the server to back it up it's giving the following error

(Browse Failure Failure to browse "SERVERNAME" A communication failure occured when attempting to connect to this server. Some common causes for this error are: the computer name typed incorrectly, the computer is not powered on, a Backup Exec agent is not installed, or the network improperly configured. Additional Information QueryMetaData: MDQ_MachineInfo_View MDS_MachineInfo_View_Parameter_ConnectionLogon = '10011001-1001-1001-0101-010101010101' MDS_MachineInfo_View_Parameter_DeviceName='IPADDRESS' MDS_MachineInfo_View_Parameter_ServerLogon='88d6ab51-dfa3-4666-b287-fe323bd4ff38')

The server is pingable from the backup exec server (media server) and I confirmed the credintials are correct.

pkh's picture

Note that if you use an unsupported configuration then Symantec does not guarantee that you can restore your backups even if they are successful. Also, you will not be able to open a support case with them

Qutaybah_1's picture

Thank you pkh for your valuable input. I've been using the same setup on the Oracle Enterprise Linux 5.8 shown above for the past 2 years. Backups and Restores are tested multiple times before we implement the solution in the business. Also, we are using these backups to create test clones and all of them were successfull.

pkh's picture

As long as you are aware that an unsupported configuration can break anytime and you get no support from Symantec

Qutaybah_1's picture

Hi,

First thing let me thank you for your reply and clear explaintation. Secondly, I've managed to add these servers to the Symantec Backup Exec 2012 Console. But, when I try to establish the trus or try to back it up it gives an error

(Unable to establish trust with SERVERNAME  Unable to connect to the backup exec agent for windows. Ensure the agend for windows installed, that creditntials are correct and then try this operation again. Additional Information CallingMethod "SetServerTrust" BEMSDK Method "MediaServerAdvertisementUpdate"BEMSDK Failure Code: -536835807:X8).

Also, when I try to browse the server to back it up it's giving the following error

(Browse Failure Failure to browse "SERVERNAME" A communication failure occured when attempting to connect to this server. Some common causes for this error are: the computer name typed incorrectly, the computer is not powered on, a Backup Exec agent is not installed, or the network improperly configured. Additional Information QueryMetaData: MDQ_MachineInfo_View MDS_MachineInfo_View_Parameter_ConnectionLogon = '10011001-1001-1001-0101-010101010101' MDS_MachineInfo_View_Parameter_DeviceName='IPADDRESS' MDS_MachineInfo_View_Parameter_ServerLogon='88d6ab51-dfa3-4666-b287-fe323bd4ff38')

The server is pingable from the backup exec server (media server) and I confirmed the credintials are correct.

lmosla's picture

pkh is absolutely correct. Though this may backup successfully and even restore it is at your own risk and something Symantec doesn't stand behind and offer support it if there are any issues. 

You can make product enhancement requests and track your request's progress here on this site by selecting Create Content and clicking Idea.  

 

Qutaybah_1's picture

Dears ,,,

Thank you for your valuable input in the issue. I contact Symantec support and we have installed the Service Pack 4 on Backup Exec 2012 and applied a patch for linux agent on the linux server. After that I was able to establish the trust also we were able to backup and restore files from the server.

I know it's not the best practice but this is what our environment provided us to work with.