Video Screencast Help

Installing CMDB solution for NS 7

Created: 18 Aug 2009 • Updated: 21 May 2010 | 5 comments
djkiff's picture

I am having issues installing CMDB solution to my NS 7 box.  I can install the Data Connector but it fails to install CMDB with the following error:

Source: Altiris.NS.Installation.ProductConfigurationWorker.ConfigureProduct

Description: Failed to configure E:\Program Files\Altiris\CMDB\Config\CMDB.config

( Exception Details: System.InvalidOperationException: ExecuteNonQuery requires an open and available Connection. The connection's current state is closed.

at System.Data.SqlClient.SqlConnection.GetOpenConnection(String method)

at System.Data.SqlClient.SqlConnection.ValidateConnectionForExecute(String method, SqlCommand command)

at System.Data.SqlClient.SqlCommand.ValidateCommand(String method, Boolean async)

at System.Data.SqlClient.SqlCommand.InternalExecuteNonQuery(DbAsyncResult result, String methodName, Boolean sendToPipe)

at System.Data.SqlClient.SqlCommand.ExecuteNonQuery()

at Altiris.Database.DatabaseContext`1.Rollback()

at Altiris.NS.ContextManagement.DatabaseContext.Rollback()

at Altiris.NS.StandardItems.Product.ProductInstallation.InstallProduct()

at Altiris.AssetContractCommon.AssetContractCommonBaseInstallation.InstallProduct()

at Altiris.NS.Installation.ProductConfigurationWorker.ConfigureProductInternal(String configFile, Boolean ownsProgressContext, SerializationMode serializationMode)

at Altiris.NS.Installation.ProductConfigurationWorker.ConfigureProduct() )

( Exception logged from:

at Altiris.Diagnostics.Logging.EventLog.ReportException(Int32 severity, String strMessage, String category, Exception exception)

at Altiris.Diagnostics.Logging.EventLog.ReportException(String strMessage, String category, Exception exception)

at Altiris.NS.Installation.ProductConfigurationWorker.ConfigureProduct()

at System.Threading.ThreadHelper.ThreadStart_Context(Object state)

at System.Threading.ExecutionContext.runTryCode(Object userData)

at System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode code, CleanupCode backoutCode, Object userData)

at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state)

at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)

at System.Threading.ThreadHelper.ThreadStart()

)

( Extra Details: Type=System.InvalidOperationException Src=System.Data )

I have try installing to 3 different NS 7 servers and I get the same error each time.  SMS 7 is installed and completly up to date.

Thanks for your help,

DK

Comments 5 CommentsJump to latest comment

jharings's picture

Are you getting this from the SIM installer?

Edit:  Hmm, the release notes say July 30th. I must have been asleep at the wheel.

Jim Harings
HP Enterprise Services
1st Rule of Connect Club: Mark the post that helped you the most as a 'solution'. 2nd Rule of Connect Club:You must talk about Connect club.

djkiff's picture

Yes, Barcode and  Data Connector are also out too.

David Kiff - AAC, MCSE

AMorris's picture

Based on the error you have provided it looks like a data base issue.
Please try and load the console to see what error it gives you on screen (restart Altiris Service if this doesn't work).
After that reboot your machine to reconnect your NS to your data base.

Are you using an On-Box SQL or an Off-Box SQL ?

jharings's picture

I'm going back to a clean VM, but it fails at 61% during every install, while importing "merged security items". My SQL is on-box (SQL Express 2005), and I confirmed the following:
1) TCP\IP and Named Pipes were both enabled
2) Tried installing after enabling XP Command shell (fail)
3) Tried installing after enabling Open Row Source and Dataset (fail)

The process is looking for an open SQL connection, perhaps SQL Express isn't allowing that (at least on my end).

EDIT and UPDATE
The issue in my case was the good old "PEBKAC" (problem exists between keyboard and chair). I simply needed to restart the SQL service instance, which I thought I did initially. So, I think if you do Option 1 above, you can skip 2 and 3, just make sure you restart the SQL services after. Then try installing CMDB.

Jim Harings
HP Enterprise Services
1st Rule of Connect Club: Mark the post that helped you the most as a 'solution'. 2nd Rule of Connect Club:You must talk about Connect club.

Pascal KOTTE's picture

Hello - Are you talking about the small CMDB solution altiris miss named, that is automatically update some "Assets" database fields, according some automation rules ?
OR
Are you talking the new full version of  "Asset & Contracts" full database, that is formally, the "true" CMDB & the heart of all Altiris solutions with this (AMS2) extension.
?

For sure, Barcode & Data connector 7 are part the 2nd option. Good news, as usual, totally underground done from Symantec ???
I was thinking those solutions will not be available before Dec 2009 ???

It is a critical topic, because CMS7 does not forward inventory to AMS v6 server, so you cannot upgrade v7 without.
I was receive from Symantec a KB explaining how to use Connecto 6 to pull data from CMS7 into AMS6 server,
but... This KB said it does the contrary :-(
https://kb.altiris.com/article.asp?article=47224&p=1

More over: SD7 is now there (also silently underground for a such major update...) this should include a CMDB v7 licence, but SD7 docs/FAQ also said CMDB7 not already there, so SD7 integration "must" use a CMS7 for integration for the current SD7 release ! ...

What a mess !

~Pascal @ Kotte.net~ Do you speak French? Et utilisez Altiris: venez nous rejoindre sur le GUASF