Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Installing cubes fail in Analytics Solutions 7.1

Created: 15 Mar 2011 • Updated: 04 Apr 2011 | 12 comments
This issue has been solved. See solution.

Hi,

I'm trying to install cubes and there is no available cubes.

I could see some availabe cubes at the first time so check all the cubes and click Save Change to install but there is error messege like this 'IT Analytics Packs could not be validated. Please repair IT Analytics Solutions'

So I did repair IT Analytics Solutions but still this issue doesn't go away.

Anyone know why is that?

Comments 12 CommentsJump to latest comment

mclemson's picture

If you launch SIM, do you show valid, unexpired licenses for IT Analytics?

Mike Clemson, Senior Systems Engineer, ASC
Intuitive Technology Group -- Symantec Platinum Partner
intuitivetech.com

Gyeong Un Kim's picture

Hi, mclemson

I run it with tryware license for the test and of caurse it is unexpried yet.

Does it cause the this problem?

Andrew Bosch's picture

1) After any install of Altiris software, add the SMP server to the Internet Explorer Trusted Sites. 

2) Now reset the security level by doing the following: 

From the IE > Tools > Internet Options > Security > Trusted Sites tab > Security level for this zone > Click custom level
Scroll down to Miscellaneous and change the first option “Access data sources across domains” back to Enable. This option is now disabled by default.

3) While not required, a second change to make while you’re in here is to scroll all the way to the bottom, the very last entry is “User Authentication” and change the Logon to the 3rd option “Automatic login with current user name and password” 

------------------------------------
Sr. Principal SQA Engineer
Symantec

Mr.Mik's picture

Hi,

I have had exactly the same behaviour that
Gyeong Un Kim wrote.

I've reinstalled the entire suite over the night due to an error into the IT Analytics solution,
was probably due to the fact i didn't install the SQLServer2005_ASOLEDB9_x64.msi even it's wierd,

however at the end of the installation I was finally able to see available cubes.

This morning, I was connecting and I got the described alert with no cubes more available:

IT Analytics Packs could not be validated. Please repair IT Analytics Solutions.

I'm using trial license but it expires in 30 days, so still valid,
I've also modified ie settings as Andrew has wrote.

Any Suggestions?

Should I repair the IT Analytics again?

Many thanks.

Michele Ferrari

mclemson's picture

If you repaired the solution, uninstalled, then reinstalled, then are being prompted to repair, yes, try a repair.

Mike Clemson, Senior Systems Engineer, ASC
Intuitive Technology Group -- Symantec Platinum Partner
intuitivetech.com

sgosden's picture

we are getting the error as well. have licences and the cubes were available. when I installed a cube it failed and gave the 'it analytics packs could not be validated'

have uninstalled, reinstalled and moved all the packs except the CSMP and still get the error.

If I remove all the packs it says no packs are available but the error comes back as soon as any packs are installed.

david_evans's picture

Hello All,

We are aware of this problem and are in the process of posting a fix to the knowledge base once it has been fully tested. It is caused by a datetime format issue between the SMP and SQL server.  In the interests of keeping everyone moving with their installs I will post the resolution here, but it should only be used on the understanding that it has not yet been fully ratified.

I have personally seen this fix applied successfully twice, but I cannot guarantee there will be no issues.  

Resolution

Using SQL Server Management Studio run the attached sql script to alter the stored procedure.

Then execute the stored procedure by issuing the following command:

Exec spITAnalytics_CSMP_CreateViews

Once both steps above have been successfully completed navigate to the Cubes page again and the page should load correctly. The problem should no longer occur unless IT Analytics for Client and Server Management pack is repaired or uninstalled and reinstalled.
 

AttachmentSize
Alter CSMP CreateViews SP.txt 301.4 KB

________________________________

David Evans
Senior Product Manager
Deployment Solution, Ghost Solution Suite, Server Management Suite, Task Server
www.symantec.com
________________________________

SOLUTION
kbering's picture

Evans,

When I try to run the attached sql I get this error:

Cannot add rows to sys.sql_dependencies for the stored procedure because it depends on the missing table 'dbo.spITAnalytics_CMDB_GetFullyQualifiedDataSource'. The stored procedure will still be created; however, it cannot be successfully executed until the table exists.

Cheers

Kåre

mclemson's picture

I'd recommend running a repair and then retrying.  If it still fails, though, I'm not sure if you should create it manually in SQL Studio, or if you should wait for a response from support.

Mike Clemson, Senior Systems Engineer, ASC
Intuitive Technology Group -- Symantec Platinum Partner
intuitivetech.com

sgosden's picture

I ran the sql query and it gave me the same error. however I then ran the stored procedure and didn't get any errors.

I could then install the cubes and all is working ok.

richardx's picture

Fixed it for me - using v7.1 gold - thanks David_evans

r

tecjunky's picture

The Resolution offered by David_Evans is the official Fix, and is now offered as KB TECH156446.