Video Screencast Help

Installing Endpoint Protection on Windows 7 PC

Created: 29 Dec 2009 • Updated: 27 Sep 2010 | 11 comments

I am trying to Load Symantec Endpoint Protection on a new laptop running Windows 7.  It will not install and I get the following message "The wizard was interrupted before Symantec Endpoint Protection could be completely Installed."  Any way around this?

Comments 11 CommentsJump to latest comment

sandeep_sali's picture

If we understand you correctly, you are trying to install SEP as an unmanaged client on an Windows 7 machine.

Can you let us know the version of SEP because only the latest version i.e. RU 5 is compatible with Windows 7. If you do not have the latest version you can download it from the following site.

https://fileconnect.symantec.com/licenselogin.jsp?...

If it is the latest version then let us know the stage where the installation stops or rolls back.

Go to start >> run >> and type %temp% and locate the sep_inst log file, open it and search for return value 3 in it, paste 15 lines above the return value 3 error

Thanks & Regards

Sandeep C Sali

Magellen2's picture

Mr Sali,

How can you confirm the  version of SEP?  Also can you further explain what you mean by this statement "..open it and search for return value 3 in it, paste 15 lines above the return value 3 error" i.e. what do you mean by paste 15 lines?

Thanks.

 

pliu's picture

I have the same problem as the OP, SEP 11 MR5 just will not install on a Windows 7 x64 client. Relevent lines from the Install log (the 15 above the first instance of "return value 3" are below:

MSI (s) (74:D4) [11:25:47:158]: Executing op: CustomActionSchedule(Action=LU_Register_Decomposer_ABI.611D9A69_39FC_4998_998E_1ECADF28A979,ActionType=1025,Source=BinaryData,Target=_LURegisterDecomposerABI@4,)
MSI (s) (74:90) [11:25:47:158]: Invoking remote custom action. DLL: C:\Windows\Installer\MSI62F8.tmp, Entrypoint: _LURegisterDecomposerABI@4
-- DECABI_LOGGING --   Enter LURegisterDecomposerABI()
-- DECABI_LOGGING --   GetDecomposerABIProperties Registry created.
-- DECABI_LOGGING --   GetDecABIDirectory() -- failed to get Installed Apps key from registry.
-- DECABI_LOGGING --   Decomposer ABI DLL version is: not installed
-- DECABI_LOGGING --   Could not get Decomposer ABI version from LiveUpdate. (HRESULT=-2147221164)
-- DECABI_LOGGING --   Decomposer ABI version registered with LiveUpdate is: not installed
-- DECABI_LOGGING --   Decomposer ABI sequence number registered with LiveUpdate is: not installed
-- DECABI_LOGGING --   For rollback using Decomposer ABI custom action  property: sizeof= 130 not installed:not installed
-- DECABI_LOGGING --   LiveUpdate registration failed. (HRESULT=-2147221164)
CustomAction LU_Register_Decomposer_ABI.611D9A69_39FC_4998_998E_1ECADF28A979 returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
Action ended 11:25:47: InstallFinalize. Return value 3

Any idea what could be the cause?

.

Jeremy Dundon's picture

 LiveUpdate registration failed (HRESULT=-2147221164)

Try right-clicking LUSETUP.EXE and Run As Admin. (you can find LUSETUP.EXE in /SEP directory of CD1.)
Then try installing SEP again.


srnovak's picture

Why must Live Update be installed first? If it is to be installed first why doesn't the exported install package perform that operation first?

snekul's picture

 As sandip_sali said, if you try and use any version of SEP older then RU5, SEP will either not install or run improperly.  That's usually the major problem with Windows 7 installs.

Eric C. Lukens IT Security Policy and Risk Assessment Analyst University of Northern Iowa

kwjuan's picture

I start the set up wizard and it I get an error that states:  "Symantex endpoint protection has detected that there are pending system changes that require a reboot.  Please reboot the system and rerun the installation."

I have rebooted several times but no change.

I am running windows 7, new laptop.

Downloaded SEP_MR5.

thanks

John

snekul's picture

That's another common install problem, but not specific to Windows 7.

Full details can be found at http://service1.symantec.com/SUPPORT/ent-security.nsf/docid/2007121609023348, but the gist is to backup then remove the following registry entries if they exist and restore after installing SEP:

HKEY_LOCAL_MACHINE\SYSTEM\ControlSetXXX\Control\SessionManager\PendingFileRenameOperations
KEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update\RebootRequired


Eric C. Lukens IT Security Policy and Risk Assessment Analyst University of Northern Iowa

AravindKM's picture

Try like this
Disable
Control Panel > User accounts
> User account control

 
Delete following directories if exist
C:\Program Files\Symantec\Symantec Endpoint Protection (Or the appropriate directory if you installed in a different one)
C:\Program Files\Symantec\LiveUpdate (Or the appropriate directory if you installed in a different one)
C:\Program Files\Symantec\ (Or the appropriate directory if you installed in a different one)
C:\Program Files\Common Files\Symantec Shared
C:\Users\All Users\Microsoft\Windows\Start Menu\Programs\Symantec Endpoint Protection
C:\ProgramData\Symantec

Install Liveupdate.(You cdan run LUsetup.exe which is present in cd1\sep can be used for this)
Install SEP client.
If this not helps as sandip_sali said paste the 15 lines above return value 3 from SEP_INST.log

Please don't forget to mark your thread solved with whatever answer helped you : ) Thanks & Regards Aravind

srnovak's picture
Install Liveupdate.(You cdan run LUsetup.exe which is present in cd1\sep can be used for this)
Install SEP client.


That actually worked for both 32 and 64 bit clients here. A small hassle, but we can script the install in Altiris now for future win7 machines.

Carrefour-dan's picture

We have an open support case with Symantec trying to deply Endpoint Protection out to Windows 7 machines.
So far it will not deply, support has had the case for almost 2 months with no resolution, they can replicate it on their end where SEP will not deploy to windows 7 machines.

Still waiting..