Video Screencast Help
Symantec Appoints Michael A. Brown CEO. Learn more.

Installing a Media Server on Netbackup 6.5.5

Created: 17 Jun 2010 | 9 comments

I'm trying to install a media server on Netbackup 6.5.5. When I create a new storage unit for the media server, I don't get the option to specify the media server. When I go to Netbackup Management > Storage > Storage Units, specify a "New Storage Unit" and select "Storage unit type" Media Manager, the only option I get for "Media server" is "Any available" and the master master. How come I cannot select the media server? The media server is shown in Media and Device Management > Devices > Media Servers. I do notice that the status for the media server is "Active for Disk." Is there a way to make the media server "Active for Tape and Disk?"

The documentation I've been reading is for configuring the media server as a Basic Disk. Is there a way to have the media server write directly to tape instead of disk first?

Comments 9 CommentsJump to latest comment

Stuart Green's picture

Are you using the drives in a Shared Storage Option SSO configuration. Then confirm you have loaded the correct license keys for the drives and this feature on the server.

Restart netbackup services after installing new licenses.

Also, have you added the tape drives for that server. If SSO, have you added the server to the drives.
Note: You should do device management with the GUI from the master server.

Check "Media and Devices > Devices > Robots" that your media server is listed against your robot./library.

references to use
System Administration Guide Vol.2
Shared Storage Guide

all found here  http://seer.entsupport.symantec.com/docs/290282.htm

Tip: Get overview/document your NBU environment. Run 'nbsu' and review the output.

• If this provides help, please vote or mark appropriate solution.

zumatech's picture

I've confirmed that the SSO license key is installed. From the GUI on the master server when I go to "Media nad Devices > Devices > Robots," I only see the device for the master server. Should there be one for the media server? When I add a new robot and specify the media server as a device host, I get this error:

The EMM server failed to process the request.

I did try specifying the robot control as "Robot control is handled by a remote host" and that worked.

When I go to "Netbackup Management > Storage > Storage Units," and add a new storage unit, I still don't get the option to specify the media server. The only option is any available and the master server. How do I populate the Media Server field to include the media server?

richs24's picture

play around with your 'on-demand' setting in your storage units.  we had it where we had to set it to on-demand, create what we wanted, then un-tick on-demand, and it worked fine.
saw that in version 6.0 right up until 6.5.5

Kevin Good's picture

You won't find the Media Server listed as an option to create a new STU on.

try these things:

On the Master:
Windows: <install_path>\NetBackup\bin\admincmd\
UNIX: <install_path>/netbackup/bin/admincmd/
nbemmcmd -listhosts

should look something like this
NBEMMCMD, Version:6.5.5
The following hosts were found:
media           <media_server>
server          <master_server>
master          <master_server>

Then try it on the new media server (results should match)

next, back on the master, force bprd to reread it's configuration
Windows: <install_path>\NetBackup\bin\admincmd\
UNIX: <install_path>/netbackup/bin/admincmd/
bprdreq -rereadconfig

Relaunch you admin console

Try defining the new STU

Backups are IT-101 (Do Backups) Doing Backups well is an art form. Nobody cares about getting their data backed up... They only care that you can restore it for them!

zumatech's picture

I do see the media server listed when I run nbemmcmd on both the master and media servers. When I go to the admin console and define a new STU, I still don't get the option to specify the media server.

Kevin Good's picture

Check if avrd is running

If you just configured new devices, restart ltid on the media server

Windows: <install_path>\VolMgr\bin\
UNIX: <install_path>/volmgr/bin/

stopltid
ltid

Backups are IT-101 (Do Backups) Doing Backups well is an art form. Nobody cares about getting their data backed up... They only care that you can restore it for them!

David McMullin's picture

use your OS level scan on the media server -

/usr/openv/volmgr/bin/scan -tape

 - should show there are devices there.

/usr/openv/volmgr/bin/tpautoconf -a

 - should configure your drives

This will also restart your ltid

Or use GUI wizard.

My point - if you can't see the drives at the OS - you can't use them in NetBackup.

NBU 7.0.1 on Solaris 10
writing to EMC 4206 VTL
duplicating to LTO5 in SL8500
using ACSLS 7.3.1

Marianne's picture

You need to add tape drives on the media server before you can add a storage unit.
You say that you have added SSO license key - have you also added Library Based Tape Drive license key?
For shared drives you need 3 license keys on a media server:

  • Enterprise Server (if you want to backup clients) or Enterprise client (to backup self)
  • Library based tape drives
  • Share Storage

Ensure PBX comms on port 1556 between master and media server.
Ensure forward and reverse name lookup in both directions between master and media.
If fqdn is used ANYWHERE in name lookup, ensure it resolves EVERYWHERE.
I have adopted the habit to create hosts entries just to be sure.

E.g: On master:
10.10.10.1 master master.company loghost
10.10.10.2 media media.company

Om media:
10.10.10.2 media media.company loghost
10.10.10.1 master master.company

Once all of the above is confirmed, use the device config wizard to add devices for media server:

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

xhawk's picture

I think Marianne got the point, you should use "device configuration wizard" to scan your media server for tape devices,
and then don't never forget to inventory robot.

 
 And update the volume information: