Video Screencast Help

Installing new tapedrives

Created: 16 Mar 2010 • Updated: 20 Jan 2013 | 6 comments
This issue has been solved. See solution.

Hi everybody, we are installing two new tapedrives T10000, but I need to know if in the media and master server I need to configure something, because the new tapedriver are there, in the tape library but the media and master server doen`t see them. Only I can see the new tape drives in device monitor.

Comments 6 CommentsJump to latest comment

Omar Villa's picture

Try to run the following:

vmoprcmd -devconfig -l

From here we will be able to see how your drives are configured, if you see them in Device Monitor is because are there but is probable you have them has Stand-alone drives.

Please let us know

Omar Villa

Netbackup Expert

Twiter: @omarvillaNBU

Marianne's picture

Hi Luis
I'm battling to understand - you say the master and media server can't see the tape drives, but  you can see them in device monitor?

Steps to add new tape drives:

  1. Ensure tape drives are visible to O/S
  2. If Windows - install tape drivers
  3. If Windows, ensure RSM service is stopped and disabled
  4. Add tape drives to NetBackup using Device Config Wizard
  5. Allow wizard to stop/start device management service/daemon on media server
  6. Add/update storage units

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Luis M's picture

Thanks for your help, the media and master server are in AIX.

I ran the comand and this is what showed:

vmoprcmd -devconfig -l
Device Robot Drive       Robot                    Drive            Device
Type     Num Index  Type DrNum Status  Comment    Name             Path
robot      1    -    ACS    -       -  -          -                speges02
  drive    -    0 hcart2    -      UP  -          STK.9840C.000    /dev/rmt0.1   ACS=0, LSM=2, PANEL=1, DRIVE=1
  drive    -    1 hcart3    -    DOWN  -          STK.T10000B.003  /dev/rmt10.1  ACS=0, LSM=0, PANEL=1, DRIVE=1
  drive    -    2 hcart3    -    DOWN  -          STK.T10000B.004  /dev/rmt6.1   ACS=0, LSM=2, PANEL=1, DRIVE=3
  drive    -    3 hcart3    -    DOWN  -          STK.T10000B.000  /dev/rmt2.1   ACS=0, LSM=2, PANEL=1, DRIVE=4
  drive    -    5  hcart    -      UP  -          STK.T9940B.000   /dev/rmt3.1   ACS=0, LSM=2, PANEL=1, DRIVE=7
  drive    -    6 hcart2    -      UP  -          STK.9840C.003    /dev/rmt4.1   ACS=0, LSM=2, PANEL=1, DRIVE=0
  drive    -    7 hcart2    -      UP  -          STK.9840C.004    /dev/rmt5.1   ACS=0, LSM=2, PANEL=1, DRIVE=2
  drive    -    9  hcart    -      UP  -          STK.T9940B.001   /dev/rmt7.1   ACS=0, LSM=2, PANEL=1, DRIVE=6
  drive    -   10 hcart3    -      UP  -          STK.T10000B.001  /dev/rmt8.1   ACS=0, LSM=0, PANEL=1, DRIVE=3
  drive    -   11 hcart3    -      UP  -          STK.T10000B.002  /dev/rmt9.1   ACS=0, LSM=0, PANEL=1, DRIVE=2

In this case the new tape drives are .003 and .004
In Netbackup I ran a job using the new tape drives but the job is stuck at mounting, then I had to cancel it. And in the tape library the tape does not unmount, I have always to use a dismount force in this tape drives. 

Marianne's picture

What you are describing sounds like a device mapping mismatch.
To confirm, compare the drive serial numbers as follows:

On the ACSLS server  from cmd_proc do:
ACSSA> display drive *,*,*,* -f type serial_num

On NetBackup:
tpautoconf -t

Ensure that the /dev/rmt#.1 matches the correct acsls address

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

J.H Is gone's picture

when you do an lsdev does AIX see the drives as availiabel?

rmt0 Available 0A-08-02 IBM 3580 Ultrium Tape Drive (FCP)

rmt1 Available 0A-08-02 IBM 3580 Ultrium Tape Drive (FCP)

rmt2 Available 0A-08-02 IBM 3580 Ultrium Tape Drive (FCP)

rmt3 Available 0A-08-02 IBM 3580 Ultrium Tape Drive (FCP)

if you do not see the new drives have you run cfgmgr?
did cfgmgr come back with any errors.
if they are new drives on the san are they zoned?

Next thought is you have them reversed.
may be .003 is rmt6 and .004 is rmt10

I don't have to know how to spell....I work on Unix.
NetBackup 7.0.1 - AIX & Windows

Omar Villa's picture

If you dont have any NDMP drive run this:

tpautoconf -report_disc

Paste the output here it will clearly tell us if you have any missmatch between autoconf, tpconfig and vmglob DB's, also try the following

tpconfig -dev_ping -drive -path /dev/rmt10.1
tpconfig -dev_ping -drive -path /dev/rmt6.1

This will query the drives directly and you will confirm if your zones are correct.

Hope this helps.

Omar Villa

Netbackup Expert

Twiter: @omarvillaNBU