Video Screencast Help

Installing OWA2003 on exchange gives ado error

Created: 14 Jan 2013 • Updated: 17 Jan 2013 | 1 comment
This issue has been solved. See solution.

 Situation:

Exchange 2003 on w2K3 (64 bit)

Enterprise Vault 8 on w2k3 (32 bit)

 

About:

Installation of the Vault Extensions for OWA2003.

 

When I installed the Vault Extensions for OWA2003 on the exchange server this error came up when trying to configure the public folders.

 

10/01/2013 10:11:05 : Debug   : ConfigureSchema                      : Creating ADODB Connection...

10/01/2013 10:11:05 : Error   : ConfigureSchema                      : ADO connection error: -2146105340

10/01/2013 10:11:05 : Error   : ConfigureSchema                      : Failed to make ADO connection to: http://EXCHANGESERVER/exadmin/admin/MYDOMAIN.LOCAL/Public%20Folders/%23%23SchemaURI%23%23/

10/01/2013 10:11:05 : Error   : ConfigureSchema                      : If you do not intend to archive from public folders, you may ignore this error.

10/01/2013 10:11:05 : Error   : ConfigureSchema                      : Otherwise see Technote 281092 (http://seer.entsupport.symantec.com/docs/281092.htm)

 

You can open the archived mails in public folders and the link to the original mail works, but there are no buttons to retrieve or archive an item in a public folder.

I tried the solution in the technote, but this did still gives the ado connection error.

On the Symantec Support site and in the Symantec forums, I found this solution.

C:\Program Files\Enterprise Vault\OWA>cscript.exe BackEnd2003Setup.wsf /formregdomain:<mysmtpdomain.tld>

This ran fine, but the effect was less.

You couldn’t retrieve the original of the archived mail in public folders anymore.

This error was shown in a webpage when trying to open the archived mail

Reason: Unable to determine a web app url for vault access

Luckily, the archived mails in the users mailbox were still ok.

 

Any suggestions?

Discussion Filed Under:

Comments 1 CommentJump to latest comment

Andrew G.'s picture

You won't get archive or restore options for public folders. In OWA those actions are only available in a mailbox. If you can open the archived item from the shortcut, then you are done and the registration error can be ignored.

SOLUTION