Video Screencast Help

Installing Symantec Endpoint Protection

Created: 31 Dec 2012 | 12 comments

I am getting this error as I am trying to install Symantec Endpoint protection 11.0

"To continue the installation, make sure that the Internet Information Services (IIS) World Wide Web Publishing Service (W3SVC) is installed and running.  On computers that run IIS 7.0 or later, the following IIS role services must alsobe installed: ASP.NET, CGI, and IIS 6.0 Management Compatibility."

I do not know how to check to see that these things are installed or running.

 

Thanks.

Comments 12 CommentsJump to latest comment

Cameron_W's picture

You are going to need to install IIS. Below is a example on how to install IIS on a 2003 OS.

http://technet.microsoft.com/en-us/library/aa998483%28v=exchg.65%29.aspx

If you have 12.1 available to download I would recommend using that as IIS is not required for the 12.1 SEPM.

If I was able to help resolve your issue please mark my post as solution.

.Brian's picture

I assume this is for the SEPM (SEP Manager) install? Server 2008?

You need to open Server Manager

Select Roles

Select Add Roles

Go thru the wizard and on the Server Roles page, select Web Server (IIS) and agree to any dependancies. Hit Next, Next and it should do the IIS install. Reboot and try the SEPM install again.

 

 

Please click the "Mark as solution" link at bottom left on the post that best answers your question. This will benefit admins looking for a solution to the same problem.

Paynesville Mutual's picture

Yes it is for SEPM and Server 2008.

I tried to add the web server in roles and reboot and I am still getting the same error.

.Brian's picture

Did you also add the roles for:

ASP.NET, CGI, and IIS 6.0 Management Compatibility

Please click the "Mark as solution" link at bottom left on the post that best answers your question. This will benefit admins looking for a solution to the same problem.

MichaelD50's picture

Don't even bother with installing any version 11 at this point in time. You really want to use version 12.1 RU2 (12.1.2015).

If you have a valid support contract, you may need to contact Licensing to get a new serial number for FileConnect (https://fileconnect.symantec.com); you will find the SEP 12.1 installers there.

Cheers!

MJD

.Brian's picture

Once IIS is installed, on the Roles page, scroll down until you see Web Server (IIS) and click on Add Role Services

A new box will pop up

They should all be available here under Web Server abd Management Tools

Click the + to expand if you need to and add accordingly.

Please click the "Mark as solution" link at bottom left on the post that best answers your question. This will benefit admins looking for a solution to the same problem.

.Brian's picture

Did you get it working?

Please don't forget to mark the thread as solved for the answer that best helped if so.

Please click the "Mark as solution" link at bottom left on the post that best answers your question. This will benefit admins looking for a solution to the same problem.

Paynesville Mutual's picture

Yes but it wasn't the program I thought it was. We use symantec for backup and thought that this was the program but it looks like this is for anti-virus.

Chetan Savade's picture

Hi,

Symantec Antivirus product is known as a Symantec Endpoint Protection (SEP)

Symantec Backup Product is known as a Backup Exec (BE)

SEP latest prodcuts can check here: http://bit.ly/m0vOJp

Chetan Savade
Sr Technical Support Engineer, Endpoint Security
Enterprise Technical Support
CCNA | CCNP | MCSE | SCTS |

Don't forget to mark your thread as 'SOLVED' with the answer that best helps you.<

Mithun Sanghavi's picture

Hello,

The Error is from IIS which is being used by the Symantec Endpoint Protection Manager.

Check these Articles below, which may assist you:

IIS is already installed and running but when installing the Symantec Endpoint Protection Manager (SEPM) console, you receive errors regarding IIS and W3SVC services

http://www.symantec.com/docs/TECH98146

IIS Error Displayed During Installation of the Symantec Endpoint Protection Manager

http://www.symantec.com/docs/TECH91538

"Internet Information service ISAPI Extensions (IIS ADMIN) and World Wide Web Publishing (W3SVC) need to be installed and running for this installation to continue." while installing Symantec Endpoint Protection Manager (SEPM).

http://www.symantec.com/docs/TECH105061

Hope these helps!!

Mithun Sanghavi
Senior Consultant
MIM | MCSA | MCTS | STS | SSE | SSE+ | ITIL v3

Don't forget to mark your thread as 'SOLVED' with the answer that best helped you.