Video Screencast Help

Intelligent Diaster Prep Error, Netlogon.chg

Created: 14 Apr 2005 • Updated: 22 May 2010 | 10 comments

When I go to run the intelligent recovery prep wizard to create an .iso image I get the error, "Error opening c:\windows\netlogon.chg. The process cannot access the file because it is in use by another process."

What do i do?

Comments 10 CommentsJump to latest comment

Sagar Kamat 2's picture

Thank you for submitting this support query. It is possible that the netlogon.chg file has become corrupt. If it is corrupt, you must either rename or delete the file.

Because the system uses netlogon.chg continuously, you need to take the following steps to rename or delete the file from an NTFS partition:



1. Set the System account permissions from Full Control on \%systemroot%\netlogon.chg to No Access.


2. Restart the computer, and delete the netlogon.chg file (or copy it to an alternate location).


3. Before you reboot a second time, add the Local System Account to the permissions on the C:\Windows and C:\Windows\System32 Folders and grant the object Full Control. If you don't do so, the system can't create the netlogon.chg file, and partial synchronization errors will occur.


4. Reboot once more. The system will create netlogon.chg at startup. Verify that the system created netlogon.chg.


5. Run the IDR Wizard Setup again to test.


http://support.microsoft.com/default.aspx?scid=kb;...


Hope, this should resolve the issue.


NOTE: If we do not receive your intimation within two business days, this post would be assumed answered and archived

Madhuri Shenoy's picture

As per our previous reply, marking the case as "assumed answered" and moving it to "answered questions" pool.

Rich Holst's picture

I am receiving the same error but it is in windows 2003, and I am NOT receiving any errors in the event log that would indicate a corrupt NETLOGON.CHG

Peter Nikolaidis 2's picture

I am receiving this same exact error message on two new installations of BE 10 SBS edition running on factory installs of SBS 2003 from Dell.

I will try the proposed fix and report back.

Peter Nikolaidis 2's picture

I followed the procedure outlined above, and NETLOGON.CHG was successfully recreated, however I am still getting the same error message when attempting to create the IDR disc. "Error opening 'C:\WINDOWS\NETLOGON.CHG' The process cannot access the file because it is being used by another process.

Allan Krueger's picture

We are running Windows 2003 Server - SP1, Exchange 2003 and Backup Exec v10. We receive the netlogon.chg file in use when attempting to creat IDR image. We followed procedure above, rebooted and the file seems to be recreated and the permissions are returned to default for the SYSTEM account. We have also tried changing the permissions to DENY for all accounts (Dell's suggestion), with the same results. After changing the permissions and rebooting the server, the file seems to be absent for quite some time, then it re-appears. If we try and create the IDR disks during this absence, we get another error on the windowsupdate.log.

Am I being naive in asking, if NETLOGON.chg is recreated when you boot the server, why is BE attempting to access it for the IDR's in the first place?

IDR is of no use to us if we can't create the bootable CD - someone else who has had this issue (I know there are a lot of others) must have a solution - HELP!

Allan Krueger's picture

Thank you for your thoughtful reply, Veritas / Symantec.

This IS an ongoing problem that requires a solution! I have read other threads referincing the party line solution, but, Microsoft with W2K3 servers seems to have modified the code so that the NETLOGON.CHG file is deleted and recreated AUTOMATICALLY if the system account cannot write to it. If this is true, then Veritas / Symantec, you need to patch BE 10.x to solve this issue!

Some comment would be welcomed!

Henry Prins 2's picture

Has there been ANY kind of solution to this problem? Somone please clue us in here. I would like to be able to tell my clients that the software they paid for is ready for use if and when the time comes.

James Brennan's picture

I sure would like a solution as well.

I'm in the same situation as Allan. Tried to create IDR discs, got the netlogon.chg error, followed the instructions for the fix for that, got an error that windowsupdate.log was in use. Have not been able to find a solution for this.

Come on support people!

Where's the support?

Owen Iverson's picture

A year later and still no answers?! Wow. This kind of "support" seems to be representative of what I've seen with Symantec/Veritas since the merger. Really makes you wonder why so many people are trusting their business to this level of ... service? incompetence?

And who decides that an issue was answered? I see that there is "1 correct" answer?? Says who?

other threads on this issue:
http://forums.veritas.com/discussions/thread.jspa?...

http://forums.veritas.com/discussions/thread.jspa?...

http://forums.veritas.com/discussions/thread.jspa?...