Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Invalid archive ID

Created: 01 Jul 2014 • Updated: 02 Jul 2014 | 4 comments
This issue has been solved. See solution.

Good afternoon,

We've got quite a few error messages relating to an archive ID which does not seem to exist (at least, not any more).  The event ID 13360 is generated by the Directory Service, and the event ID 6469 is generated by the Storage Online service; examples of such are:

------------------------------------------------------------------
An error was detected while accessing the Vault Database 'EnterpriseVaultDirectory' (Internal reference: {CADODataAccess::ExecuteSQLCommand} [.\ADODataAccess.cpp, lines {1317,1319,1335,1353}, built Jul 10 17:51:36 2013]):

Description:  

An attempt was made to create a resource lock name with invalid values for ParentFolderVEID[14D61ADD982873A40BB0F76A74D5D985D1110000evserver1] and ContainerArchiveVEID[Not Supplied]
------------------------------------------------------------------
An exception has occurred.
 [Internal reference CArchiveAssister/CF/ce]
[
Details:
ContainerArchiveVEID: null
ParentFolderVEID: 1B9334478E78C514A9230D7EF980C7C2A1110000evserver1
FolderName:  
FolderPath:
]

------------------------------------------------------------------

A search for the archive ID results in a response of "Could not find an Archive or Archive Folder with the specified id"i

Our evault system processes overnight, so while I could run a dtrace, it would be a monster log file by the time I came back in.  Does anyone have any suggestions?  Thank you in advance,

Russell.

Operating Systems:

Comments 4 CommentsJump to latest comment

JesusWept3's picture

Probably best off doing an EVSVR in report mode

1. Go to a command prompt
2. CD \Program Files (x86)\Enterprise Vault\
3. Type 'evsvr' and press Enter
4. Type 'edit' and press Enter
5. In the drop down box next to Operation - choose "Verify"
6. In the drop down box next to Option - choose "ArchivesDirectory"
7. Bump up the threads to like 5 or so, or to match however many processors/cores the machine has
8. Press OK
9. Press Start
10. Wait for the EVSVR to complete 
11. Review the log file

If i had to guess it would be either that a transaction rolled back somewhere along the line OR you restored the Directory database recently.

Like you said, you could DTrace, you could either trigger on the Archive ID and include 10,000 lines which may catch it, you could Filter and use the Archive ID but its probably not going to give you the correct amount of information OR your best bet is to BackTrace using the archiveID

SOLUTION
NameTaken's picture

Hi JesusWept,

Thank you for the advice; I ran an evsvr verify, and the resulting log looks fine - no errors or problems raised.  Reading up on BackTrace, the triggers seem to be limit to Event IDs, or am I missing something?

While there hasn't been a roll-back or restore recently, I've only been here one year - so such may have occurred before my time.

Russell.

AndrewB's picture

i found this thread which describes a similar error. hope it steers you in the right direction. https://www-secure.symantec.com/connect/forums/upgrade-enetrprise-vault-10-sp1-sp2

Andy Becker | Authorized Symantec Consultant | Trace3 | Symantec National Partner | www.trace3.com

SOLUTION
NameTaken's picture

Hi AndrewB,

Thanks for the pointers, that looks like it might well be helpful. An SQL search of the ArchiveFolder table shows that there is one entry with no FolderName or FolderPath.  I'm not sure if that's the problem, but I'll try and associate the RootIdentity of the entry with a mailbox or public folder.  Just need to figure out how, as there isn't a RootIdentity of the same value in the Archive table.

Russell.