Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Inventory reports showing software that no longer exists on the PC

Created: 06 Jan 2013 | 5 comments

I am trying to create license count reports using 7.1.8280 Management console.  When I run the Reports \ Discovery and Invnetory \ Cross-Platform \ Software/Applications \ General Software \ Audit Software search report with the criteria of Visio.exe I get my computer listed in the results.

I re-imaged my machine a couple weeks ago and Visio is not installed.

When I open resource manager for my computer the installed software list does NOT include Visio.

Do I need to add a filter to the canned report to filter out removed software?

Jarett 

Comments 5 CommentsJump to latest comment

HighTower's picture

Check out my post in this other thread. It's a known issue and is supposed to be fixed in 7.5 but there is a workaround:

https://www-secure.symantec.com/connect/forums/how...

Jarett Dumas's picture

I removed the file C:\Program Files\Altiris\Altiris Agent\Agents\SoftwareManagement\data\SoftwareCache.xml and then I ran a task to gather inventory data again. After it finished successful I re-ran the report showing machines with Visio and my machine was still listed in the report.

The old and todays files both listed the same entries for Visio:

-

The report shows the following pathand file name which do not exisit on the machine.
Product Name Product Version Manufacturer File Size Internal Name File Description File Path File Extension
Microsoft Office 2010 14.0.6122.5000 Microsoft Corporation 1483352 VISIO.EXE Microsoft Visio C:\Program Files (x86)\Microsoft Office\Office14

The bad data must be somewhere in the SMP database not on the local machine.
any ideas?

Jarett

HighTower's picture

Instead of the Audit Software report (which I think is actually working properly as it's a record of the actual files, not the application) how about try this one?

Reports > Discovery and Invnetory > Cross-Platform > Software/Applications > Software > "Installed Software"

From there specify "Microsoft % Visio %" in the name field and then click Refresh.

mclemson's picture

I'd use the Installed Software report instead.  If it's still appearing, make sure you're running a full inventory--not a delta--as a delta will only add software, not remove it.

Mike Clemson, Senior Systems Engineer, ASC
Intuitive Technology Group -- Symantec Platinum Partner
intuitivetech.com

Christina_Lever's picture

Symantec is aware of the above issue, and working on a fix for it.

At the moment, the workaround is to apply the following steps in the affected client machine:

  1. Remove the file : C:\Program Files\Altiris\Altiris Agent\Agents\SoftwareManagement\data\SoftwareCache.xml
  2. Run full inventory.

This will remove the entry from the table Inv_InstalledSoftware

More information can be found at : http://www.symantec.com/docs/TECH183521