Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

ISCSI reboot problem with Veritas Cluster Server

Created: 12 Aug 2014 • Updated: 19 Aug 2014 | 4 comments
This issue has been solved. See solution.

Hi

I've a problem with iSCSI and VCS. Basically the problem is for RHEL. As you know when you reboot a system that uses iSCSI usually the name of the devices is always changing, (/dev/sdf to /dev/sdm) so I found a way to solve this issue with UUID (not cluster UUID). That's the ID you get with blkid command.

I've configured in VCS in BlockDevice section (/dev/sdX) but I've been looking for documentation about If I can configure UUID instead /dev/sdX but there aren't any references about it, so please tell me how should I configure UUID in VCS.

Thanks for your help!

Operating Systems:

Comments 4 CommentsJump to latest comment

Koven1's picture

I've tried setting BlockDevice like this:

UUID=62cb6ce3-4da8-4ccc-94b8-9015d0f6cae6

But it says that device does not exist, so i don't know how to fix this issue.

Koven1's picture

I've tried this persistent storage too but it's not working either

http://www.tuxgeek.org/news/configuring-persistent...

Any help would be appreciated.

Marianne's picture

Try iSCSI Persistent Binding.

See http://www.linux-tutorial.info/modules.php?name=ManPage&sec=5&manpage=iscsi.bindings

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Koven1's picture

I was thinking there was some kind of workaround at cluster level but I see I must solve it at OS level, anyway thanks for your help.

Best Regards.

SOLUTION