Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

Issue with Getalldepartments

Created: 21 Sep 2010 • Updated: 22 Oct 2010 | 7 comments
billasullivan's picture
This issue has been solved. See solution.

I have been working on a workflow for a new user and have come across an issue I was hoping the group could help with.

Here was the base structure so far.

  1. Detection check for current logged on user with relevant pieces to allow for the use of all information of the user who is filling out the form
  2. Form that says hi <current user> enter First name of user to create, enter last name of user to create.
  3. I then use all of that information to create the new account in AD (first.last = UserID, first.last@blah.com = email address, first last = common name)
  4. Email response to the person filling out form with details of account creation

That worked exceptionally good.

NOW

I wanted to add the selection of the "Department"

I injected a "getalldepartments" object in just before the webform, added a dropdownlist which used an array to show all available departments within the CMDB.  This list worked "YAY" 

Trouble is now when I run the form, the name of the person filling out the form is not correct.  First time it was "backup Exec" 

"Huh?" you say!!!

yeah me too.

I  still went through it and created a user called "Rob Robson"

It got created in AD with teh Department too.  Thats great.

Now when I run the form it comes up with Rob Robson for the person filling out the form.

<sigh>

 

Anyone have any idea on this?

Comments 7 CommentsJump to latest comment

Aaron - WEVO Group's picture

It sound like you're changing something in the setup or the test that isn't being conveyed here.  First, are you getting these same results when running the process both in Debug and when Deployed?

 

Second, are you closing the project every time, or are you simple directing back to the original page where you first displayed the user?  It really sounds like you are overwriting one of your variables in a later step of the process.  We may need a screen shot of the process flow to understand where this is.

billasullivan's picture

Yes it is the same in debug as well

I am closing the project every time 

Attached are 3 screenshots of my workflow. 

Note: I have since added some more fields like location

New_User_Main.png New_User_Embedded Decision.png New_User Webform.png
Aaron - WEVO Group's picture

This is just a guess, but it may be something in the "Copy data element" or "initialize data" components.  Are any of those using the variables that are changing?

billasullivan's picture

Nope they just hold the information gathered from the "Get Current User" and "Get User with Details" objects.  Then it allows the information for "use" downstream.

No weirdness....because I really don't know how to make anything really complex as of yet.

It all worked just great until I added the getalldeparments component

billasullivan's picture

Found the issue

Because I re-deployed this project, my Windows Authentication did not carry over. 

As per THIS video, there are a few edits that you need to do to be able to use the Get Current User component.

 

I am not just troubleshooting a few other minor things and should have this fixed within the hour

Thanks for the advice Aaron....always appreciated :)

SOLUTION
Aaron - WEVO Group's picture

Good to hear.  I didn't think to check that because there is a way to avoid having to change it multiple times.  If you change the web.config file that is in the designer project folder  c:\Program Files\altiris\workflow designer\WorkflowProjects\YourProjectName  then every time you deploy it will keep those settings.  Hopefully this will save you some time and headaches in the future.