Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Issue with granular restore option SSR 2013 - not seeing any data on backups

Created: 08 Feb 2013 | 12 comments

Hi All, wondering if someone can help me.

I have been running backups for about a week now. At first all seemed good, I restored the base image to a new server and was able to perform a granular restore on e-mail. However, now that the backup has run several incrementals I have come into some trouble; when I select the sv2i file nothing appears in the granular restore window.

The backup seems to be fine and logs suggest the data backed up fine (even with verify enabled). Has anyone encountered this issue, not sure what has gone wrong. Many thanks

Jon

Comments 12 CommentsJump to latest comment

Chris Riley's picture

So it works for a full but not for a full+incrementals? Hmm.

What version of Exchange (including service pack) and Outlook (on the machine where you are using GRO for the restore) are you using?

jonnob's picture

Exchange 2010 + SP2 (and Outlook 2010) on the Domain Controller that SSR 2013 is installed on.

But I did upgrade Exchange 2010 from SP1 to SP2 after the base image was performed. I'm not sure if this would break things, but a bit concerning if it does because I do run updates once in a while.

Cheers.

Chris Riley's picture

Not sure if the upgrade from SP1 to SP2 would cause this or not.

Do you have another machine where you could try GRO on? It would need to be same bit-level as the Exchange server.

Something else you could try; run an independent backup (full only) to a new folder (assuming you have enough space). Then see if a GRO restore works from this backup.

jonnob's picture

Hi Chris,

  I run an independent backup (fully only) to a different location. I then tried to open it with GRO and it worked fine?

Not sure what is going on here then, bit concerning if the updates will break my recovery point sets. Cheers.

Update on 11/02/2012 @ 00:04

----------------------------------------------

Hey, I've now let my weekly fully recovery point set run to the original location and I have the same issue. Not sure what is going on here?

And there only seems to be one .sv2i. No idea how I can open different recovery point sets created earlier. 

Thanks.

Chris Riley's picture

And there only seems to be one .sv2i. No idea how I can open different recovery point sets created earlier.

There will only be one .sv2i file if you are using the same destination folder.

Using GRO, you can select the relevant recovery point file by date (top-right corner within GRO).

Are you saying the newly created full backup shows the same issue?

jonnob's picture

Hi Chris,

  That's correct.I try to open the latest .sv2i file and it sits there for a minute, then I get nothing. It doesn't freeze, just doesn't show any data.

My schedule runs a new full backup every Sunday, then incrementals throughout the week. If I look at the backup history I can see it has performed a full backup on Sunday (and the size of the backup looks correct)...But it doesn't show anything in GRO.

I can mount the backup fine as well, and the backups are verified.

I am about to try and full restore to a different PC to see if that works.

Update at 15:06

I am now running a restore (using the boot disc) to restore from the latest full backup. So far it is at 12% and seems to be working fine. It did throw up a message prior to beginning the restore though about the server being under heavy load during the backup, and something about enabling VSS quiescing (whatever that means - seems strange as I ran it at 00:30)

jonnob's picture

Hey,

  The restore using the boot disc has now finished. The latest backup has restored perfectly fine.

So I assume nothing is wrong with the restore point. Very confused.

Any thoughts? I am very lost...

Note: Well, all is working apart from the USB keyboard and mouse at the login screen. Same issue for PS2 mouse and keyboard as well, but both work fine prior to login screen 

Update at 17:35

Okay, the keyboard and mouse is now finally recognised at the login screen. Wow, that tooks ages. I can only assume this is normal?

Otherwise, the restore works perfectly fine. So something is up with that GRO and I'm not sure...

jonnob's picture

Hi,

  I've been tested the restored backup for a few hours now, and it really doesn't seem clean.

Various services were stopped (DNS, DHCP and Exchange Information Store), and the database is in dirty shutdown state (checked this via eseutil, and it wouldn't mount in the Exchange Management Shell).

I am not sure if this is related to the GRO situation, but something doesn't seem quite right. The backup verified okay.

The only change since the succesful restore I ran last week is a few Microsoft updates and Exchange Server 2010 SP2 upgrade.

Thanks

Chris Riley's picture

So if you create a new recovery point set (full + several associated incrementals) - does this work in GRO? I guess this may take a few days of backups to run before you are able to try this...

jonnob's picture

Hi Chris,

  I started again with the backup. I ran a full recovery point set on 13 feb. I then tried to restore this and all was fine.

I then left the backup running via my schedule (incremental sets during last week and a new full set yesterday).

However, I have the same issue again this evening. GRO not showing the contents of the backup.

Chris Riley's picture

I think this is going to need a support case opened so we can look at this in more detail. Can you go ahead and open a case?

Let me know what the case number is and I will try and help although I can only do this if you are based in the EMEA region.

Dave_H's picture

Hello,

Sorry to butt in here, but I think you may be missing something.

That image is from Ghost 15, not SSR but I'm sure it's the same problem.

That means the image was made without volume shadow copy and would explain your statement " I've been tested the restored backup for a few hours now, and it really doesn't seem clean". Without VSS working correctly your not going to get a good image of files in use. I also don't understand why it says "High Load" it would be more informative to simply say VSS is busted.

It's usually due to a problem with one of the shadow copy providers, services, or a COM+ catalog problem.

You can verify this by creating a cold image from the recovery disk and comparing the "behaviour" of that restored image.  (the shadow copy services and providers will work correctly from the recovery disk).

Best of luck,

Dave