Video Screencast Help

Issue with PGP Desktop 10.1 using 25%-50% processor time

Created: 11 Feb 2011 | 15 comments

I have PGP Desktop 10.1, and it is using 25%-50% processor time for pgptray.exe per user who is logged on.  It is running on a Citrix server, and is setup so it only runs for the authorized users.  10.0 didn't do this, and I cannot find my 10.0 installer to downgrade.  Any suggestions?  I've already done a repair through add/remove programs.

Comments 15 CommentsJump to latest comment

John Powell's picture

Forgot to mention, the server is running Windows Server 2003.  Email server is Exchange 2003.

Jonathan Brain's picture

We have seen issues with 9.x on desktops where PGP consumes 50%CPU.  We have found relief by unregistering PGPFSSHL.DLL on all workstations.  The PGP Tech that I spoke with mentioned that it had to do with DFS shares, which we do use.

John Powell's picture

Thanks.  So far, this seems to be working.  I will see what happens with it on both servers.  If it works, I'll mark it as a solution.

John Powell's picture

OK.  It worked for a short while, but now, the system is back to its old tricks.  Do I need to have the dll unregister at startup every time to avoid this?  Thanks.

Jonathan Brain's picture

Once the dll is unregistered, it should stay that way.  I would assume the same would be true if you preformed it on a server.

Jonathan Brain's picture

John,

This may be a better option for you to use.  We stopped using it because in version 9.12 (our current standard) despite the fact that you told the MSI to not install netshare it laid down and registered the dll files anyway.  I recently read the release notes for version 10 and they report that this now works as it should, I havent tested it yet though.

PGP Desktop 10.1.x - Resolved Issues

Look under PGP Desktop 10.1.0 -> PGP Netshare -> Second bullet point

PGP NetShare DLLs will no longer be registered in the system if the PGP_INSTALL_NETSHARE=0 option is used in the command line using msiexec.exe to install PGP Desktop. [23267] 

PGP Desktop Installation MSI Switches

FlexDigital's picture

PGP tech looked at our case and said

"It looks like this is indeed a reported bug that our development team is aware of. They have a fix for it scheduled in the next major release of PGP Desktop. For the time being, you will have to stay on 10.0.3 or lower it appears"

 

We are waiting for 10.2 to see if it fixes the issue.  We tried all the switches to disable but couldn't fix it.  We are currently back at 10.0.0 and no problems on this release.

Sarah Mays's picture

it would be nice for PGP to publish a list of known issues/bugs.

unfortunatley i can't unregister netshare because we actually use netshare on the server that has this issue.

SDTSymantec's picture

I was able to track down the bug causing this problem. It is fixed in PGP Desktop 10.2 however I do not have a firm release date.

Jonathan Brain's picture

Are you able to post technical details about whats happening? Is there anything that can be changed in the environment that might relieve the issue until 10.2 is released?

FlexDigital's picture

Does anyone know if this Citrix Issue is fixed in the 10.1.2 version.  The release notes on the ersion doesn't say.  Of course my case with PGP probably didn't migrate over. If not when is 10.2 going to be released???

Any help from a PGP tech support person would be great!

 

UGHHH....I still have so many problems finding support now that PGP went to Symantec.  Where do we actually create cases?  Where are my license strings and downloads?

s3a0tt3r's picture

Ever since install PGP Desktop 10.1.2[Build 9], I have been having a problem with explorer.exe getting into a state where it consumes an entire CPU (or Core, not really sure there).  The CPU usage hangs at 50%.  Then eventually a second explorer.exe process gets launched and consumes the rest of the CPU.  Takes for ever to get TaskMgr up so I can kill the processes.

The problem presented 2-3 times a day, sometimes in as little as 30 minutes after a reboot.  I removed PGPTray.exe from my startup folder and the problem stopped.    Since then, I've been up and running for a day and a half.  Not definitive proof, but I'll post updates as necessary and more data if requested.

Windows XP Pro SP3

Dell Latitude D620 (I'll hunt down the specs if anybody thinks they need them to figure this out.)

 

Thanks in advance

Grant

s3a0tt3r's picture

Sorry for the chatter.  Probably something else.

 

Grant

b.alekseenko's picture

Hello.

I have PGP 10.1.2. Subject problem still actual.

Any ideas?

Alex Medved's picture

Hello.

We use PGP 10.1.2. x64 + Win Serv 2008 x64 in Terminal

Subject problem still actual.

Any ideas?