Video Screencast Help

Issue restoring backups from tapes

Created: 09 May 2014 | 17 comments

Hey Folks, 

I've been having some issues restoring backups. It all started around a week ago, I tried to restore some data and the it kept failing so I tried to run a catalog and it failed. I then noticed that there where many alerts regarding failed catalog attempts so I tried troubleshooting it and eventually I deleted the catalog folder contents and started from fresh. 

Now when I run a catalog it doesn't fail, however, when I run the restore it prompts me to run a catalog which I already have. I've tried running an inventory as well. 

Any ideas?

Operating Systems:

Comments 17 CommentsJump to latest comment

AmolB's picture

What version of BE you are using?

Could you post exact error message that you are getting while restoring data.

pkh's picture

If you are ding a backup from tape then try duplicating the backup set to disk before doing the restore

lmosla's picture

Along with providing the info that AmolZeroCool requested...

In Backup Exec, go to Tools|Options and click on “Catalog” section.

Uncheck the "Use storage media-based catalogs" option and rerun the catalog job again and restore.

for reference see:

NoSun's picture

The option seems to be greyed out, It is unchecked however.

NoSun's picture

Using Backup Exec 2010 R3 ( Version 13. REV 5204).

When trying to restore a tape, I get the message below:

The selected media was not found in the catalogs. You must first catalog the media if you want to use it for restore operations.

I run a catalog and even an inventory and there are no errors, however when I go to restore data I get the same message. 

lmosla's picture

It might not be able to resolve the correct backup dates.  Try going to the restore job properties and under selections uncheck the restore dates.

NoSun's picture

Nope, still getting this same error. 

 e0000904 - An error occurred while retrieving catalog information
Mai Ali's picture

Try to do following steps

  1. Click on tools select options
  2. In the right pane select Catalogs
  3. Uncheck Use Media Based Catalogs
  4. Click OK and then try to catalog that media again

Also you can check below link

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

Twitter: Mai Ali

pkh's picture

Why are you repeating information which has been posted earlier?

NoSun's picture

Tried that KB and it's still not working. Anyone have any other ideas? 

NoSun's picture

To clarify, I am still getting the same error. 

NoSun's picture

One thing that I have noticed is that when I go to restore the tape and look at the general info, it tells me that the size of the tape is 0kb. However, looking at the tape in the loader it says that it has 1.5TB of data. 

A catalog and Inventory do not fix this issue. 

CraigV's picture

...have you tried to repair the BEDB as per the TN below?


Alternative ways to access Backup Exec Technical Support:

lmosla's picture

hmmm...  make sure all of your Live Updates are installed

do you have any Windows application event errors?

please see this about the issue and workaround