Video Screencast Help

Issue with reusing BTD folder disk space

Created: 21 May 2013 | 7 comments

We have version 12.5 revision 2213 (fully patched SP4) of Backup Exec running on a fully patched Windows 2008 Server.  My issue is that even though my media set has an OPP set to "none" after about 12 days my daily BTD folders run out of space.  It doesn't appear that my backup jobs are reusing the previously used space (i.e. the .bkf files).  My daily (Mon-Fri) backups are setup to do an incremental backup with my weekly (Saturday) backup doing a full backup to a differnt BTD folder.  I only need to keep 1 week of backups at any one time.  Media Management under Options is set up with None for the OPL and to overwrite recyclable media before scratch media.  BTD is setup with a maximum of 100 files, maximum file size of 5 Gb and the low disk threshold of 2 Gb.  After 12 days or so the daily backups begin to fail with alerts that the daily BTD folder is out of free space.  Some of the .bkf files do get overwritten during that process.  Can anyone help me figure this out?  The only way I have been able to get it to work is to associate the files with the Retired Media set and delete the files manually or completely redo the BTD folders.

Operating Systems:

Comments 7 CommentsJump to latest comment

SFG's picture

Is your B2D part of a staged backup, the final stage being duplicate to tape?  That's what I do here.  I set the B2D media sets to expire after 23 hours, so the next backup after 24 hours deletes the current set, leaving me with one.

I do full backups daily so you would probably need to switch to daily fulls for this to work.

Scamby's picture

No tape backup is involved.  We are just doing a full backup to disk on Saturdays.  Incremental backups to disk on Monday thru Fridays.  Then repeat.

Colin Weaver's picture

Do you have any kind of security software that might somehow be limiting operations against existing files on the disk (but allowing creation of new ones (thinking anti-virus or similar) Note: We do recommend that b2d folders are excluded from active security software blocking

Also what type of disk holds the storage (i.e. internal disk, SAN disk, NAS/Share, USB, RDX)

Scamby's picture

We do have SEP running.  The folders were not excluded but are now.  I will see what I get tonight when the backup runs.  The disks are on a Netgear ReadyNAS Pro 4 using iSCSI.

Scamby's picture

Excluding from SEP didn't work.  Same result.

pkh's picture

Media Management under Options is set up with None for the OPL

When you do this, any OPP does not apply.  You should set your OPL to at least Partial.

Also, set your OPP to 1 hour.  I find that I get funny results when I set the OPP to 0 hour.

Scamby's picture

Made the changes suggested.  Running a backup now.  Will let you know what happens.