Video Screencast Help

issue with windows 7 remote desktop / 2010 internet security

Created: 26 Dec 2009 | 9 comments

I have two computers in my house and since i have installed windows 7 and norton internet security 10 i cannot for the life of me get windows remote desktop connection to work.

Nothing fancy here.  all computers are on a default "workgroup".  I tried opening the the 3389 port - not sure if i did it right though.  same issue.  keep getting:

"remote desktop can't find the computer "spencer-pc". this might mean that "spencer-pc" does not belong to the specified network. verify...."

Any help would be appreciated. 

Comments 9 CommentsJump to latest comment

Dev T's picture

Hello,

Are we able to ping both the computers with name and ip?

Have you enabled "Network Discovery" on windows 7 Machines?

Its a best practice to have a "Support Contract" with Symantec...
 

rtruesdale's picture

 My computers are by default recognizing each other though strangely enough if i try to ping the computer i'm not getting a response.  See's it but cannot ping it.  seems as though norton is blocking the reply.

ping spencer-pc

"ping request could not find host...."

I also tried turning off the norton firewall and that made no difference.

Rafeeq's picture

In the Norton Personal Firewall, you need to go to the Advanced settings and allow TCP Port 3389 for Remote Desktop.

Please fist disable the Windows Firewall and enable the Norton Firewall.

Next, please follow the instruction in the following document.

http://service1.symantec.com/SUPPORT/norton2008.nsf/0/94f15aedb258d4de6525731c005abd15?OpenDocument&seg=hm&lg=en&ct=us

Please let me know if configuring the Norton Firewall as described in the document resolves your issue. 

rtruesdale's picture

 This is still not working.

If i "disablesmart firewall", will this factor out norton as the issue?

very frustrating.

rtruesdale's picture

I disabled all of norton internet security and still getting blocked.

can windows 7 basic remote to windows 7 basic?

btw - windows firewall is disabled 

rtruesdale's picture

figured out my problem.  can't go windows 7 basic to basic.

Which editions of Windows 7 include Remote Desktop Connection?

All editions of Windows 7 include Remote Desktop Connection.

  • You can use Remote Desktop to initiate a connection from any edition ofWindows 7.

  • You can connect to computers running Windows 7 Professional, Windows 7Ultimate, or Windows 7 Enterprise.

  • You can't use Remote Desktop Connection to connect to computers runningWindows 7 Starter, Windows 7 Home Basic, or Windows 7 Home Premium.

Imagona50's picture

To get get remote desktop to work with NIS 2010 you need to open NIS then click Settings  in the Network part of the GUI. 
You then under Smart Firewall you Click on Configure On Advanced Settings. 
Then on General Rules Click Configure. Then ADD Select Allow and then next and Select Connections to and From other computers.
Then Click Next under what Computers leave at Any and select Next. 
Then Select the Type of port and select Only Communications that match all types and ports listed below: and then Click Add to add the port you need to select Individually specified ports as Remote desktop isn't listed as a port. 
And enter the port 3389 you need to add it for both Local and Remote. 
Once both Local and Remote are in there click next. 
Select Log and or NAT traversal and click next. 
Name the Rule you made click next and Finish if it looks correct. 
Then Click OK to close all the NIS windows and it will now allow Remote desktop connection throught NIS 2010

Moondoggy's picture

Onc question....  When it asked for a protocol I left it as a defult which was TCP and UDP was that correct?

TimLC's picture

I have followed every instruction here and anywhere else on the web I can find.  I'm trying to connect an XP machine to my W7-Professional machine with Norton Internet Security 2010.  Interestingly, I can use Remote Desktop from the W7 machine to the XP machine, but it won't work the other way around. 

In Norton, I have added both General Rules and Program Controls per the instructions above, disabled any W7 firewalls, disabled Norton firewalls.  Nothing works.

Any ideas?