Video Screencast Help

Issues with EV\CA after applying MS Patches

Created: 12 Nov 2011 • Updated: 19 Nov 2011 | 16 comments
This issue has been solved. See solution.

Has anyone seen any issues with EV after installing the latest Microsoft sercurity patches?

After applying them on Thrday our CA server is unable to view items and we get the folliwing error:

 

Event Type:    Error
Event Source:    Accelerator Service Processor
Event Category:    None
Event ID:    375
Date:        11/12/2011
Time:        6:31:29 PM
User:        N/A
Computer:    RESCA01
Description:
APP AS - Customer ID: 6 - An Error has occured when retrieving Item
SaveSetID: 201111110981365~201111110311200000~Z~20406AF28FA88F8956678A9BA1B1FF31
VaultID: 14234AB7249F0194FA71709BAE05B3CBD1110000reskvs01a
Format: XML
sAttachmentID: 0.
System.Runtime.InteropServices.COMException (0x80040306): An internal failure occurred. Internal Error: 'The parameter is incorrect.  [0x80070057]'.
   at KVS.Common.VaultItem.Item.CallEcmAPI(String sSaveSetID, String sVaultID, String sAttachmentID, String sFormat)
   at KVS.Common.VaultItem.Item.GetEcmArchivedItem(String sSaveSetID, String sVaultID, String sAttachmentID, String sFormat)
   at KVS.Common.VaultItem.Item.GetItemFromECM(String itemID, String sSaveSetID, String sAttachmentID, String sFormat, String sVaultID, MessageType msgType)
 

 

When this happens we get this corresonding error on the EV server in the system log;

 

Event Type:    Error
Event Source:    DCOM
Event Category:    None
Event ID:    10016
Date:        11/12/2011
Time:        6:20:39 PM
User:        RESOURCES\kvsadmin
Computer:    RESVAULT02
Description:
The application-specific permission settings do not grant Local Launch permission for the COM Server application with CLSID
{7DB927A8-A2F9-4B72-B10B-359353D3A39F}
 to the user RESOURCES\KVSADMIN SID (S-1-5-21-1659004503-527237240-725345543-2065).  This security permission can be modified using the Component Services administrative tool.
 

 

Comments 16 CommentsJump to latest comment

JesusWept3's picture

Have you tried setting the appropriate permissions via dcomcnfg and restarting the admin service?

Andrew Tankersley's picture

Thansk Tony - the article looks promising. However when I apply the permissions as mentioned in DCOM and restart the services, the DCOM permissions revert back to thier previous settings. Am i missing something?

Ameen's picture

I think the easiest way of fixing the issue is to re-install enterprise vault on the server. Technically its called re-apply binaries of EV.

It may looks strange but this is easiest possible way of fixing it. Hope this helps!

 

JesusWept3's picture

The admin service will reset permissions if it detects a change on the com properties
You can also try updating the password through the VAC and it will reset DCOM permissions and services on all servers, Ive had similar errors before and the resets help

Just as a matter of interest, what does the GUID relate to in the dcomcnfg? The storageonlineopns)?

Andrew Tankersley's picture

Exactly - storageonlineopns. And any changes to the DCOM permissions get wiped after services are restarted. I'll try the VAC soulution....

JesusWept3's picture

Have a look at this script from Wayne Humphrey and see if it sheds any light
Run it from the CA server first under the account that runs the CA services

https://www-secure.symantec.com/connect/forums/fet...

JesusWept3's picture

No, it will attempt to retrieve the item via similar mechanisms as CA/DA uses

Andrew Tankersley's picture

I can retrieve the items on the vault server using the web based saerch tool, but I will try your suggestion tomorrow

Andrew Tankersley's picture

Just to follow up - we wound up rebuilding our primary EV server in order to restore services.

SOLUTION
AndrewB's picture

are the same MS hotfixes installed as before?

Andy Becker | Authorized Symantec Consultant | Trace3 | Symantec National Partner | www.trace3.com

Andrew Tankersley's picture

Yes..... Clean build of the OS (W2k3 with SP2) and with all current patches applied....