Video Screencast Help
Give us your opinion and win with Symantec! Please help us by taking this survey to tell us about your experience with Symantec Connect, so that we can continue to grow and improve.  Take the survey.

Issues by updating the Databas shema from 12.1.1 to RU2 now

Created: 16 Nov 2012 | 9 comments

Hello Team,

I am running serveral SEPM Version 12.1.1000.157.

I just have started to upgrade the Testcenter server and an error occurs at the first server with an external DB:

2012-11-16 09:31:25.920 THREAD 28 SEVERE: SQL Exception:
2012-11-16 09:31:25.920 THREAD 28 SEVERE: SQL Command:   IF NOT EXISTS [..]--> shortened
2012-11-16 09:31:25.920 THREAD 28 SEVERE: SQLState:  S1000
2012-11-16 09:31:25.920 THREAD 28 SEVERE: Message:  Invalid filegroup 'FG_INDEX' specified.
2012-11-16 09:31:25.920 THREAD 28 SEVERE: Vendor:  1921
2012-11-16 09:31:25.920 THREAD 28 SEVERE: java.sql.SQLException: Invalid filegroup 'FG_INDEX' specified.

Has anybody the same issue??

(

Comments 9 CommentsJump to latest comment

Christoph_A's picture

nonono!!

I am not going to delete my database!!!

Crazy idea!

It happened during the upgrate from SEp12.1 to 12.1.2 RU2. So of corse a DB called SEM5 exists.

Any other idea? Is it possible that I have insufficient rights at the external DB? It is hosted by the db team. but usually they do not touch the given rights from useres.

Thank you!

Christoph_A's picture

More info:

It seems that during the upgrade a table called "SE_COMPLIANCE_CRITIERIA_2" will be set up, but the filegroup "FG_INDEX" is not existing. We just have "PRIMARY" as filegroup.

Hm. I do not know what to do....

Christoph_A's picture

Hello to all.

Does anyone have an idea what to do now? Currently I have a non working upgraded SEP Manager and an old SEP manager that is able to use the old database. 

But now I am sure not to try the upgrade in the production area.

Sorry.

SameerU's picture

Have you followed the link provided by Pete ?

It will help you....

Regards

Christoph_A's picture

Hi,

Finally I was able to fix this issue!!!
It seems that our database admins changed the file groups. I do not know why but they did it. This lead to one single database file and one log file.

Now we have installed a clean SEPM and added the filegroups and files manually to the database server.

But my admins told me that of corse they never changed anything.. :-)

Thanks to everyone!

Dushan Gomez's picture

filegroups ?

What do you mean by that ?

Dushan Gomez
IT Manager
VCP 4 and 5 | MCITP Exchange Server | MCTS SharePoint Server | MCP Windows XP