Video Screencast Help

It requires to enable vxdctl after the rebooting the server

Created: 23 Sep 2013 • Updated: 29 Oct 2013 | 2 comments
This issue has been solved. See solution.

Hi,

I installed veritas in a training server recently. I created dgs,sub disks,plexs and volumes, after the reboot server those are invisible again need to be enabled vxdctl.

please suggest me.

Thanks in advance.

Operating Systems:

Comments 2 CommentsJump to latest comment

Marianne's picture

Which version of SF? Which version of Solaris?
What type of storage? SCSI or SAN attached?

vxdctl enable is not normally necessary.

Can you check /var/adm/messages to see at which point during boot process devices can be seen?

Were diskgroups in 'imported' state before the reboot?

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

SOLUTION
mikebounds's picture

If diskgroup was deported before rebooting, or if diskgroup was imported with -t option (-t option disables reimporting automatically when the system is rebooted) then this is normal and you just need to import diskgroup.

To check diskgroup is imported, use "vxdg list" and you can also use "vxdisk -o alldgs list" to see which diskgroups are deported (deported diskgroups are shown in brackets)

If diskgroup is imported but can't mount volume as the volume is not there, then this means the volumes need starting which you can do using "vxrecover -sg dg_name" (or vxvol -g dg_name startall).

Mike

UK Symantec Consultant in VCS, GCO, SF, VVR, VxAT on Solaris, AIX, HP-ux, Linux & Windows

If this post has answered your question then please click on "Mark as solution" link below

SOLUTION