Video Screencast Help

Items stuck pending for all users

Created: 13 Feb 2013 • Updated: 06 Mar 2013 | 2 comments
This issue has been solved. See solution.

EV version  single server,  OS: 2008r2

Backups by NetBackup - Enterprise Vault policies, no watchfile/triggerfile/etc. EV policy is supposed to handle it all.  (NBU 7.5.03 on server 2008 std)

I have been banging my head on this issue a while, and now its happening again in another date range. I have a case in with symantec but they are not getting anywhere with it, and take too long to respond. I seem to have better luck with good answers from the community anyways :) I will try to outline basics of the issue, and hopefully someone point me down the right troubleshooting path with it. By policy we archive after 30 days, delete shortcuts after 90.

From 11/22/2012 around 8pm to 12/5/2012 around 6pm


From 12/21/2012 around 7pm to 1/14/2013(and growing)

All the messages in all mailboxes during those time periods are stuck in pending state. The messages do appear in the vault (verified from both time periods).

Backups are all completing successfully, full and incrementals. I am showing no errors with them in netbackup.

I looked through the technote: TECH66202 and towards the bottom there are a couple SQL queries that will return how many items are waiting to be indexed, and waiting to be backed up.  I ran the first and returned 0 (waiting index), I run the second and return 380,000 items on the journal store and 490,000 items in the mail store.  I had ran a full backup directly before running this. I tried running it again the next day after an incremental. The values only continue to grow.

That makes me think that the issue has something to do with the backups, but im not sure where to go from there.  I have attempted to set the 'Pending Shortcut Timeout' to 0, and then run a report against my mailbox, which did switch the icon from shortcut pending back to a regular mail item, but then the next night they went back to pending.

Any thoughts? Can I provide any more information to help? Any ideas where I should start my next troubleshooting steps?

Thanks much!

Comments 2 CommentsJump to latest comment

Nate.D's picture

This was resolved by switching to using a trigger file rather than the archive attribute. I think there should have been a way to fix it with the archive attribute, but that was what tech support walked me through.

If I was helpful in solving your issue please mark my post with a thumbs up or a solution!  Have a great day :)

Rob.Wilcox's picture

Glad you got it sorted..  Trigger files are a decent way to go I think.