Video Screencast Help

Java Console taking time to login

Created: 13 Mar 2014 | 4 comments
Zahid.Haseeb's picture

Environment

OS = RHEL 6.3

SFHA/DR

JavaConsole version = VCS_Cluster_Manager_Java_Console_6.0.1_for_Linux.tar.gz

Query

It seems that JavaConsole taking time to login.

Furthermore sometime it happens that I OFFLINE a resource from Java Console and Java Console seems doing nothing(means on resource no arrow showing downwords) and respond after a while but the resource keep Online.

 

 

Operating Systems:
Discussion Filed Under:

Comments 4 CommentsJump to latest comment

Gaurav Sangamnerkar's picture

Hi Zahid,

There can be 2  suspicions of what I would believe

1. Network between your console machine & actual server -- did you see any packet drops between them?

2. Is the "HAD" running without any CPU/memory contention, if HAD is having issues & not responding, it may be because of server being heavily loaded

Any evidences on both of these ?

 

G

PS: If you are happy with the answer provided, please mark the post as solution. You can do so by clicking link "Mark as Solution" below the answer provided.
 

Zahid.Haseeb's picture

- Its not connectivity issue. I also happen on production server when I run the JavaConsole on Production Server.

- Is the "HAD" running without any CPU/memory contention

top command is show much idle resources. Any VCS log help in this regard ? I run the below command but does not find something suspecious

less /var/VRTSvcs/logs/engine_A.log | grep usage

Any comment will be appreciated. Mark as Solution if your query is resolved
__________________
Thanks in Advance
Zahid Haseeb

zahidhaseeb.wordpress.com

Gaurav Sangamnerkar's picture

This is not a issue with product anyways as product is tested & works on n number of setups .. one of the area explained above needs investigation

Because the connectivity exists (though its slow), we can't suspect any firewall sort of settings as it would have completely blocked the connectivity .. if its slow, it could be that there are packet drops OR too many hops to reach the server OR network speed as GUI console is appearing slow

If above network parts are OK, then suspicion is the server itself running with high usage. Try to look more at the time when you connect to console, at the same time you are able to see idle resources ? At the same time, try some network troubleshooting like trace route etc to see how long is delay ..

third suspicion is your laptop/desktop itself, do you have any tools like threat protection or any other security software installed, check the logs on that as well if you find something relevant.

 

G

PS: If you are happy with the answer provided, please mark the post as solution. You can do so by clicking link "Mark as Solution" below the answer provided.
 

Zahid.Haseeb's picture

Thanks Gaurav for your kind words on the subjected query. Furthermore I felt on more thing is that, I did offline(again and again) a resource but it keep showing me online, when I open a new hagui it then show me offline, I thought its something related to refresh the javaconsole session.

Any comment will be appreciated. Mark as Solution if your query is resolved
__________________
Thanks in Advance
Zahid Haseeb

zahidhaseeb.wordpress.com