Video Screencast Help

Java Error when attempting to Import Software from console on workstation

Created: 09 Apr 2013 | 8 comments

I've got an interesting one here that I have not been able to solve via the KB's availabile from Symantec. We've got a new 7.1 environment. When we go to Import Software form a workstation (link a migrated package to a new Software Resource), Java loads but then we get an error that doesn't allow us to browse the P: dir up on the SMP. We are using the 'Local Directory on Notification Server' option. This works fine when accessing from an RDP session on the actual SMP.

 

After Java loads we get a message where the applet should load that says Error : Click for details. when you click the error you get the following message below:

(Unfortunuatley although there are a couple of KB's that reference this errror neither of them have solved the issue). One referenced a Proxy setting in IE and the other referenced a missing file but referenced a dir that only exists on the SMP itself.

 

The Error Generated:

load: class PackageDefinition.class not found.

java.lang.ClassNotFoundException: PackageDefinition.class

                at sun.plugin2.applet.Applet2ClassLoader.findClass(Unknown Source)

                at sun.plugin2.applet.Plugin2ClassLoader.loadClass0(Unknown Source)

                at sun.plugin2.applet.Plugin2ClassLoader.loadClass(Unknown Source)

                at sun.plugin2.applet.Plugin2ClassLoader.loadClass(Unknown Source)

                at java.lang.ClassLoader.loadClass(Unknown Source)

                at sun.plugin2.applet.Plugin2ClassLoader.loadCode(Unknown Source)

                at sun.plugin2.applet.Plugin2Manager.createApplet(Unknown Source)

                at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Unknown Source)

                at java.lang.Thread.run(Unknown Source)

Caused by: java.io.IOException: Authentication failure

                at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)

                at java.net.HttpURLConnection.getResponseCode(Unknown Source)

                at sun.plugin2.applet.Applet2ClassLoader.getBytes(Unknown Source)

                at sun.plugin2.applet.Applet2ClassLoader.access$000(Unknown Source)

                at sun.plugin2.applet.Applet2ClassLoader$1.run(Unknown Source)

                at java.security.AccessController.doPrivileged(Native Method)

                ... 9 more

Exception: java.lang.ClassNotFoundException: PackageDefinition.class

 

Any thoughts on this? We are ramping up on the road to get 7.1 deployed but only being able to import software from the SMP itself is a pain.

 

Thanks

DC

 

 

 

 

 

Operating Systems:

Comments 8 CommentsJump to latest comment

Andrew_Shishkov's picture

Can you check log created in C:\Users\USERNAME\AppData\LocalLow\Sun\Java\Deployment\log location on the machine where SMC console is launched?

Have you checked Internet Explorer Security Settings -> Scripting of Java Applet setting value? Is it Enabled or at least prompt?

 

Thanks,

Andrew. 

D-Chad's picture

Andrew,

 

I checked the location and there actually aren't any logs being generated under my user ID.

 

As for IE settings, I rechecked and the Java Applet Setting is in fact Enabled. Any thoughts?

 

I've seen this error over several workstations all running 6 Update 18 or higher and one wiht the latest version of 7. All exhibit the same behavior,

 

Let me know if you have any additional thoughts.

 

Thanks

DC

Andrew_Shishkov's picture

Ok, then try following:

1) Go to Control Panel. Search by "Java". You should find "Java (32bit)" item (Java Control Panel).

2) Open it, go to Advanced tab, change Java Console node to Enabled and press Ok.

Java Console.png

3) Java Console should be opened. Press 5 to enable hiest level of lohgging.

4) Start import of software to SW catalog and check output to Java Console (you should se something similar to screenshot below).

Java Console - logging.png

Thanks,

Andrew.

ehsu's picture

Try this one. It works with 7u25 and 7u40 that I tried. It should work with other 7uXX as well.

Disable certificate revocation check.

JavaDisableCRLCheck.jpg
Christopher Lüpnitz's picture

Hi Everyone,

I'm experiencing the same problem after updating to Java7u51. I've tryed clearing IE and Java caches and deactivating the certificate check but the error still persists.

This error occurs on WinXP / Win7 / IE8 / IE9 with Symantec Management Console Version 7.1.8280

The output of the Java Console ist not helpful:

Java-Plug-in 10.51.2.13
JRE-Version verwenden 1.7.0_51-b13 Java HotSpot(TM) Client VM
Benutzer-Home-Verzeichnis = C:\Dokumente und Einstellungen\%username%

Trace-Ebene auf 5 (alle) setzen ... abgeschlossen.ui: Pushing modality for applet ID 3 with dialog sun.plugin.util.PluginSysUtil$DummyDialog[dialog0,-100,-100,123x34,layout=java.awt.BorderLayout,APPLICATION_MODAL,title=,defaultCloseOperation=HIDE_ON_CLOSE,rootPane=javax.swing.JRootPane[,3,29,117x2,layout=javax.swing.JRootPane$RootLayout,alignmentX=0.0,alignmentY=0.0,border=,flags=16777673,maximumSize=,minimumSize=,preferredSize=],rootPaneCheckingEnabled=true]
basic: Dialog type is not candidate for embedding
ui: Pushing modality for applet ID 3 with dialog javax.swing.JDialog[dialog1,702,402,516x208,layout=java.awt.BorderLayout,TOOLKIT_MODAL,title=Anwendungsfehler,defaultCloseOperation=HIDE_ON_CLOSE,rootPane=javax.swing.JRootPane[,3,29,510x176,layout=javax.swing.JRootPane$RootLayout,alignmentX=0.0,alignmentY=0.0,border=,flags=16777673,maximumSize=,minimumSize=,preferredSize=],rootPaneCheckingEnabled=true]
ui: Pushing modality for applet ID 3 with dialog sun.plugin.util.PluginSysUtil$DummyDialog[dialog2,-100,-100,123x34,layout=java.awt.BorderLayout,APPLICATION_MODAL,title=,defaultCloseOperation=HIDE_ON_CLOSE,rootPane=javax.swing.JRootPane[,3,29,117x2,layout=javax.swing.JRootPane$RootLayout,alignmentX=0.0,alignmentY=0.0,border=,flags=16777673,maximumSize=,minimumSize=,preferredSize=],rootPaneCheckingEnabled=true]
 

Deinstalling Java7 and using Java6 seems to help, but is there a way to get it running with Java7?

Thanks,

Chris

 

Stefan S.'s picture

Hi,

My colleague just showed me the same error a couple of minutes ago when using java 7u51. There seems to be a new setting in that version which can get it to work. There is a setting under security where "exceptions" can be defined. So if you add the altiris server in the exception list the import loads without error.

Stefan

Christopher Lüpnitz's picture

There seems to be a new setting in that version which can get it to work. There is a setting under security where "exceptions" can be defined. So if you add the altiris server in the exception list the import loads without error.

Hi Stefan,

thanks for the information. This solution works for me.

Thanks,

Chris

jpellet2's picture

You can also lower the Java security settings to Medium on the machine which will once again allow the applet to load. The issue is that that Java 7 U51 now enforces and blocks applets that don't have a permission property as well as signed code inside of a java manifest (or something like that, doing this from memory). The update cause a little havoc around the campus today and we had to change the settings on workstations to medium until we can wrangle all of our vendors into changing their code and providing updates.