Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Java in NetBackup

Created: 29 Jul 2013 • Updated: 30 Jul 2013 | 6 comments
This issue has been solved. See solution.

Is there anyway we can get information on the embedded java versions that the software uses? Is the embedded java needed if we are not using the GUI or are there other processes that run off the java vm?

Operating Systems:

Comments 6 CommentsJump to latest comment

CRZ's picture

1. To determine Java version, run the java -version command.  On UNIX/Linux, it would be:

# /usr/openv/java/jre/bin/java -version
java version "1.6.0_45"
Java(TM) SE Runtime Environment (build 1.6.0_45-b06)
Java HotSpot(TM) Client VM (build 20.45-b01, mixed mode, sharing)

In the example above, I ran the command on a server running NetBackup 7.5.0.6.

On a Windows system, the command would be something like <install_path>\VERITAS\Java\jre\bin\java -version (<install_path> might be C:\Program Files or it might be something else) and you'd need to run it from a cmd command window.

2. If you are not using the GUI, you do not need the embedded Java, no.


bit.ly/76LBN | APPLBN | 75LBN

SOLUTION
epsilon22222's picture

In regard to not needing the embedded Java.  Are we able to remove the package entirely or is it required in order to upgrade the software?

CRZ's picture

That is an excellent question for which I do not know the answer.  :)  I believe you can remove the package without consequence...but we may try to reinstall it every time you upgrade, after which you'll have to remove it again.  DISCLAIMER: I have no testing to back up this belief, so please don't take my word for it.  It's possible that if we wait long enough someone will show up who can tell us that they've done it and what happened!


bit.ly/76LBN | APPLBN | 75LBN

CRZ's picture

OK, I just tried it. 

On a new 7.5 Solaris 10 client, I did a pkgrm on SYMCnbjre.  I was then able to apply 7.5.0.6 without a hitch... but in the process a new SYMCnbjre package was installed.  So I pkgrm'd THAT one, too.

Script output attached if you're bored.

Actually, now that I look more closely at that output, I probably should have done a pkgrm SYMCnbjava while I was at it - that's the package for the Java console itself and you probably don't need that if you've already zapped the JRE.

Man, now I want TWO solutions.  ;-)

EDIT: Now that I look at my output, I accidentally pkgrm'd SYMCnbjava instead of SYMCnbjre.  If it were the morning, I would do it all over again correctly... but I'm 99% sure and want to go home, AND if I hadn't drawn your attention to it, you might not even have noticed, so... hopefully that's good enough for now.  :)

AttachmentSize
nbclient1.txt 54.09 KB


bit.ly/76LBN | APPLBN | 75LBN

epsilon22222's picture

Awesome, thanks Chris.  After looking at your test results, I decided to try the same on one of our Red Hat media servers.  I uninstalled the entire thing first just to get to a good starting point, reinstalled just the base 7.5 installation, then removed the Java packages (SYMCnbjava, SYMCnbjre) and installed the 7.5.0.1 update.  The update procedure went fine and it reinstalled as expected. 

I would love to give you another solution marking.  Perhaps you could break up this thread and make a new thread? :)

CRZ's picture

Ha!  That's OK; your thumbs up is just fine.  :)  Glad your test results matched the ones partially in my head.


bit.ly/76LBN | APPLBN | 75LBN