Video Screencast Help

Job Failed - Shadow Copy Component

Created: 30 Mar 2012 | 14 comments
Invision's picture

I have a trial of BE2012 installed for a client and I am trying to give it a chance. I hate it when companies change things but I am trying to keep an open mind. I can't believe that Symantec would risk losing every single loyal tech out there without knowing that this new product is somehow better.

I am getting an error after upgrading my job from 2010. It is stating that I should edit the job and delete the Shadow Copy Components selection. I can't for the life of me find where to do that.  Here is the actual message:

V-79-57344-37925 - Snapshot Technology: Initialization failure on: "Shadow?Copy?Components". Snapshot technology used: Microsoft Volume Shadow Copy Service (VSS). Snapshot technology error (0xE0009425): The Shadow Copy Components file system has been modified to contain only user-defined data, such as Backup Exec Deduplication Disk Storage (PDDE) and Distributed File System Replcation (DFSR). All other operating system-related data is now incorporated into System State. As a result, existing Shadow Copy Components file system backups and backup sets are incompatible with Backup Exec 2012. You should edit the job, delete the Shadow Copy Components selection, and then run the job again.

Can anyone help me find where to do what it is telling me to do?

I thought I might be able to just delete the server object and start over with a new job so the Shadow Copy Components selection wouldn't be there. But alas it is the actual backup server and I can't find how to do that either. It let me remove all of the other servers and recreate the jobs for them, but not this one.

I may change my mind eventually but as of right now, BE 2012 is no longer the backup product of choice. Symantec ... help me change my mind.

Comments 14 CommentsJump to latest comment

Backup_Exec's picture

Hi there for this issue I would recommend please remove the server having shadow copy component selected and then read again doing that it would remove the references it has got from previous version has in be2012 shadow copy no longer exist as like previous version so once youc delete the server and readd it again you can make new job and should work fine

Sameer

Don't forget to give a "Thumbs Up" or Mark as "Solution" if someones advice has helped you.

pkh's picture

Why are you repeating what is covered in the previously referenced document?

Invision's picture

Thanks for the replies but ...

marc, I saw that article but the place it says to go and deselect the Shadow Copy Component, under details, it isn't there. In my job definition, there isn't an item for SCC.

backup-exec, I can't delete the server and recreate the whole thing because it is the backup server I guess. It won't let me remove it like I did the other 4 servers to start over.

Any others?

pkh's picture

If your job has been migrated from an earlier release of BE, delete the job and define a new one.

Invision's picture

I'm not sure how else to say it... There is no option for Shadow Copy Components in the selections on the server details. I see the System State stuff and there are many selections listed in there but Shadow Copy Components is NOT one of them. It isn't listed there and unchecked..., no... it isn't in the list at all.  Yet it is still complaining that it should be removed.  Now you understand why I'm confused?

I know what you all are saying... to go in and deselect it from the selections, but it isn't physically in the list to check or uncheck. Nor is it listed in the details list.

pkh's picture

It could be in the job definition in the BEDB, but is not displayed.  Delete the job and define a new job.

BOCM's picture

Invision,

I had the very same problem. I was able to remove the Shadow Copy Components. At least I think so, I just removed it and tonight I'm hoping to get a good backup.

Here is how: Edit the job. Click edit on the selection side. Click on the Selection Details tab (the Browse tab does not show the SCC). I saw the SCC in the Selection Details tab. I clicked on "Include - *.*  [Subdir]" under SCC and then was able to click on the Delete button.

Like I said, I hope this solves this pesky problem. 

I'm all for newer, better ways to do things too. I'm still not convinced Backup Exec 2012 falls into that category.

Moltron1's picture

I second BOCM.  I migrated from 2010 to 2012, with about  300 jobs that got migrated.  Many of them had the same problem.   I've noticed that on alot of the converted jobs.  BOCM's way should work.

Personally I like to edit the selections, and on the browse tab, uncheck everything, then look at the "Selection Details" tab.  You may notice there are still things in there even after you's deselected everything.  One of them is probably Shadow Copy Components.  Just highlight everything in there and get rid of it, then switch back to the Browse tab and select what you need again. 

I've noticed that even on converted jobs that work ok, there is extra garbage in the "Selection Details" tab, stuff that you don't see come back after reselecting everything. 

Demz's picture

I cannot find this crappy shadow copy components from the selections. I have tried to look everywhere. Moltron1 and BOCM posts didn't help me.

I cannot remove and readd this server to BE because it's the only server in this environment.

HEEEELP!

marcusolini's picture

Keep in mind that this scenario only affects backup jobs migrated to Backup Exec 2012.  Meaning, that newly created backup jobs with Backup Exec 2012 will not be affected.  Also, that using Remove-Server and Add-Server is not relevant.

Hopefully screen captures will be a good starting point to help demonstration the missing selection and the delete action required.  These screen captures depict a scenario where Shadow Copy Components is no longer reported on the Server because the simplification and consolidation into System State.  Please let me know if this still does not help.

SCC-Migrated-01.png SCC-Migrated-02.png
Moltron1's picture

Hey Demz.  I'm not sure what you mean by 

I cannot remove and readd this server to BE because it's the only server in this environment.

But, you shouldn't need to remove the whole server and re-add.  Right click your server and choose "edit backups".  Then push the edit button on the selection list (bottom of the first colunm of the "backup properties" window).  What might be the easiest way to clear things up is to uncheck everything from the browse tab, then click ok.  Then, go back in and place a check on the server node to select everything in it.  Then ok everything to save the job. 

If that does not work, I have to ask, are you seeing the exact same error in the beginning of this post?  And BTW, not being able to find it might be a tell that the problem you have is somehow different.

mvalpreda's picture

I just migrated from 2010 R3 to 2012. I am getting this V-79-57344-37925 error as well. I went through my 18 servers and multiple jobs (thanks Symantec) and removed Shadow Copy Componets. Let's see how my jobs do over the weekend.

Really wish there was a place to look at the active job running instead of clicking on all the servers and then trying to figure out what is running. Worked with this since 7.X and never have I been more confused than with 2012.