Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Job fails every day

Created: 03 Oct 2012 • Updated: 16 Oct 2012 | 9 comments
This issue has been solved. See solution.

We have a HP Ultrium 400GB Drive, and every day, when it gets to 140, 160, 180 GB, it asks for me to remove the tape.  Of course, this occurs at about 2 am when no-one is here, so when we arrive in the morning, we have an error:

Job ended: 28 September 2012 at 01:50:37
Completed status: Canceled
The job was canceled because the response to a media request alert was Cancel, or because the alert was configured to automatically respond with Cancel, or because the Backup Exec Job Engine service was stopped.

Why is Backup Exec asking that the tape be removed (it's set to Eject when finished)?

And why, when the Tape is 400GB capacity, is it finishing at less than 200GB and asking for the Tape to be removed as though it's waiting for a new tape (and when it doesn't get the new tape, it 'cancels' the job)?

Thanks for any help or advice.

Brian

 

Comments 9 CommentsJump to latest comment

lmosla's picture

Hi,

Make sure the Media Remove alert is set it to be automatically cleared. depending on what version of Backup Exec you have: 

Backup Exec 2012 see https://www-secure.symantec.com/connect/forums/backup-exec-2012-media-remove-autoresponse-not-possible

or Backup Exec 2010 http://www.symantec.com/business/support/index?page=content&id=HOWTO22882

Also, check and see if the Symantec drivers are installed. http://www.symantec.com/business/support/index?page=content&id=TECH17931

Hope this helps

pkh's picture

You get this alert because your tape is full and another tape is required for the job to continue to completion.

You got to be careful when you are talking about tape capacity.  Normally LTO tapes are marketed with 2 capacity a lower uncompressed native capacity and a higher capacity which reflects a 2:1 compression ratio which is hardly achieved in real-life.  For example, a LTO2 tape is marketed as 200GB/400GB.  The native uncompressed capacity is 200GB and the 400GB assumes a 2:1 compression ratio which is hardly achievable.

Compression depends on your data.  If you are compressing data which is already compressed like zipped files, sound and movie clips, then you might end up with more data than you have started.  See my article below

https://www-secure.symantec.com/connect/articles/c...

In your case, determine what is the native capacity of your tapes and see what kind of data that you are backing up.  If you are backing up data which is already compressed, it might be better to turn off compression.

If the above does not explain why you are getting so little data onto your tapes, then make sure that you have updated your tape library and tape drive with the latest firmware.

565515211's picture

Thanks for your feedback, however, even if it is 200GB capacity and not 400GB, why does it eject and ask for new media when it's at only 140-180GB full?

What I've done now is split the Backup across 2 Tapes.  One Backup of 2 Servers in the morning and the 2nd Backup of the other 2 Servers in the afternoon.  So, this morning's operation completed, and it's now at the Verfify stage, but it ejected the Tape before it ran the Verify operation?????

So, I stuck the tape back in to allow it to Verify, but now it's just sitting there, doing nothing 'Loading Media' has been stuck there for over an hour even though the Tape is in?

I can't begin the 2nd Backup Operation because it won't complete the Verify of this morning's backup?

*sigh*

Jaydeep S's picture

About the backup writing less data to the tape please post a screenshot of the media statistics. This can happen mostly if you are backing up precompressed data and attempting to use compression again.

I am not sure if I understand this correctly, but if the backup spanned on 2 tapes, during the verify, it will ask for both the tapes to be inserted. It does mention the media label in the alert. Verify that you insert the correct media. Once you insert the correct tape and respond to the alert, it sould continue.

565515211's picture

Sorry if I explained it badly . . .

I've created 2 separate Backups: 1 that runs in the morning for Exchange & Finance (Backup, Verify, Eject).

Then one that runs in the afternoon for FP Server + CRM Server (Backup, Verify, Eject).

The Backup doesn't span 2 tapes.  They're 2 different Backup jobs.
Does that make sense?

Many thanks

Brian

pkh's picture

even if it is 200GB capacity and not 400GB, why does it eject and ask for new media when it's at only 140-180GB full?

As I said before, if you are compressing data which is already compressed like zipped files, sound and movie clips, then you might end up with more data than you have started.  Read my article below for a fuller explanation

https://www-secure.symantec.com/connect/articles/c...

Your situation seems to indicate that you have 140-180 GB of compressed data.  When you compress these, you end up with 200GB of data, filling the tape.

 

Splitting your job is no guarantee that you will not fill a tape.  It all depends on the data from the backup.

What could be happening is that even with your jobs split, the first tape is filled and it is ejected.  BE is then waiting for a second tape to continue the backup.  You must put in a second overwritable tape for the backup to complete.  You should get an alert asking you to insert overwritable media.  Putting the tape that has just been ejected will do no good.

The tape sequence in your job will go something like this

Backup to Tape1

Insert Tape2 for backup.  Assuming that the backup does not need a thrid tape

Insert Tape1 for verification.  You would be prompted for this tape by an alert

Insert Tape2 for verification.

SOLUTION
565515211's picture

Thanks.  Your article is good and does help to explain the concept of trying to compress already compressed data.  It would seem, though, that Backup Exec should automatically ignore certain file extentions (.zip, .mp3) and just copy them.  It should only compress, eg, .doc, .ppt, .wpd, .accdb, etc.

I'm assuming it doesn't employ any logic when doing a backup and just 'compress everything' is the way it works?

Is there a way to change the way Backup Exec works with a specific job, eg,

Job 1: Backing up a CRM/SQL DB, then uses compession

Job 2: Backing up File System, don't compress

Are there recommended settings, eg

Backup of Exchange, CRM, SQL = Best practice is to use compression

Backup of File/Print Servers = Best practice is don't use compression?

 

pkh's picture

If you find my article good, do give it a thumbs up.

Compression is enabled on a job level, so you either enable compression or disable it.  It is up to you.

There is no particular recommendation with regards to compression.  Again it is up to you which data you want to compress.  There is no restriction on compressing files.  It is just that if you have compressed data then you got to be careful about the effect of compression.

565515211's picture

I've given your article a thumbs-up.  smiley

It's a pity there isn't a recommendation for certain Data Types.  Of course, it would be even better if Backup Exec could make those decisions itself—it obviously is Exchange Aware, SQL Aware, etc, so it should be super simple for Symantec to set the recommended Backup jobs based on what it's backing up.

Eg

  • "I'm about to Backup an Exchange Information Store . . . employ compression"
  • "I'm about to Backup a SQL Database . . . employ compression"
  • "I'm about to Backup a File Directory, employ compression for all files except for the following file types: MP3s, etc."

Seems common sense to me, and I'm suprised this isn't already the way Backup Exec works.  Maybe the next version will employ such?  wink

Anyway, thanks for all your help to date.

Have a good week.

Take care

Brian