Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Job failures on CASO after BE 2010 R3 SP3 update

Created: 30 Jan 2014 • Updated: 31 Jan 2014 | 4 comments
This issue has been solved. See solution.

Setup is as follows:

  • Servers A, B; both are media servers with A as the CASO.
  • BE 2010 R3 with SP3 applied.
  • Updated remote agent applied to remote host.
  • No other changes to network, servers or logon accounts have taken place before/after the SP3 application.

The following issue has occurred only after the application of SP3:

Using the BE 2010 UI on the CASO

  1. I am able to browse the remote host and make selections.
  2. I am able to do a TEST run of the job on both A and B with success.
  3. Credential checks are also successful.
  4. Managed media servers are allowed to use any network interface.
  5. No other service is using port 10000 on either A or B, or the remote host.
  6. Jobs submitted to run on server B are successful.
  7. Jobs submitted to run on server A (CASO), however, fail.

Jobs ran on server A report

The job failed with the following error: The media server could not connect to the remote computer. The remote computer may not exist on the selected subnet. Try an alternative network interface, or allow Backup Exec to choose any available network interface

Running SGMon on server A produces the following:
 
NDMPAgentConnector:SetupConnection(): Data Server = <remote IP>
[ndmp\ndmpcomm]      - Could not resolve the "bews-ndmp" or the "ndmp" service, error code: 10109, using port 10000
[ndmp\ndmpcomm]      - ndmpConnectEx: Querying the neighbour advertisement cache to discover information on '<remote IP>' ...
NRDS API - client connected.
NRDS API - client disconnected.
[ndmp\ndmpcomm]      - ndmpEstablishConnectionUsingAnyIPv4SubnetOnAdapter: Unable to find any route from the Adapter: '<NIC>' to the remote host
[ndmp\ndmpcomm]      - ndmpEstablishConnectionUsingNetworkOptions: Could not connect to the remote host through NIC: '<NIC>'
[ndmp\ndmpcomm]      - ndmpConnectEx: unable to connect using NetworkOptions to <remote IP>
[ndmp\ndmpcomm]      - ndmpConnectEx: no NIC fallback to <remote IP>
[loops]              - NDMPAgentConnector::Connect: ndmpConnectEx() failed on server <remote IP>, port: 0.
[loops]              - NDMPAgentConnector::HandleConnectionError: ndmpConnect failed: The remote machine <remote IP> was not detected on the selected NIC <NIC> using protocol IPv4, and the 'Fallback' option was not chosen.
[loops]              - IsLocalAgent:beclass::BEConvertServerNamePlus returned error: 87
[loops]              - NDMPRAHostBackupEngine::ConnectToDataServer() failed. Error = 0xE0000F02.
[loops]              - NDMPHostBackupEngine:ConnectToDataServer() failed for machine <remote IP>. Skipping BSDs for this machine.
 

How is the remote host 'detected'?  Does BE expect a PING reply?  Doesn't seem appropriate as PING is often turned off for security reasons.  This doesn't explain, though, why I'm able to browse the remote host, or perform a TEST backup job, or the ability to run the job on server B.

Any Ideas?

Operating Systems:

Comments 4 CommentsJump to latest comment

pkh's picture

You must be able to telnet from the media server to the remote server using port 10000

dparrs's picture

Thank you for your input.

Telnet does work on both A and B servers.  I am able to browse remote clients as well as run TEST backups. It's only the actual backup job itself on server A (CASO) that has the problem.

dparrs's picture

Another piece of this conundrum pie:

Both A and B sit on the same subnet.  Jobs submitted to A for hosts on the same subnet complete, as well as jobs submitted to B.

Jobs submitted to A for hosts on a different subnet fail, but complete when submitted to B.  Yet I can browse either subnet from A.  And, from PKH's suggestion above, I can also telnet to either subnet.

This makes me think this is network related.  I'll post my findings next week.

dparrs's picture

I have solved my issue:

I refer you to http://www.symantec.com/business/support/index?page=content&id=TECH205946#CAS-MMS for reference.

Even though I had only one NIC, and was using only IPv4, BE apparently does not like being restricted to those two options.  I had to set Job Defaults to use any NIC and any protocol.

SOLUTION