Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

Job Stuck in Queue status

Created: 07 May 2013 • Updated: 08 May 2013 | 12 comments
This issue has been solved. See solution.

Dear all,

We had installed a new Backup Exec 2012 server recently.

We had created a Disk-Based storage and created a server group to backup 3 of our server.

One of these server had been backup sucessfully without any problems.

But the others two are stuck in Queued status and never start.

Mind I have your kindly advice on this issue?

Thank you very much

Operating Systems:

Comments 12 CommentsJump to latest comment

VJware's picture

Are there any alerts ?

And are all 3 backups scheduled to start at the same time ? If yes, check the concurrency under the Disk Storage properties & ensure it is atleast set to 3

pkh's picture

Are there any outstanding alerts that need to be responded to?

PoorGuy's picture

Thank you all for your reply.

I had checked and no alert need my response.

And yes, they both run at the same time based on set schedule.

But I tried to run them one by one, the problems still not fix.

pkh's picture

If you just run one of the job which stucks by itself, does it run?

PoorGuy's picture

No, I tired search the solution and reboot our Backup server few times.

But the backup job still stuck even i hold the backup job of the other server and only run 1 of them.

Thank you very much

PoorGuy's picture

Hi all,

New finding, As both stuck queue server had installed SQL server, I had tried the following action.

1. Backup only the server system state -- result ok.

2. Backup the server local drive only -- result ok.

3. Backup Microsoft SQL server instances -- Stuck in queue.

Is there any setting that I set it wrong to make us have the queue situation?

Thank you very much

VJware's picture

Ensure Named Pipes & TCP/IP protocols are enabled on the SQL server using cliconfg. If you enable them now, you would need to restart the SQL service for the changes to take effect.

Does the Backup Exec logon account have sufficient privileges to backup SQL such as sysadmin, db_owner etc ? If not, pls provide them.

Lastly, any errors logged under Application Log on the SQL server's event viewer ?

PoorGuy's picture

Thanks Vjware

I had tried your provide solution. But no luck.

1. Enable Named Pipes & TCP/IP protocols, restart the server.

2. The Backup Exec account had sufficient privileges to backup SQL

3. No error from the Application Log on SQL server.

Anything I need to test to fix this problems?

VJware's picture

On the Backup Exec server & SQL server, open SGMon.exe from \Program Files\Symantec\Backup Exec

Enable options "Job Engine, RAWS, Agent Browser" and "Capture to File"

Keep this debug monitor minimized & run a backup job just for the SQL instances. Let the backup job be stuck in queue for about 5 mins.

Then choose the option to "Open Log" from SGmon & save the corresponding log file on both servers. PM or post the log files. Disable the previously checked options & close SGMon.

PoorGuy's picture

Thank you so much VJware, just send a PM to you.

 

VJware's picture

There are plenty of consistency errors in the SQL debug.

In addition to the consistency errors, it reports in-row data is incorrect & stating to run DBCC UPDATEUSAGE. It could be possible the consistency errors are due to the incorrect in-row data.

Run DBCC Updateusage first followed by a consistency check from SQL to verify it comes out clean. Then re-attempt a backup via BE.

 

 

SOLUTION
PoorGuy's picture

Thank you very much VJware.

Will try your solution and reply here soon.