Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

Jobs failing with error "remote agent not detected"

Created: 03 Dec 2012 • Updated: 03 Dec 2012 | 18 comments

I have a job that just started failing and the issue points to a specific server with the error "remote agent not detected". I've verified the remote agent on the problem server is enabled and that the version is the same as the media server. Here is the exact error on the log:

Final error: 0xe000846b - The resource could not be backed up because an error occurred while connecting to the Backup Exec for Windows Servers Remote Agent. Make sure that the correct version of the Remote Agent is installed and running on the target computer. If the server or resource no longer exists, remove it from the selection list. Edit the selection list properties, click the View Selection Details tab, and then remove the resource. Final error category: Resource Errors For additional information regarding this error refer to link V-79-57344-33899

I've reinstalled the remote agent but getting same error. I went into user define selections and notice that I could not browse to the problem server via hostname but was able to via IP Address. I've tested DNS and it is working as it should. From the media server (not in backup exec) I am able to browse to problem server via hostname and IP Address. Anyone have any ideas?

Comments 18 CommentsJump to latest comment

lmosla's picture

Try checking for duplicate DNS entries

Use NSLOOKUP and IPCONFIG /ALL to displayed DNS Server settings.  Check the TCP/IP configuration for a local incorrect DNS Server settings. Local settings will overwrite settings from the DHCP Server. By deleting the local DNS setting and switching to auto configuration DNS server settings should be corrected.

If you make any changes run ipconfig /renew /registerdns

 

pkh's picture

Do you have multiple NIC's in either the remote server or the media server?  This could be the source of the problem.

leekum's picture

PKH,

Yes, the problem servers have multiple NICs on them.

leekum's picture

It looks like if I delete the server from Favorite Resources, Windows Systems.........Then go to Domains, Microsoft Windows Networks, Domain, and browse the problem server it's successful. I did notice that the little orange icon to the left of the server now is gone. I ran a test backup and it was successful. I then checked later and the server which I deleted from Favorite Resources, Windows Systems was there again. I tried to browse the server and was getting the same error again both from Windows Systems and under Microsoft Windows Networks and Domain. I again deleted the server from Windows Systems and again was able to browse the server from Microsoft Windows Network, Domains. But it keeps reverting back.

Jose Vega Coto's picture

Hi Leekum

are 2 NIC configured? if yes, in the network tap of the backup policy are you selecting the NIC used to do the backup? many time users left the default option and not always this is good.

 

check on what network is the RAWS conencted and select the appropiate NIC in the policy, and run the backup.

leekum's picture

There are multi NICs on the media server and remote server which is having the issue. I'm guessing I do this on the media server?

Jose Vega Coto's picture

yes yo have to select the nic for the backup in the media server by editing the policy, be sure what network is using the RAWS

lmosla's picture

To configure the remote server to advertise using the IP on the NIC. http://www.symantec.com/business/support/index?page=content&id=TECH37569

and you can Edit the job or the global settings [Tools -> Options] to "Use any available Network Interface" and "Use any available Protocol" under Network and Security. Try backup exec to select the option "choose any available network interface".

Also it maybe that Port 10000 is being blocked on this server. Use the following document to check and resolve this issue http://www.symantec.com/business/support/index?page=content&id=TECH60245

pkh's picture

 Try backup exec to select the option "choose any available network interface".

It is probably allowing BE to choose the interface that cause his problems.

pkh's picture

@leekum - Try to force BE to use one specific NIC by doing this

1) Put an entry in the HOST file of the media server with the IP address of a specific NIC on the remote server

2) Put an entry in the HOST file of the remote server with the IP address of a specific NIC on the media server.

3) Do a traceroute on both the media server and the remote server and make sure that the route goes to the specific NIC.

4) In your job, go the Network and Security section and choose the specific NIC on tthe media server.

leekum's picture

Under network and security it is already set to use any available network interface and any available protocal. I will try adding host name of media server and remote server. Perform the tracert and let you know.

pkh's picture

use any available network interface

No. When you use this option, BE will use any NIC which is the cause of your problem.  You want to select a specific NIC for BE to use.

any available protocal.

Again no.  You should choose IPv4 if you have both IPv4 and IPv6 on your media server.

leekum's picture

It looks like the issue is definitly the multi NICs. When I do a netstat -ano | findstr 10000 on the remote server I get:

0.0.0.0:10000

This causes the media server and client server to communicated on the wrong interface. Is there a way to configure the remote agent on client server to use a specific interface????

lmosla's picture

Can you go into User Defined Selections and use the IP address of the server to back it up?

See this discussion that describes the problem and solutions. 

If you are on Backup Exec 2010R2 you should upgrade to 2010R3

Here is the download.

http://trialware.norton.com/files/fc/Backup_Exec_2010_13.0.5204_MultiPlatforms_Multilingual_DVD.iso

leekum's picture

User define selection via IP Address, the job completes successfully. But this defeats the purpose....There's got to be a way to configure the remote agent to listen on a specific interface instead of listening on all.