Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

jobs keep creating overwritable media in B2D folder

Created: 28 Sep 2012 | 8 comments

I am noticing a problem when the B2D folder gets low on space while the job is running it will continually create overwritable media sets every 4 seconds. Is there a way to tell the job to stop creating media when the B2D folder has become full?

Comments 8 CommentsJump to latest comment

SuperBrain's picture

Yes.

Go to the Devices tab

Right-click on the B2D folder - Properties

Set a Disk Space Reserve limit.

See http://www.symantec.com/docs/TECH55778 for more information.

 

If suitable, you could also start overwriting older overwritable media from that B2D by selecting "Overwrite recyclable media before scratch...." option under Tools - Options - Media Management.

Excerpts from http://www.symantec.com/docs/HOWTO22311

 

Overwrite recyclable media contained in the targeted media set before overwriting scratch media

Lets Backup Exec overwrite recyclable media in the targeted media set first when an overwrite job occurs.

If no recyclable media are found in any of the storage devices, Backup Exec overwrites scratch media.

If no recyclable or scratch media are found, Backup Exec searches for media to overwrite. The media that is overwritten depends on the level of overwrite protection that you set (Full, Partial, or None).

See How Backup Exec searches for overwritable media.

If you choose to overwrite recyclable media in the targeted media set first, you will re-use the same media more frequently than if you choose to overwrite scratch media first.

 

j.durlewanger's picture

http://www.symantec.com/docs/TECH55778 - does not take me to a tech document

I do not have an option to set a reserve limit

I already have the option to overwrite recycled media enabled.

 

SuperBrain's picture

 

Strange that you're unable to view that technote.
 
However, try this..
 
On the navigation bar, click Devices. Select the Backup to Disk folder. Right-click the folder and select Properties > Advanced
 
The following option is available on the Advanced tab of the Properties for a Backup to Disk folder:
 
Disk space reserve
Check Disk space reserve to prevent a job from being written to the backup-to-disk folder when the threshold that you specify is reached. Enter an amount of disk space to reserve on the disk. When this threshold is reached, Backup Exec cannot submit jobs for processing that are targeted to this backup-to-disk folder, but jobs that are running will finish. The backup-to-disk status displays Low Disk Space. Free up some disk space to allow job submission to resume.
j.durlewanger's picture

I do not have a disk space reserve option for the backup to disk folder properties.

pkh's picture

The option is called Low Disk Space Threshold.

David Palmerston's picture

j.d -

Even if you had the option, reserving space is only a temporary solution to your problem that may help with the repeated attempts to create the very small files and fill up the remaining space. 

To my knowledge (and research), there is presently no method within BE2012 to prevent this a storage device from filling up.  (I'd love to be able to develop a powershell command to put every job on hold that has a certain destination device when the device is approaching full, but haven't been able to set aside the time yet)...

Also, there are other significant problems that arise when any BE2012 SP1a+ B2D storage device fills up (to the allotted, non-reserved limits).  You should try very hard to make sure that the B2D storage device does NOT ever fill up.  Right now that may require manual work.

I've outlined the steps that I've been using in another thread: https://www-secure.symantec.com/connect/forums/overwrite-backups-older-7-days-old-disk-based-storage

Hopefully those can be of help to you.

SuperBrain's picture

Thanks for the inputs David, but if i'm not mistaken j.d.'s issue is not with BE2012... its related to BE 11d... indecision

j.durlewanger's picture

I have the low disk threshold set but it still continues to create the overwritable media files. Just to point out, the agent will never use these media sets. I have to manually delete them.