Video Screencast Help

Keep getting these error in the log - NS 7.5

Created: 29 Oct 2013 | 13 comments

Hello,

 

I have a new NS 7.5 server in my lab built from scratch.  It has ITMS installed and I am currently testing DS 7.5 functionaslity.  I get the following sequence of error messages in the log every 1 or 2 seconds: (The GUID in the errors corresponds to a package called "Imaging Package")

 

 

Error in SetWorkFolder(): Cannot lock work folder The process cannot access the file because it is being used by another process. (-2147024809). New folder: C:\Program Files\Common Files\Altiris\Package Delivery (current folder: ) 

 

Begin download for package: {ABD668D6-E76D-4313-B50C-3309D75D7012}

 

Download Snapshot: http://servername/Altiris/NS/Agent/GetPackageSnapshot.aspx?Resource=&PackageId={ABD668D6-E76D-4313-B50C-3309D75D7012}&compress=1

Download Snapshot complete: OK

 

Snapshot signature is not valid for package: '{ABD668D6-E76D-4313-B50C-3309D75D7012}'

 

Error while downloading package: The snapshot received does not correspond the signature. (0x80004005)

 

 

Error while downloading package: No connection to server (0x80004005)

 

Retry package: id={ABD668D6-E76D-4313-B50C-3309D75D7012} delay=5760 secs at=29/10/2013 5:34:27 PM causedDelay=1 earliestRetryTime=

 

End download for package: {ABD668D6-E76D-4313-B50C-3309D75D7012}. Status: retrying

 

 

I believe the messages started to appear when I tried to run am imaging job on one of my test machines, but I am not certain of this.  Any help would be great. Thanks

 

Operating Systems:

Comments 13 CommentsJump to latest comment

Network23's picture

Hi Nande1965

Currently I´m seeing the exact same issue with my installation and also looking for a solution.

Please keep posting if you receive a solution for this problem

Network23

botassio's picture
Hi everyone!
 
Currently I´m living the exact same issue with my installation and also looking for a solution.
 
In another installation on my virtual environment, did not have this problem.
 
I believe it could be something related to proxy / firewall.
 
Best regards!
 
Botassio

If the suggestion has helped to solve your problem, please mark the post as a solution.

Thiago Botassio
Altiris Certified Profissional | WTR Services | www.wtrservices.co

Mkoka1's picture

Hello All,

Can you please try the following :

Under the Task Scheduler , run the following three tasks :

1.) NS.Package Distribution Point Update Schedule.{29a2b641-222a-43b0-830c-a25c59e93fe4}
2.) NS.Package Refresh.{bd6bf880-bfae-4dad-b746-e8be99f3b8a8}
and
3.)NS.Package Server Status Event Capture Item.{f85fe5d9-005a-40ac-b213-944b496405fe}

 

these would update the package snapshot and its signature as well and then you can try to recreate the WinPE and wait for some time untill it downloads the package and executes the bootwiz.exe in the task manager.

 

Network23's picture

Hello Mkoka1

Tried the steps but it doesn´t help - still getting the same error messages...

Network23

MKOKA's picture

Hello Network23,

 

Do you see anything under the DSTask.log something like :

"The symbolic link cannot be followed because its type is disabled" ??

If yes then probably there are two symbolic links for DS

1.)DriversDB and 2.)BDC....

 

To check if they are enabled check

fsutil behavior query SymlinkEvaluation
 

So we may have to enable the Symbolick link via the following commands :

fsutil behavior set SymlinkEvaluation R2R:1

fsutil behavior set SymlinkEvaluation R2L:1
 

For these you may want to check more on this on the Technet articles from Microsoft, and then try again to recreate the WinPEs'

 

Mistral's picture

Having the same issue ... it takes ages to work

It is failing 9 times until it is downloading the package from "somewhere else".

It says "E:" (I dont have this on any machine)

Ok ... got it

E: have mapped to \\SMPServer.somedomain.net\NSSWD_{abd668d6-e76d-4313-b50c-3309d75d7012}$

 

[2013/11/15 09:05:28.474 4240:3188 0] Once again have failed in downloading packages. Cout =9
[2013/11/15 09:05:28.477 4240:3188 0] trying to download {ABD668D6-E76D-4313-B50C-3309D75D7012} package using DownloadPackageWithoutSMP() function
[2013/11/15 09:05:28.478 4240:3188 2] Start of util::CSMPPackage::DownloadPackageWithoutSMP function
[2013/11/15 09:05:28.489 4240:3188 2] Function Name is util::CSMPPackage::getNearestPackageInfoXML(),file name is common\util\SMPPackage.cpp and Line no 318.Reuest XML is /Deployment/Agent/GetNearestPackageServerInfo.aspx?xml=packageserver{83A0DEEA-4696-487E-AB2E-571091F11C50}110.0.0.250{ABD668D6-E76D-4313-B50C-3309D75D7012}
[2013/11/15 09:05:28.539 4240:3188 2] Function Name is util::CSMPPackage::getNearestPackageInfoXML(),file name is common\util\SMPPackage.cpp and Line no 328. Response of getNearestPackageInfoXML = falseSMPServer.somedomain.net10.0.0.25083a0deea-4696-487e-ab2e-571091f11c50true\\SMPServer.somedomain.net\NSSWD_{abd668d6-e76d-4313-b50c-3309d75d7012}$https://SMPServer.somedomain.net/Altiris/PackageShare/pkggroup_cdkumhevjpj65ay3mqyzqk5vtb23p6b2/Imaging
[2013/11/15 09:05:28.539 4240:3188 2] Function Name is util::CSMPPackage::ParsePackageInfoXML(),file name is common\util\SMPPackage.cpp and Line no 343. Return XML is =falseSMPServer.somedomain.net10.0.0.25083a0deea-4696-487e-ab2e-571091f11c50true\\SMPServer.somedomain.net\NSSWD_{abd668d6-e76d-4313-b50c-3309d75d7012}$https://SMPServer.somedomain.net/Altiris/PackageShare/pkggroup_cdkumhevjpj65ay3mqyzqk5vtb23p6b2/Imaging
[2013/11/15 09:05:28.539 4240:3188 2] Function:util::CSMPPackage::Initialiaze(),File:common\util\SMPPackage.cpp and Line:98.SMPServer.somedomain.net have selected as a PS
[2013/11/15 09:05:28.562 4240:3188 2] Function:util::CNetShare::DoMapping,File:common\util\NetShare.cpp,Line:64.E: have mapped to \\SMPServer.somedomain.net\NSSWD_{abd668d6-e76d-4313-b50c-3309d75d7012}$
[2013/11/15 09:05:28.563 4240:3188 1] Dest directory path[C:\Program Files\Altiris\Altiris Agent\Agents\Deployment\SBS\Imaging\{ABD668D6-E76D-4313-B50C-3309D75D7012}\cache] created.
[2013/11/15 09:05:28.563 4240:3188 1] trying to download {ABD668D6-E76D-4313-B50C-3309D75D7012} package from E:
[2013/11/15 09:05:28.640 4240:3188 1] have downloaded {ABD668D6-E76D-4313-B50C-3309D75D7012} package from E:
[2013/11/15 09:05:28.641 4240:3188 2] end of util::CSMPPackage::DownloadPackageWithoutSMP function

Lark's picture

I have this issue too - did anyone find a solution?

I have tried running the three tasks as described with no change to the issue.  I don't have any symbolic link error messages in the DSTask.log file.

PatrickLunn's picture

I have the EXACT same errors.  Exact same GUID as well.  I believe it has to do with bootwiz or some other portion of imaging.  Everything works fine in my environment,  but I would still like to get rid of this damn error.

Robert McArthur's picture

I'm also seeing this issue and it's causing all packages on the package server to be checked and redownloaded

PatrickLunn's picture

I have these exact same errors too.  Please help!!!!!!!!!!!!

Ludovic Ferre's picture

The snapshot are now signed, so if the signature file on your PS doesn't match the one from the server the agent will flag the mis-match and not use the snapshot file that has the invalid signature.

I wrote an article on some oft hose new security features in 7.5:

SMP 7.5 New Package Delivery Features: File Hashing and Snapshot Signing!

If the agent gets the signature file from a PS then the problem is with the PS that is not proeprly synchronised. Else, I don't really know.

I am currently off-net, on a retreat of some kind. I'll be back real soon, and you sure will hear from me then ;-).

Ludovic FERRÉ
Principal Remote Product Specialist
Symantec

Lark's picture

This issue was fixed in one of the hotfixes released since the first post.  Check your SIM.  Do you have all the latest updates installed?  Check the release notes for any extra steps.