Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

Lan Enforcer upgrade Problem

Created: 26 May 2013 • Updated: 06 Jun 2013 | 6 comments
D@ry1's picture
This issue has been solved. See solution.

Hey Guys,

 

I'm in rush right now I hope someone can help me. One of our client upgrade their Lan Enforcer from 11.0.6 to 12.1.2, this lan enforcer was used for 11.0.6 sepm but after the upgrade was now used to the 12.1.2 sepm. After that the next morning clients got disconnected. The upgrade was done night before.

 

Thanks,

Comments 6 CommentsJump to latest comment

Mithun Sanghavi's picture

Hello,

Did the client migrate to the Latest version of SEP 12.1?

SNAC is installed as part of SEP installation, so the version of SNAC is the same as SEP. When SEP is upgraded SNAC is upgraded as well.

SNAC gets activated in SEP when HI policy is applied on the client. Separate SNAC installation is not necessary.  You can install the SNAC-only client (which has no AV/Firewall/IPS/Device Control, etc).

Check these Articles:

SNAC is installed on clients, but the service is not started, nor is the NAC component is showing on interface

http://www.symantec.com/docs/TECH178780

Planning for the installation of a LAN Enforcer appliance

http://www.symantec.com/docs/HOWTO81551

About installing an Enforcer appliance

http://www.symantec.com/docs/HOWTO55765

Installing an Enforcer appliance

http://www.symantec.com/docs/HOWTO81714

Does The Auto-Upgrade Feature of Symantec Endpoint Protection11 (SEP11) Support Moving An Agent From SNAC to a Protection Agent?

http://www.symantec.com/docs/TECH94353

Hope that helps!!

Mithun Sanghavi
Senior Consultant
MIM | MCSA | MCTS | STS | SSE | SSE+ | ITIL v3

Don't forget to mark your thread as 'SOLVED' with the answer that best helped you.

Chetan Savade's picture

Hi,

Check this known issue and has fixed in SEP 12.1 RU2 MP1

After migrating SEPM from 11.0 to 12.1, Enforcers are unable to register with the server
Fix ID: 2557651
Symptom: Enforcers are unable to register with the SEPM server after migrating SEPM from 11.0 to 12.1. The SEPM log may contain the following error:
SEVERE: in: com.sygate.scm.server.task.EnforcerCompilerTask
java.lang.ClassCastException:
com.sygate.scm.common.configobject.schema.SemServerList cannot be cast
Solution: SEPM was modified to handle corrupted data when compiling the profiles for Enforcer groups.
 
Planning for the installation of a LAN Enforcer appliance

http://www.symantec.com/docs/HOWTO81551

About installing an Enforcer appliance

http://www.symantec.com/docs/HOWTO55765

Chetan Savade
Sr Technical Support Engineer, Endpoint Security
Enterprise Technical Support
CCNA | CCNP | MCSE | SCTS |

Don't forget to mark your thread as 'SOLVED' with the answer that best helps you.<

D@ry1's picture

Hey,

 

In where log can I see the "SEVERE: in: com.sygate.scm.server.task.EnforcerCompilerTask

java.lang.ClassCastException:" so I can really identify that this is the same problem for us?
 
thanks,
Chetan Savade's picture

Hi,

Check the scm-server-0.log and it should be present under tomcat/logs folder.

Chetan Savade
Sr Technical Support Engineer, Endpoint Security
Enterprise Technical Support
CCNA | CCNP | MCSE | SCTS |

Don't forget to mark your thread as 'SOLVED' with the answer that best helps you.<

Chetan Savade's picture

Hi,

Could you please update this thread?

Chetan Savade
Sr Technical Support Engineer, Endpoint Security
Enterprise Technical Support
CCNA | CCNP | MCSE | SCTS |

Don't forget to mark your thread as 'SOLVED' with the answer that best helps you.<

Mithun Sanghavi's picture

Hello,

The Above Defect # is resolved in SEP 12.1 RU1 MP1.

Check this Article:

New fixes and features in Symantec Endpoint Protection 12.1 Release Update 1 Maintenance Patch 1

http://www.symantec.com/docs/TECH187656

Since you are facing this issue even when installing the SEP 12.1 RU2, I would suggest you to create a case with Symantec Technical Support.

Create a case with with Symantec Technical Support Team.

How to create a new case in MySupport http://www.symantec.com/docs/TECH58873

Phone numbers to contact Tech Support:-

Regional Support Telephone Numbers:

  • United States: 800-342-0652 (407-357-7600 from outside the United States)
  • Australia: 1300 365510 (+61 2 8220 7111 from outside Australia)
  • United Kingdom: +44 (0) 870 606 6000
 
Hope that helps!!

Mithun Sanghavi
Senior Consultant
MIM | MCSA | MCTS | STS | SSE | SSE+ | ITIL v3

Don't forget to mark your thread as 'SOLVED' with the answer that best helped you.

SOLUTION