Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Latitude E7440 Ultrabook Intel® Ethernet Connection I218-LM

Created: 15 Nov 2013 • Updated: 15 Nov 2013 | 8 comments

We have just taken delivery of a new Latitude E7440 Ultrabook and like all good IT Engineers I set about taking a Factory Image of the machine before I do anything else to it.

 

However, surprise, surprise, the GHOST CD doesn't have the drivers for the Intel® Ethernet Connection I218-LM Network Interface.

So I went looking for the drivers so my GHOST 11.5 can make me a WinPE CD for me.

First of all I tried the Dell Support page, no good only WIndows 7/8 drivers there, maybe I could get lucky, may be the Windows 7 drivers could be used for the Vista drivers?

Lots of files to choose from e1c6232, e1d6232 etc etc.

None of them worked.

So I go to the Intel site and download the drivers from there, can't find any for Vista/WinPE so I download Windows 7 32 Bit and pray.

Long story short I find in the PRO1000\Win32\NDIS62\WinPE directory files e1s6232 could this be the one?

 

NOPE!

So has anybody else found or even written a driver for the I218-LM NIC and would be grateful if you could point me to it.

 

Cheers.

 

 

Operating Systems:

Comments 8 CommentsJump to latest comment

Terry BU's picture

first, you arent the first to have this problem (and you wont be the last).  we talked about it a little in this thread: https://www-secure.symantec.com/connect/forums/drivers-not-working-ghost-suite

second, you have an adventure ahead of you...

Here are 2 links to articles i wrote about setting up a WinPE 3.1 image for Ghost and how to make that work with non-VISTA drivers in GSS

https://www-secure.symantec.com/connect/articles/creating-and-using-winpe31-image-gss-251

https://www-secure.symantec.com/connect/articles/faking-drivers-gss-251-winpe-31

BHays's picture

Your only good options are to upgrade your WinPE or go back to using DOS. This Vista driver problem is only going to get worse so hacking drivers to work with the current PE seems like a waste of time. I went the DOS route for a while and it was fine for small jobs but multicasting a classroom became a nightmare. Things have been very smooth since upgrading to WinPE 5.0.

EM-Pulse's picture

Thanks for your comments guys.  

 

Terry BU I will give your suggestion a go unless BHays can tell me how I upgrade Ghost Solution Suite 2,5 to use WinPE 5.0? 

I've downloaded a trial version of the lateest 2.5 Suite with has Ghost 11.5.1 but the PE looks like 3.1 still to me and the drivers supplied still don't work.

 

Terry BU's picture

its actually very similar!  when i wrote mine, PE5.0 wasnt out yet.  some of the command names are different, and you need the PE image from WADK 8.1, but its not that hard to do the new ones.  you might even need less drivers since PE5.0 would have more built in drivers than 3.1!

EdT's picture

@EM-Pulse

Are you familiar with the concept of a search engine? Our forums have them and you can look at the postings of any individual. So the BHays solution can be found here:

https://www-secure.symantec.com/connect/forums/winpe-30-gss-251

It's actually the second thread below this one at the time of writing.

Hope this helps

EdT

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

EM-Pulse's picture

"Are you familiar with the concept of a search engine?"

Yes I am actually, but it helps to know what you are ****ing looking for!

I will have a look at this https://www-secure.symantec.com/connect/forums/winpe-30-gss-251 but at first glance it looks like I need to fully understand Ghost Console (which I've never used) and have a copy of Windows 8 or Server 2012, neither of which I have to hand.

I have so far spent 3 days on trying to find a way to take a Ghost image of this new laptop, this is absolutely ridiculous!  

I expect for my money an Out of the Box solution from Symantec, not having to spend days on end messing around with templates and startnet.cmd just because Intel have changed a driver.  I'd renew the support package if I knew it would get me anywhere but from what else I've read on this forum that would be a waste of money as well as time.

I'm not a happy bunny!

Thanks for pointing me to the tread EdT looks like I've got swotting on GSS to do.

 

Terry BU's picture

in fairness, if the VISTA driver existed, the GSS Boot wizard would compile it and set the startnet.cmd stuff once you added the driver to the dialog box and selected it.  Though it has a learning curve, and has hit the wall on support, it still is a good tool.  shame they wont update.

EM-Pulse's picture

Well I think I've found the solution to my problem.

 

Using information in this thread: http://www.symantec.com/business/support/index?page=content&id=TECH194877

I created a WinPE_x86 boot CD with Ghost32.exe and the Intel drivers for this laptop (among others) as part of the ISO image.

I have successfully booted the CD connected to my network and taken an image of the laptop.

I am now seeing if I can re-image another PC with it, but I think I'm going in the right direction.

I will update later with any more information, but I thought I would let you know how I'm going on.

Cheers guys.