Video Screencast Help vxdisk: fatal: open failed: No such file or directory

Created: 14 Sep 2013 • Updated: 21 Nov 2013 | 2 comments
Paulo Mota's picture
This issue has been solved. See solution.

Hello Guys,

I need help to solved a problem. I'd like to install VxVM in my Solaris 11 (x86 - Virtual ) to learn and practice many commands to execute on production environment.

I installed this trial package VRTS_SF_HA_Solutions_6.0PR1_Solaris_11_x64.tar.tar . Is it correct ?

More informations:

root@solarisITS:~# cat /etc/*release
                             Oracle Solaris 11.1 X86
  Copyright (c) 1983, 2012, Oracle and/or its affiliates.  All rights reserved.
                           Assembled 19 September 2012
An example of problem:
root@solarisITS:~# vxdisk list vxdisk: fatal: open failed: No such file or directory
root@solarisITS:~# vxassist vxassist: fatal: open failed: No such file or directory
root@solarisITS:~# pkginfo -l |grep VRTS
   PKGINST:  VRTSaslapm
   PKGINST:  VRTSfssdk

 What could I do to solved this problem ?

Thanks a lot!


Operating Systems:

Comments 2 CommentsJump to latest comment

Paulo Mota's picture

Additional information:

root@solarisITS:~# ldd `which vxdisk` |grep "not found" =>  (file not found)
How to install it ?
g_lee's picture

Solaris 11.1 (per your /etc/release) isn't supported with SF6.0PR1 - you need SF6.0.3 per following technote:

TECH202397 Storage Foundation High Availability Solutions (SFHA) installation and upgrade issues concerning Solaris 11.1

Solaris 11.1 (SPARC and x64) is officially supported with SFHA 6.0.3 onwards. Installation of SFHA 6.0.3 requires a pre-installation SFHA 6.0.1. A few potential installation and upgrade issues exist concerning SFHA on Solaris 11.1.

See the technote for issues/considerations to see which scenario applies to your configuration.

Also - refer to the SF6.0.3 release notes & installation guide for further requirements.

If this post has helped you, please vote or mark as solution